xfsprogs: fix compilation with musl 1.2.4
authorTianling Shen <cnsztl@immortalwrt.org>
Wed, 17 May 2023 12:29:40 +0000 (20:29 +0800)
committerNick Hainke <vincent@systemli.org>
Wed, 17 May 2023 13:37:59 +0000 (15:37 +0200)
musl 1.2.4 deprecated legacy "LFS64" ("large file support") interfaces so
just having _GNU_SOURCE defined is not enough anymore.

Manually pass -D_LARGEFILE64_SOURCE to allow to keep using LFS64 definitions.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
utils/xfsprogs/Makefile

index 77cb580667e52335c8a9ad76055f930fe81f036d..71cf38c7ded62567b33435a72b499a1c0f90cf86 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xfsprogs
 PKG_VERSION:=5.9.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs
@@ -67,7 +67,7 @@ CONFIGURE_ARGS += \
        --disable-scrub \
        --disable-libicu
 
-TARGET_CFLAGS += -DHAVE_MAP_SYNC
+TARGET_CFLAGS += -DHAVE_MAP_SYNC $(if (CONFIG_USE_MUSL),-D_LARGEFILE64_SOURCE)
 TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 
 define Package/xfs-admin/install