Merge pull request #1401 from kooiot/master
authorTed Hess <thess@kitschensync.net>
Wed, 17 Jun 2015 16:49:40 +0000 (12:49 -0400)
committerTed Hess <thess@kitschensync.net>
Wed, 17 Jun 2015 16:49:40 +0000 (12:49 -0400)
libzmq upgrade to 4.1.1  lzmq upgrade to 0.4.3

lang/lzmq/Makefile
libs/zmq/Makefile
libs/zmq/patches/disable_pedantic_on_linux_with_ulibc++.patch
libs/zmq/patches/map_with_const_string_with_ublic++.patch [new file with mode: 0644]
libs/zmq/patches/streamoff_missing_with_ulibc++.patch
libs/zmq/patches/tools_gcc_fix.patch [deleted file]

index a62d7e0759263ddaaa8575b12a5504528dcc3719..b17b945d3d35187c264ada5062676d66b659f788 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lzmq
-PKG_VERSION:=0.4.2
-PKG_RELEASE:=2
+PKG_VERSION:=0.4.3
+PKG_RELEASE:=1
 PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
 PKG_LICENSE:=MIT
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://codeload.github.com/zeromq/lzmq/tar.gz/v0.4.2?
-PKG_MD5SUM:=ec9e15bd1495f4c87959fe22a368523d
+PKG_SOURCE_URL:=https://codeload.github.com/zeromq/lzmq/tar.gz/v$(PKG_VERSION)?
+PKG_MD5SUM:=c4e51a60a5a26987bdce59e45d674a9e
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
index 515d6faced003e3cb373f9a6d5417f6a5addbcc1..dd845815a2b20cc8a397be0d0694e6269e08590d 100644 (file)
@@ -10,8 +10,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zeromq
-PKG_VERSION:=4.0.5
-PKG_RELEASE:=2
+PKG_VERSION:=4.1.1
+PKG_RELEASE:=1
 PKG_MAINTAINER:=Dirk Chang <dirk@kooiot.com>
 PKG_LICENSE:=GPL-3.0+
 PKG_LICENSE_FILES:=LICENCE.txt
@@ -58,6 +58,12 @@ CONFIGURE_ARGS += \
        --enable-static \
        --enable-shared
 
+ifneq ($(CONFIG_PACKAGE_libsodium),)
+  CONFIGURE_ARGS+= --with-libsodium
+else
+  CONFIGURE_ARGS+= --without-libsodium
+endif
+
 # add make variable overrides here
 MAKE_FLAGS +=
 
index 9d1f06eb00ff6196d4515c66f8e7db6a1ce1a9c7..74e0091e96726121fe93dc41b2887e51bcac7864 100644 (file)
@@ -1,5 +1,5 @@
---- zeromq-4.0.4_org/configure.ac      2014-06-04 10:19:35.140061796 +0800
-+++ zeromq-4.0.4/configure.ac  2014-06-04 11:08:17.231997926 +0800
+--- a/configure.ac     2014-06-04 10:19:35.140061796 +0800
++++ b/configure.ac     2014-06-04 11:08:17.231997926 +0800
 @@ -127,8 +127,10 @@
      *linux*)
          # Define on Linux to enable all library features. Define if using a gnu compiler
diff --git a/libs/zmq/patches/map_with_const_string_with_ublic++.patch b/libs/zmq/patches/map_with_const_string_with_ublic++.patch
new file mode 100644 (file)
index 0000000..c1a14fc
--- /dev/null
@@ -0,0 +1,41 @@
+--- a/src/metadata.hpp 2015-06-17 21:39:33.629934688 +0800
++++ b/src/metadata.hpp 2014-10-14 22:07:36.000000000 +0800
+@@ -31,7 +31,7 @@
+     {
+         public:
+-            typedef std::map <std::string, const std::string> dict_t;
++            typedef std::map <std::string, std::string> dict_t;
+             metadata_t (const dict_t &dict);
+             virtual ~metadata_t ();
+--- a/src/socket_base.cpp      2015-06-17 21:42:26.289413233 +0800
++++ b/src/socket_base.cpp      2015-06-02 18:31:00.000000000 +0800
+@@ -20,6 +20,7 @@
+ #include <new>
+ #include <string>
+ #include <algorithm>
++#include <ctype.h>
+ #include "platform.hpp"
+--- a/src/stream_engine.cpp    2015-06-17 21:57:29.599443517 +0800
++++ b/src/stream_engine.cpp    2015-06-02 18:31:00.000000000 +0800
+@@ -198,7 +198,7 @@
+             //  Compile metadata.
+             typedef metadata_t::dict_t properties_t;
+             properties_t properties;
+-            properties.insert(std::make_pair("Peer-Address", peer_address));
++            properties.insert(std::make_pair<std::string, std::string>("Peer-Address", peer_address));
+             zmq_assert (metadata == NULL);
+             metadata = new (std::nothrow) metadata_t (properties);
+         }
+@@ -805,7 +805,7 @@
+     //  If we have a peer_address, add it to metadata
+     if (!peer_address.empty()) {
+-        properties.insert(std::make_pair("Peer-Address", peer_address));
++        properties.insert(std::make_pair<std::string, std::string>("Peer-Address", peer_address));
+     }
+     //  Add ZAP properties.
index 543d6ecf3a44eabb018ef902faefe085bef04327..0d1127bdb79b0ca6368d718ce3a86b026cebb1e2 100644 (file)
@@ -1,5 +1,5 @@
---- zeromq-4.0.4_org/src/blob.hpp      2014-06-04 10:19:12.680062287 +0800
-+++ zeromq-4.0.4/src/blob.hpp  2014-06-04 10:30:31.168047457 +0800
+--- a/src/blob.hpp     2014-06-04 10:19:12.680062287 +0800
++++ b/src/blob.hpp     2014-06-04 10:30:31.168047457 +0800
 @@ -21,6 +21,7 @@
  #define __ZMQ_BLOB_HPP_INCLUDED__
  
diff --git a/libs/zmq/patches/tools_gcc_fix.patch b/libs/zmq/patches/tools_gcc_fix.patch
deleted file mode 100644 (file)
index a91e846..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -ruNa zeromq-4.0.4_org/tools/Makefile.am zeromq-4.0.4/tools/Makefile.am
---- zeromq-4.0.4_org/tools/Makefile.am 2014-06-03 20:01:12.392379933 +0800
-+++ zeromq-4.0.4/tools/Makefile.am     2014-06-03 19:59:18.616382420 +0800
-@@ -1,5 +1,5 @@
- EXTRA_DIST = curve_keygen.c 
-+CFLAGS += -std=c99
--
- INCLUDES = -I$(top_srcdir)/include
- bin_PROGRAMS = curve_keygen