ffmpeg: Dependency cleanup
authorTed Hess <thess@kitschensync.net>
Fri, 19 Aug 2016 22:40:41 +0000 (18:40 -0400)
committerTed Hess <thess@kitschensync.net>
Fri, 19 Aug 2016 22:50:29 +0000 (18:50 -0400)
Custom builds need to select x264 and/or lame-lib explictly. Automatic
CONFIG_ALL builds of ffmpeg-full include x264 and lame.

Signed-off-by: Ted Hess <thess@kitschensync.net>
multimedia/ffmpeg/Config.in
multimedia/ffmpeg/Makefile

index e9413b0d20c6cef82d3fc7ea0fe112a40bde7b78..1ba84e3d80acba35a11f4613de7ad66ef23c91c7 100644 (file)
@@ -113,6 +113,7 @@ comment "External Libraries"
 config FFMPEG_CUSTOM_SELECT_mp3lame
        bool "MP3 LAME"
        depends on FFMPEG_CUSTOM_PATENTED
+       depends on PACKAGE_lame-lib
        select FFMPEG_CUSTOM_DECODER_mp3
        select FFMPEG_CUSTOM_MUXER_mp3
        select FFMPEG_CUSTOM_DEMUXER_mp3
@@ -124,8 +125,9 @@ config FFMPEG_CUSTOM_SELECT_speex
        bool "Speex"
 
 config FFMPEG_CUSTOM_SELECT_x264
-       depends on FFMPEG_CUSTOM_PATENTED
        bool "x264"
+       depends on FFMPEG_CUSTOM_PATENTED
+       depends on PACKAGE_libx264
        select FFMPEG_CUSTOM_DECODER_h264
        select FFMPEG_CUSTOM_MUXER_h264
        select FFMPEG_CUSTOM_DEMUXER_h264
index e79f5d630e3f54a41f533092a7853fc21929597f..03fe85ad8d935b692892f5951713bc316b2f8dff 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ffmpeg
 PKG_VERSION:=2.8.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://ffmpeg.org/releases/
@@ -291,7 +291,8 @@ define Package/libffmpeg-custom
 $(call Package/libffmpeg/Default)
  TITLE+= (custom)
  DEPENDS+= +FFMPEG_CUSTOM_SELECT_libopus:libopus +FFMPEG_CUSTOM_SELECT_speex:libspeex \
-           +FFMPEG_CUSTOM_SELECT_x264:libx264 +FFMPEG_CUSTOM_SELECT_mp3lame:lame-lib
+           +PACKAGE_libx264:libx264 +PACKAGE_lame-lib:lame-lib
+
  VARIANT:=custom
  MENU:=1
 endef
@@ -324,7 +325,7 @@ endef
 define Package/libffmpeg-full
 $(call Package/libffmpeg/Default)
  TITLE+= (full)
- DEPENDS+= +alsa-lib +libx264 +lame-lib +libopus +libspeex
+ DEPENDS+= +alsa-lib +PACKAGE_libx264:libx264 +PACKAGE_lame-lib:lame-lib +libopus +libspeex
  VARIANT:=full
 endef
 
@@ -423,8 +424,8 @@ ifeq ($(BUILD_VARIANT),full)
        FFMPEG_CONFIGURE+= \
                --enable-libopus --enable-decoder=libopus \
                --enable-libspeex --enable-decoder=libspeex \
-               --enable-libx264 \
-               --enable-libmp3lame
+               $(if $(CONFIG_PACKAGE_libx264),--enable-libx264) \
+               $(if $(CONFIG_PACKAGE_lame-lib),--enable-libmp3lame)
 endif
 
 ifeq ($(BUILD_VARIANT),custom)
@@ -468,12 +469,12 @@ endif
 
 ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_x264),y)
   FFMPEG_CONFIGURE+= \
-       --enable-libx264 --enable-decoder=libx264
+       --enable-libx264
 endif
 
 ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_mp3lame),y)
   FFMPEG_CONFIGURE+= \
-       --enable-libmp3lame --enable-encoder=mp3
+       --enable-libmp3lame
 endif
 
 endif