Add xinetd package
authorNicolas Thill <nico@openwrt.org>
Sun, 15 May 2005 20:25:32 +0000 (20:25 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 15 May 2005 20:25:32 +0000 (20:25 +0000)
SVN-Revision: 912

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/xinetd/Config.in [new file with mode: 0644]
openwrt/package/xinetd/Makefile [new file with mode: 0644]
openwrt/package/xinetd/files/xinetd.conf [new file with mode: 0644]
openwrt/package/xinetd/files/xinetd.init [new file with mode: 0644]
openwrt/package/xinetd/ipkg/xinetd.conffiles [new file with mode: 0644]
openwrt/package/xinetd/ipkg/xinetd.control [new file with mode: 0644]
openwrt/package/xinetd/patches/ar.patch [new file with mode: 0644]
openwrt/package/xinetd/patches/destdir.patch [new file with mode: 0644]

index 92254826422c0c876636d066939f8b0c8e49994b..55a536d5f28f02357cc99f87fc5274ec43b05db5 100644 (file)
@@ -67,6 +67,7 @@ source "package/siproxd/Config.in"
 source "package/sipsak/Config.in"
 source "package/htpdate/Config.in"
 source "package/howl/Config.in"
+source "package/xinetd/Config.in"
 
 comment "Libraries"
 source "package/libpthread/Config.in"
index 872489fb970983a27a8dc37b2398743f49576fe1..b6f5f809f4cffad66e8276318ab269fa540620b1 100644 (file)
@@ -89,6 +89,7 @@ package-$(BR2_PACKAGE_SIPSAK) += sipsak
 package-$(BR2_PACKAGE_HTPDATE) += htpdate
 package-$(BR2_PACKAGE_HOWL) += howl
 package-$(BR2_PACKAGE_OSIRISD) += osiris
+package-$(BR2_PACKAGE_XINETD) += xinetd
 
 DEV_LIBS:=tcp_wrappers glib ncurses openssl pcre popt zlib libnet libpcap mysql postgresql iptables matrixssl lzo gmp fuse portmap libelf uclibc++ speex libpng libgd
 DEV_LIBS_COMPILE:=$(patsubst %,%-compile,$(DEV_LIBS))
diff --git a/openwrt/package/xinetd/Config.in b/openwrt/package/xinetd/Config.in
new file mode 100644 (file)
index 0000000..13bf0ba
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_XINETD
+       tristate "xinetd - a powerful and secure superserver"
+       default m if CONFIG_DEVEL
+       help
+         A powerful and secure superserver
+         
+         http://www.xinetd.org/
+         
diff --git a/openwrt/package/xinetd/Makefile b/openwrt/package/xinetd/Makefile
new file mode 100644 (file)
index 0000000..71b9cf2
--- /dev/null
@@ -0,0 +1,70 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xinetd
+PKG_VERSION:=2.3.13
+PKG_RELEASE:=1
+PKG_MD5SUM:=4295b5fe12350f09b5892b363348ac8b
+
+PKG_SOURCE_URL:=http://www.xinetd.org/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,XINETD,xinetd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --enable-shared \
+                 --disable-static \
+                 --without-libwrap \
+                 --with-loadavg \
+       );
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       touch $(PKG_BUILD_DIR)/.built
+
+$(IPKG_XINETD):
+       install -d -m0755 $(IDIR_XINETD)/etc
+       install -m0644 ./files/xinetd.conf $(IDIR_XINETD)/etc/xinetd.conf
+       install -d -m0755 $(IDIR_XINETD)/etc/init.d
+       install -m0755 ./files/xinetd.init $(IDIR_XINETD)/etc/init.d/xinetd
+       install -d -m0755 $(IDIR_XINETD)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/xinetd $(IDIR_XINETD)/usr/sbin/
+       $(RSTRIP) $(IDIR_XINETD)
+       $(IPKG_BUILD) $(IDIR_XINETD) $(PACKAGE_DIR)
diff --git a/openwrt/package/xinetd/files/xinetd.conf b/openwrt/package/xinetd/files/xinetd.conf
new file mode 100644 (file)
index 0000000..bd473ed
--- /dev/null
@@ -0,0 +1,6 @@
+defaults
+{
+
+}
+
+includedir /etc/xinetd.d
diff --git a/openwrt/package/xinetd/files/xinetd.init b/openwrt/package/xinetd/files/xinetd.init
new file mode 100644 (file)
index 0000000..2df7a81
--- /dev/null
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+DEFAULT=/etc/default/xinetd
+RUN_D=/var/run
+PID_F=$RUN_D/xinetd.pid
+[ -f $DEFAULT ] && . $DEFAULT
+
+case $1 in
+ start)
+  [ -d $RUN_D ] || mkdir -p $RUN_D
+  xinetd $OPTIONS
+  ;;
+ stop)
+  [ -f $PID_F ] && kill $(cat $PID_F)
+  ;;
+ *)
+  echo "usage: $0 (start|stop)"
+  exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/xinetd/ipkg/xinetd.conffiles b/openwrt/package/xinetd/ipkg/xinetd.conffiles
new file mode 100644 (file)
index 0000000..f49d840
--- /dev/null
@@ -0,0 +1 @@
+/etc/xinetd.conf
diff --git a/openwrt/package/xinetd/ipkg/xinetd.control b/openwrt/package/xinetd/ipkg/xinetd.control
new file mode 100644 (file)
index 0000000..73c3dd7
--- /dev/null
@@ -0,0 +1,8 @@
+Package: xinetd
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/xinetd/
+Description: a powerful and secure superserver
diff --git a/openwrt/package/xinetd/patches/ar.patch b/openwrt/package/xinetd/patches/ar.patch
new file mode 100644 (file)
index 0000000..f0d4f0d
--- /dev/null
@@ -0,0 +1,72 @@
+diff -ruN xinetd-2.3.13-orig/libs/src/misc/Makefile.in xinetd-2.3.13-6/libs/src/misc/Makefile.in
+--- xinetd-2.3.13-orig/libs/src/misc/Makefile.in       2003-02-19 18:29:27.000000000 +0100
++++ xinetd-2.3.13-6/libs/src/misc/Makefile.in  2005-03-09 22:53:15.000000000 +0100
+@@ -62,7 +62,7 @@
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ install: $(LIBNAME)
+diff -ruN xinetd-2.3.13-orig/libs/src/portable/Makefile.in xinetd-2.3.13-6/libs/src/portable/Makefile.in
+--- xinetd-2.3.13-orig/libs/src/portable/Makefile.in   2003-02-19 18:29:27.000000000 +0100
++++ xinetd-2.3.13-6/libs/src/portable/Makefile.in      2005-03-09 22:53:15.000000000 +0100
+@@ -57,7 +57,7 @@
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ install: $(LIBNAME)
+diff -ruN xinetd-2.3.13-orig/libs/src/pset/Makefile.in xinetd-2.3.13-6/libs/src/pset/Makefile.in
+--- xinetd-2.3.13-orig/libs/src/pset/Makefile.in       2003-02-19 18:29:27.000000000 +0100
++++ xinetd-2.3.13-6/libs/src/pset/Makefile.in  2005-03-09 22:53:15.000000000 +0100
+@@ -53,7 +53,7 @@
+       mv $(LIBNAME) $(LIBDIR)/optimized
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ install: $(LIBNAME)
+diff -ruN xinetd-2.3.13-orig/libs/src/sio/Makefile.in xinetd-2.3.13-6/libs/src/sio/Makefile.in
+--- xinetd-2.3.13-orig/libs/src/sio/Makefile.in        2003-02-19 18:29:27.000000000 +0100
++++ xinetd-2.3.13-6/libs/src/sio/Makefile.in   2005-03-09 22:53:15.000000000 +0100
+@@ -52,7 +52,7 @@
+       $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ install: $(LIBNAME)
+diff -ruN xinetd-2.3.13-orig/libs/src/str/Makefile.in xinetd-2.3.13-6/libs/src/str/Makefile.in
+--- xinetd-2.3.13-orig/libs/src/str/Makefile.in        2003-02-19 18:29:27.000000000 +0100
++++ xinetd-2.3.13-6/libs/src/str/Makefile.in   2005-03-09 22:53:15.000000000 +0100
+@@ -63,7 +63,7 @@
+       $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)-O
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ LINT_IGNORE=possible pointer alignment|RCSid unused
+diff -ruN xinetd-2.3.13-orig/libs/src/xlog/Makefile.in xinetd-2.3.13-6/libs/src/xlog/Makefile.in
+--- xinetd-2.3.13-orig/libs/src/xlog/Makefile.in       2003-02-19 18:29:27.000000000 +0100
++++ xinetd-2.3.13-6/libs/src/xlog/Makefile.in  2005-03-09 22:53:15.000000000 +0100
+@@ -58,7 +58,7 @@
+       $(INSTALL) $(FMODE) $(LIBNAME) $(LIBDIR)/optimized
+ $(LIBNAME): $(OBJECTS)
+-      ar r $@ $?
++      $(AR) r $@ $?
+       $(RANLIB) $@
+ install: $(LIBNAME)
diff --git a/openwrt/package/xinetd/patches/destdir.patch b/openwrt/package/xinetd/patches/destdir.patch
new file mode 100644 (file)
index 0000000..91fd816
--- /dev/null
@@ -0,0 +1,28 @@
+diff -ruN xinetd-2.3.13-orig/Makefile.in xinetd-2.3.13-6/Makefile.in
+--- xinetd-2.3.13-orig/Makefile.in     2003-08-15 16:00:45.000000000 +0200
++++ xinetd-2.3.13-6/Makefile.in        2005-03-09 22:53:15.000000000 +0100
+@@ -75,15 +75,15 @@
+ install: build
+       for i in $(DAEMONDIR) $(BINDIR) $(MANDIR)/man5 $(MANDIR)/man8 ; do \
+-         test -d $$i || mkdir -p $$i ; done
+-      $(INSTALL_CMD) -m 755 xinetd/xinetd $(DAEMONDIR)
+-      $(INSTALL_CMD) -m 755 xinetd/itox $(DAEMONDIR)
+-      $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DAEMONDIR)
+-      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(MANDIR)/man5/xinetd.conf.5
+-      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(MANDIR)/man8/xinetd.log.8
+-      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(MANDIR)/man8/xinetd.8
+-      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(MANDIR)/man8/itox.8
+-      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(MANDIR)/man8/xconv.pl.8
++         test -d $(DESTDIR)$$i || mkdir -p $(DESTDIR)$$i ; done
++      $(INSTALL_CMD) -m 755 xinetd/xinetd $(DESTDIR)$(DAEMONDIR)
++      $(INSTALL_CMD) -m 755 xinetd/itox $(DESTDIR)$(DAEMONDIR)
++      $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DESTDIR)$(DAEMONDIR)
++      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(DESTDIR)$(MANDIR)/man5/xinetd.conf.5
++      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(DESTDIR)$(MANDIR)/man8/xinetd.log.8
++      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(DESTDIR)$(MANDIR)/man8/xinetd.8
++      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(DESTDIR)$(MANDIR)/man8/itox.8
++      $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(DESTDIR)$(MANDIR)/man8/xconv.pl.8
+       @echo "You must put your xinetd.conf in /etc/xinetd.conf"
+       @echo "There is a sample config file in xinetd/sample.conf and you can"
+       @echo "use xconv.pl to convert your old inetd.conf file to an xinetd format"