python3: sync changes from python
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Fri, 6 Jan 2017 15:05:27 +0000 (17:05 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Thu, 19 Jan 2017 16:15:12 +0000 (18:15 +0200)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python3/Makefile
lang/python3/files/python3-host.mk
lang/python3/patches/005-fix-libffi-x86-64-configure.patch [deleted file]
lang/python3/patches/011-do-not-prefer-ncursesw.patch [deleted file]

index aa758b56305613feb13a46b3dac6ff7f66444953..81e6679f8c8f4e63dc73243ec8b8b7541355c11c 100644 (file)
@@ -14,7 +14,7 @@ PYTHON_VERSION:=$(PYTHON3_VERSION)
 PYTHON_VERSION_MICRO:=$(PYTHON3_VERSION_MICRO)
 
 PKG_NAME:=python3
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
@@ -117,10 +117,6 @@ MAKE_FLAGS+=\
        LD="$(TARGET_CC)" \
        PGEN=pgen3
 
-ifeq ($(ARCH),i386)
-MAKE_FLAGS+=PYTHON_DECIMAL_WITH_MACHINE=ansi32
-endif
-
 EXTRA_CFLAGS+= \
        -DNDEBUG -fno-inline
 EXTRA_LDFLAGS+= \
@@ -231,6 +227,9 @@ define Py3Package/python3/filespec
 -|$(PYTHON3_PKG_DIR)
 endef
 
+HOST_LDFLAGS += \
+       $$$$(pkg-config --static --libs libcrypto libssl)
+
 HOST_CONFIGURE_ARGS+= \
        --without-cxx-main \
        --without-pymalloc \
@@ -238,14 +237,13 @@ HOST_CONFIGURE_ARGS+= \
        --prefix=$(HOST_PYTHON3_DIR) \
        --exec-prefix=$(HOST_PYTHON3_DIR) \
        --with-system-expat=$(STAGING_DIR_HOSTPKG) \
-       --with-system-ffi \
+       --with-system-ffi=no \
        --with-ensurepip=no \
-       CONFIG_SITE= \
-       CFLAGS="$(HOST_CFLAGS)"
+       CONFIG_SITE=
 
 define Host/Compile
-       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) python Parser/pgen
-       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) sharedmods
+       +$(HOST_MAKE_VARS) $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) python Parser/pgen
+       +$(HOST_MAKE_VARS) $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) sharedmods
 endef
 
 define Host/Install
index 8ff6dd789a23d7446883ed38dac8eb77478ec3f2..3abf6aa5f88ab755415dd434c65e1f5c52e3ee39 100644 (file)
@@ -78,13 +78,4 @@ define HostPy3/Compile/Default
        )
 endef
 
-ifeq ($(BUILD_VARIANT),python3)
-define Host/Compile
-       $(call HostPy3/Compile/Default)
-endef
-
-define Host/Install
-endef
-endif # python3
-
 endif # __python3_host_mk_inc
diff --git a/lang/python3/patches/005-fix-libffi-x86-64-configure.patch b/lang/python3/patches/005-fix-libffi-x86-64-configure.patch
deleted file mode 100644 (file)
index ea062a3..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/Modules/_ctypes/libffi/configure b/Modules/_ctypes/libffi/configure
-index 75f62a7..4d6c9f2 100755
---- a/Modules/_ctypes/libffi/configure
-+++ b/Modules/_ctypes/libffi/configure
-@@ -17257,20 +17257,12 @@ case "$host" in
-       fi
-       ;;
--  i?86-*-* | x86_64-*-*)
--      TARGETDIR=x86
--      if test $ac_cv_sizeof_size_t = 4; then
--        case "$host" in
--          *-gnux32)
--            TARGET=X86_64
--            ;;
--          *)
--            TARGET=X86
--            ;;
--          esac
--      else
--        TARGET=X86_64;
--      fi
-+  i?86-*-*)
-+      TARGET=X86; TARGETDIR=x86
-+      ;;
-+
-+  x86_64-*-*)
-+      TARGET=X86_64; TARGETDIR=x86
-       ;;
-   ia64*-*-*)
diff --git a/lang/python3/patches/011-do-not-prefer-ncursesw.patch b/lang/python3/patches/011-do-not-prefer-ncursesw.patch
deleted file mode 100644 (file)
index c023225..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 2779658..b6d3d61 100644
---- a/setup.py
-+++ b/setup.py
-@@ -693,8 +693,8 @@ class PyBuildExt(build_ext):
-         # use the same library for the readline and curses modules.
-         if 'curses' in readline_termcap_library:
-             curses_library = readline_termcap_library
--        elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
--            curses_library = 'ncursesw'
-+        #elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
-+        #    curses_library = 'ncursesw'
-         elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
-             curses_library = 'ncurses'
-         elif self.compiler.find_library_file(lib_dirs, 'curses'):