Merge pull request #18055 from pprindeville/bind-subpackage-ddns-confgen
authorPhilip Prindeville <philipp@redfish-solutions.com>
Thu, 24 Mar 2022 00:14:33 +0000 (18:14 -0600)
committerGitHub <noreply@github.com>
Thu, 24 Mar 2022 00:14:33 +0000 (18:14 -0600)
bind: add subpackaging for ddns-confgen

net/bind/Makefile

index f6065d49f472934abca4c2abcc704784d5d71ef4..2e7b6bc197e4eb48997fdbba8b0bccf4a59953e8 100644 (file)
@@ -97,7 +97,8 @@ define Package/bind-tools
        +bind-nslookup \
        +bind-dnssec \
        +bind-host \
-       +bind-rndc
+       +bind-rndc \
+       +bind-ddns-confgen
 endef
 
 define Package/bind-rndc
@@ -132,6 +133,11 @@ define Package/bind-nslookup
          200:/usr/bin/nslookup:/usr/libexec/nslookup-bind
 endef
 
+define Package/bind-ddns-confgen
+  $(call Package/bind/Default)
+  TITLE+= administration tools (ddns-confgen and tsig-keygen only)
+endef
+
 export BUILD_CC="$(TARGET_CC)"
 
 TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
@@ -266,6 +272,12 @@ define Package/bind-nslookup/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/nslookup $(1)/usr/libexec/nslookup-bind
 endef
 
+define Package/bind-ddns-confgen/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ddns-confgen $(1)/usr/sbin/ddns-confgen
+       $(LN) -s ddns-confgen $(1)/usr/sbin/tsig-keygen
+endef
+
 $(eval $(call BuildPackage,bind-libs))
 $(eval $(call BuildPackage,bind-server))
 $(eval $(call BuildPackage,bind-server-filter-aaaa))
@@ -277,3 +289,4 @@ $(eval $(call BuildPackage,bind-dnssec))
 $(eval $(call BuildPackage,bind-host))
 $(eval $(call BuildPackage,bind-dig))
 $(eval $(call BuildPackage,bind-nslookup))
+$(eval $(call BuildPackage,bind-ddns-confgen))