totem-pl-parser: new package
authorW. Michael Petullo <mike@flyn.org>
Sun, 13 Feb 2022 04:55:42 +0000 (22:55 -0600)
committerRosen Penev <rosenp@gmail.com>
Wed, 16 Feb 2022 00:42:44 +0000 (16:42 -0800)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
libs/totem-pl-parser/Makefile [new file with mode: 0644]
libs/totem-pl-parser/patches/totem-pl-parser-3.26.6-initialize.patch [new file with mode: 0644]

diff --git a/libs/totem-pl-parser/Makefile b/libs/totem-pl-parser/Makefile
new file mode 100644 (file)
index 0000000..1808b04
--- /dev/null
@@ -0,0 +1,63 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=totem-pl-parser
+PKG_VERSION:=3.26.6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=totem-pl-parser-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://download.gnome.org/sources/totem-pl-parser/3.26/
+PKG_HASH:=c0df0f68d5cf9d7da43c81c7f13f11158358368f98c22d47722f3bd04bd3ac1c
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+PKG_LICENSE:=LGPL-2-or-later
+PKG_LICENSE_FILES:=COPYING.LIB
+
+PKG_INSTALL:=1
+PKG_BUILD_DEPENDS:=glib2/host
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+include $(INCLUDE_DIR)/meson.mk
+
+define Package/totem-pl-parser
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+glib2 +libxml2
+  TITLE:=totem-pl-parser
+  URL:=https://gitlab.gnome.org/GNOME/totem-pl-parser
+endef
+
+define Package/totem-pl-parser/decription
+  totem-pl-parser is a simple GObject-based library to parse a host of playlist formats
+endef
+
+MESON_ARGS += -Dintrospection=false
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/totem-pl-parser/ \
+               $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+               $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
+               $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/totem-pl-parser/install
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+               $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,totem-pl-parser))
diff --git a/libs/totem-pl-parser/patches/totem-pl-parser-3.26.6-initialize.patch b/libs/totem-pl-parser/patches/totem-pl-parser-3.26.6-initialize.patch
new file mode 100644 (file)
index 0000000..29d7e77
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/plparse/totem-pl-parser.c
++++ b/plparse/totem-pl-parser.c
+@@ -1760,7 +1760,7 @@ totem_pl_parser_glob_is_ignored (TotemPl
+ {
+       GHashTableIter iter;
+       gpointer key;
+-      int ret;
++      int ret = -1;
+       g_mutex_lock (&parser->priv->ignore_mutex);
+       g_hash_table_iter_init (&iter, parser->priv->ignore_globs);