ocserv: don't build with libseccomp on ARC
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Tue, 13 Apr 2021 11:25:55 +0000 (08:25 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Thu, 15 Apr 2021 01:52:42 +0000 (22:52 -0300)
libseccomp can't be built on ARC, so we must disable the option here as
well.  A different fix was first proposed by @zxlhhyccc in #15377.

Fixes: #15313
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
net/ocserv/Config.in
net/ocserv/Makefile

index b6460cd8ee6b3c70f59742c37d51de8c6669a8e5..cf86bef172f907d2cd443c121ba6e3f7860a62c1 100644 (file)
@@ -9,6 +9,7 @@ config OCSERV_PAM
 
 config OCSERV_SECCOMP
        bool "enable seccomp"
+       depends on !arc
        default n
 
 config OCSERV_RADIUS
index ed05a3a554801a9a5ff921e81ae3db2fbbc21fb0..4431d9d3ca5d6de6e3f5209d0cd426006c3807eb 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ocserv
 PKG_VERSION:=1.1.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 
 PKG_BUILD_DIR :=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)