freeswitch: allow building with OpenSSL 3.0 809/head
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Thu, 9 Feb 2023 18:32:06 +0000 (15:32 -0300)
committerSebastian Kemper <sebastian_ml@gmx.net>
Tue, 11 Apr 2023 19:07:59 +0000 (21:07 +0200)
Add -Wno-error=deprecated-declarations to CFLAGS to allow usage of
deprecated API.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
(cherry picked from commit 09ad78b6cce247f4e610be006d89dfe70003aa58)

net/freeswitch/Makefile

index 799ccb02b52d0d449d33a77a4d24937d0c420e2b..62896f47903602ef8b98821910fa99d0c0c27658 100644 (file)
@@ -237,6 +237,9 @@ FS_PERL_FEED:=$(TOPDIR)/feeds/packages/lang/perl
 include $(TOPDIR)/feeds/packages/lang/python/python3-version.mk
 include $(FS_PERL_FEED)/perlver.mk
 
+# Allow compiling with OpenSSL 3.0
+TARGET_CFLAGS+=-Wno-error=deprecated-declarations
+
 PERL_SITELIB:=/usr/lib/perl$(PERL_MAJOR)/$(PERL_VERSION2)
 
 FS_PERL_LIBS:=$(shell grep "^libs=" \