[packages] usb-modeswitch: wait a second before retrying modeswitching, this reported...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 4 Jul 2012 12:02:23 +0000 (12:02 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 4 Jul 2012 12:02:23 +0000 (12:02 +0000)
SVN-Revision: 32602

utils/usb-modeswitch/Makefile
utils/usb-modeswitch/files/modeswitch.hotplug

index e2c4939b7dc9b3d6a76ea4ef8274a09ba6710409..ade1a012e3a6c58d661717245d45df230255c53c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usb-modeswitch
 PKG_VERSION:=1.2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.draisberghof.de/usb_modeswitch
index 33137d42f7e13ee8d4851f2a7422e2bb01a08923..eb71b3056a5801a15290ec85e2dfed7b1338a18b 100644 (file)
@@ -123,12 +123,13 @@ if [ "$ACTION" = add ]; then
                        # ugly workaround, but working for all hw we got for testing
                        switching_done=0
                        switching_tries=0
-                       local usb_dir="/sys/$DEVPATH"       
+                       local usb_dir="/sys/$DEVPATH"
                        [ -f "$usb_dir/idVendor" ] || usb_dir="${usb_dir%/*}"
                        while [ $switching_done -lt 1 -a $switching_tries -le 6 ]; do
                                $modeswitch -v $uVid -p $uPid -I -D -n -s 30 -c "${configs%% *}"
                                if [ $(sanitize "$usb_dir/idProduct") = $uPid ]; then
-                                       log "switching seemingly failed"
+                                       log "$DEVICENAME: Switching seemingly failed"
+                                       sleep 1
                                else
                                        switching_done=1
                                fi