transmission: add copy_file_range syscall to seccomp
authorMarius Dinu <m95d+git@psihoexpert.ro>
Sun, 23 Jul 2023 17:36:02 +0000 (20:36 +0300)
committerRosen Penev <rosenp@gmail.com>
Tue, 25 Jul 2023 05:44:32 +0000 (22:44 -0700)
Fixes this crash:

root@RPi3OpenWrt:/# grep -i seccomp /var/log/audit/audit.log
type=SECCOMP msg=audit(1689503903.597:16): auid=4294967295 uid=224 gid=1012 ses=4294967295 pid=1752 comm="transmission-da" exe="/usr/bin/transmission-daemon" sig=31 arch=c00000b7 syscall=285 compat=0 ip=0x7fa3b0eefc code=0x80000000
root@RPi3OpenWrt:/# ausyscall 285
copy_file_range
root@RPi3OpenWrt:/#

Signed-off-by: Marius Dinu <m95d+git@psihoexpert.ro>
net/transmission/Makefile
net/transmission/files/transmission-daemon.json

index b5f378a6c72cecdb17f318a065c3c3843e2e9737..703b1db6e89aa5d349026864ed0d289c91abca59 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
 PKG_VERSION:=4.0.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/transmission/transmission/releases/download/$(PKG_VERSION)/
index 6d9fa1face64bcbb3924a3cf1e021dbaaee27347..d4125103daee94c71f1b5abf829f118b43ccc51d 100644 (file)
@@ -14,6 +14,7 @@
                                "clone",
                                "close",
                                "connect",
+                               "copy_file_range",
                                "epoll_create1",
                                "epoll_ctl",
                                "epoll_pwait",