Introduce ARM SiP service
authordp-arm <dimitris.papastamos@arm.com>
Mon, 19 Sep 2016 10:21:03 +0000 (11:21 +0100)
committerdp-arm <dimitris.papastamos@arm.com>
Wed, 12 Oct 2016 14:36:45 +0000 (15:36 +0100)
This patch adds ARM SiP service for use by ARM standard platforms.
This service is added to support the SMC interface for the Performance
measurement framework(PMF).

Change-Id: I26f5712f9ab54f5f721dd4781e35a16f40aacc44
Signed-off-by: dp-arm <dimitris.papastamos@arm.com>
include/plat/arm/common/arm_sip_svc.h [new file with mode: 0644]
plat/arm/common/arm_common.mk
plat/arm/common/arm_sip_svc.c [new file with mode: 0644]

diff --git a/include/plat/arm/common/arm_sip_svc.h b/include/plat/arm/common/arm_sip_svc.h
new file mode 100644 (file)
index 0000000..640bbaf
--- /dev/null
@@ -0,0 +1,45 @@
+/*
+ * Copyright (c) 2016, ARM Limited and Contributors. All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
+ *
+ * Redistributions of source code must retain the above copyright notice, this
+ * list of conditions and the following disclaimer.
+ *
+ * Redistributions in binary form must reproduce the above copyright notice,
+ * this list of conditions and the following disclaimer in the documentation
+ * and/or other materials provided with the distribution.
+ *
+ * Neither the name of ARM nor the names of its contributors may be used
+ * to endorse or promote products derived from this software without specific
+ * prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+ * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+ * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#ifndef __ARM_SIP_SVC_H__
+#define __ARM_SIP_SVC_H__
+
+/* SMC function IDs for SiP Service queries */
+
+#define ARM_SIP_SVC_CALL_COUNT         0x8200ff00
+#define ARM_SIP_SVC_UID                        0x8200ff01
+/*                                     0x8200ff02 is reserved */
+#define ARM_SIP_SVC_VERSION            0x8200ff03
+
+/* ARM SiP Service Calls version numbers */
+#define ARM_SIP_SVC_VERSION_MAJOR              0x0
+#define ARM_SIP_SVC_VERSION_MINOR              0x1
+
+#endif /* __ARM_SIP_SVC_H__ */
index 98d72192c03a74fbd8ee9c31bef9f2764a961f89..8f8d3fd8b3ddd596c0c167a2e83a6c01a2801ddd 100644 (file)
@@ -144,6 +144,11 @@ BL31_SOURCES               +=      plat/arm/common/arm_bl31_setup.c                \
                                plat/common/aarch64/platform_mp_stack.S         \
                                plat/common/plat_psci_common.c
 
+ifeq (${ENABLE_PMF}, 1)
+BL31_SOURCES           +=      plat/arm/common/arm_sip_svc.c                   \
+                               lib/pmf/pmf_smc.c
+endif
+
 ifneq (${TRUSTED_BOARD_BOOT},0)
 
     # By default, ARM platforms use RSA keys
diff --git a/plat/arm/common/arm_sip_svc.c b/plat/arm/common/arm_sip_svc.c
new file mode 100644 (file)
index 0000000..eb8ec9e
--- /dev/null
@@ -0,0 +1,104 @@
+/*
+ * Copyright (c) 2016, ARM Limited and Contributors. All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions are met:
+ *
+ * Redistributions of source code must retain the above copyright notice, this
+ * list of conditions and the following disclaimer.
+ *
+ * Redistributions in binary form must reproduce the above copyright notice,
+ * this list of conditions and the following disclaimer in the documentation
+ * and/or other materials provided with the distribution.
+ *
+ * Neither the name of ARM nor the names of its contributors may be used
+ * to endorse or promote products derived from this software without specific
+ * prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+ * AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+ * LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
+
+#include <arm_sip_svc.h>
+#include <debug.h>
+#include <pmf.h>
+#include <runtime_svc.h>
+#include <stdint.h>
+#include <uuid.h>
+
+
+/* ARM SiP Service UUID */
+DEFINE_SVC_UUID(arm_sip_svc_uid,
+               0xe2756d55, 0x3360, 0x4bb5, 0xbf, 0xf3,
+               0x62, 0x79, 0xfd, 0x11, 0x37, 0xff);
+
+static int arm_sip_setup(void)
+{
+       if (pmf_setup() != 0)
+               return 1;
+       return 0;
+}
+
+/*
+ * This function handles ARM defined SiP Calls
+ */
+static uintptr_t arm_sip_handler(unsigned int smc_fid,
+                       u_register_t x1,
+                       u_register_t x2,
+                       u_register_t x3,
+                       u_register_t x4,
+                       void *cookie,
+                       void *handle,
+                       u_register_t flags)
+{
+       /*
+        * Dispatch PMF calls to PMF SMC handler and return its return
+        * value
+        */
+       if (is_pmf_fid(smc_fid)) {
+               return pmf_smc_handler(smc_fid, x1, x2, x3, x4, cookie,
+                               handle, flags);
+       }
+
+       switch (smc_fid) {
+       case ARM_SIP_SVC_CALL_COUNT:
+               /*
+                * Return the number of SiP Service Calls. PMF is the only
+                * SiP service implemented; so return number of PMF calls
+                */
+               SMC_RET1(handle, PMF_NUM_SMC_CALLS);
+
+       case ARM_SIP_SVC_UID:
+               /* Return UID to the caller */
+               SMC_UUID_RET(handle, arm_sip_svc_uid);
+
+       case ARM_SIP_SVC_VERSION:
+               /* Return the version of current implementation */
+               SMC_RET2(handle, ARM_SIP_SVC_VERSION_MAJOR, ARM_SIP_SVC_VERSION_MINOR);
+
+       default:
+               WARN("Unimplemented ARM SiP Service Call: 0x%x \n", smc_fid);
+               SMC_RET1(handle, SMC_UNK);
+       }
+
+}
+
+
+/* Define a runtime service descriptor for fast SMC calls */
+DECLARE_RT_SVC(
+       arm_sip_svc,
+       OEN_SIP_START,
+       OEN_SIP_END,
+       SMC_TYPE_FAST,
+       arm_sip_setup,
+       arm_sip_handler
+);