remove sysconf
authorMike Baker <mbm@openwrt.org>
Mon, 20 Mar 2006 02:18:17 +0000 (02:18 +0000)
committerMike Baker <mbm@openwrt.org>
Mon, 20 Mar 2006 02:18:17 +0000 (02:18 +0000)
SVN-Revision: 3416

openwrt/package/Config.in
openwrt/package/Sysconf.in [deleted file]
openwrt/package/base-files/Makefile
openwrt/package/base-files/default/bin/login

index b7779159769779e23b927a150079fa58f7d38951..584d2aa4a2bb6bc7681c4345cfdddbd7b0823d1f 100644 (file)
@@ -151,6 +151,3 @@ config BR2_PACKAGE_IMAGEBUILDER
          Useful for building images with custom scripts or extra packages.
 
 endmenu
-
-source "package/Sysconf.in"
-
diff --git a/openwrt/package/Sysconf.in b/openwrt/package/Sysconf.in
deleted file mode 100644 (file)
index 6c0cac3..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-#
-
-menu "Runtime Configuration"
-       choice
-               bool "Telnet access"
-               default BR2_SYSCONF_TELNET_FAILSAFE_ONLY
-               
-               config BR2_SYSCONF_TELNET_FAILSAFE_ONLY
-                       bool "open, failsafe only"
-
-               config BR2_SYSCONF_TELNET_OPEN
-                       bool "open"
-
-       endchoice
-       
-       menu "Failsafe configuration"
-       
-               config BR2_SYSCONF_FAILSAFE_IP
-                       string "IP Address"
-                       default "192.168.1.1"
-               
-               config BR2_SYSCONF_FAILSAFE_NETMASK
-                       string "Netmask"
-                       default "255.255.255.0"
-
-               config BR2_SYSCONF_FAILSAFE_MAC
-                       string "MAC Address"
-                       default "00:00:BA:DC:0D:ED"
-
-       endmenu
-endmenu
index a9426a6dcb06149edd64d27d4cfa73ee281e7826..dcd6aa0d546e614e943776584ff0288fd66586ec 100644 (file)
@@ -56,7 +56,6 @@ $(IPKG_BASE):
        -find $(IDIR_BASE) -type d -name CVS | xargs rm -rf
        -find $(IDIR_BASE) -type d -name .svn | xargs rm -rf
        -find $(IDIR_BASE) -name '.#*' | xargs rm -f
-       -grep \^BR2_SYSCONF $(TOPDIR)/.config > $(IDIR_BASE)/etc/sysconf
        $(IPKG_BUILD) $(IDIR_BASE) $(PACKAGE_DIR)
 
 $(IPKG_LIBC):
index bb065e54a1bfcec7e6a5e1f7fdb7eaba2dd08c1a..e6479c10d315fd0ca69cc488c6bfaad61ec37155 100755 (executable)
@@ -2,7 +2,6 @@
 . /etc/sysconf 2>&-
 
 [ "$FAILSAFE" != "true" ] &&
-[ "$BR2_SYSCONF_TELNET_FAILSAFE_ONLY" = "y" ] &&
 {
   grep '^root:[^!]' /etc/passwd >&- 2>&- &&
   {