kernel: bump 4.19 to 4.19.25
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 25 Feb 2019 10:38:50 +0000 (11:38 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 25 Feb 2019 16:33:16 +0000 (17:33 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.19/721-phy_packets.patch
target/linux/generic/pending-4.19/630-packet_socket_type.patch

index f2fa4ab57f4e9a0ed679d098da4571e3f06b5b90..5f3dbf23bf98a24d2ffd5dfbbb7e9c8ba3e0337f 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .136
 LINUX_VERSION-4.9 = .160
 LINUX_VERSION-4.14 = .103
-LINUX_VERSION-4.19 = .24
+LINUX_VERSION-4.19 = .25
 
 LINUX_KERNEL_HASH-3.18.136 = 48c8775013d23229462134f911bbb14c7935096fcccfb19ce28ecd5f7154f35c
 LINUX_KERNEL_HASH-4.9.160 = c09af067af62d299f5e33c279968de58c88fb7c59bd05e8f3bb460f611f60515
 LINUX_KERNEL_HASH-4.14.103 = 7aa43e34e4c9e5965da29cef5ae196e06006f8c0d1d65fd755a2f197f0796a11
-LINUX_KERNEL_HASH-4.19.24 = 3bb1885fabd874b469a8ea19571c5a4ad5b6faa3cca1662137c57b40fcbf8e04
+LINUX_KERNEL_HASH-4.19.25 = 7ec71d90d6e96e6f741676d157ac06f30c75be4eaf1649143a3c8b7d4f919731
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 8267eadac8401eb900b25cfdc955b998362c309c..421afbca1834140995356d46b3f4cdbb4ace3e7d 100644 (file)
@@ -136,7 +136,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  #include <net/protocol.h>
  #include <net/dst.h>
-@@ -499,6 +500,22 @@ skb_fail:
+@@ -503,6 +504,22 @@ skb_fail:
  }
  EXPORT_SYMBOL(__napi_alloc_skb);
  
index 273e7ff0a8e8d3ce528cbd6a936358b91dff978e..a0d177586a6c19bc8e1212b500213423390038e1 100644 (file)
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3232,6 +3234,7 @@ static int packet_create(struct net *net
+@@ -3233,6 +3235,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3843,6 +3846,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3844,6 +3847,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3895,6 +3908,13 @@ static int packet_getsockopt(struct sock
+@@ -3896,6 +3909,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;