Merge pull request #14510 from zhanhb/ddns-scripts
authorFlorian Eckert <fe@dev.tdt.de>
Fri, 22 Jan 2021 08:09:48 +0000 (09:09 +0100)
committerGitHub <noreply@github.com>
Fri, 22 Jan 2021 08:09:48 +0000 (09:09 +0100)
ddns-scripts: fix wget-ssl path

net/ddns-scripts/Makefile
net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh

index d3744c87132df76940eb0a5edd087a8cfc63afa7..04a7e8c8f38da7f140c4539ad47a3f5fa15c5981 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ddns-scripts
 PKG_VERSION:=2.8.2
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_LICENSE:=GPL-2.0
 
index eeb212ec1a2f1240b1f9fa7dceebad4c1cc9c0f1..141547f306ea46493df8eb9e935e4bb8ac62bd23 100644 (file)
@@ -85,7 +85,8 @@ NSLOOKUP=$(command -v nslookup)
 
 # Transfer Programs
 WGET=$(command -v wget)
-WGET_SSL=$(command -v wget-ssl)
+# SSL support is available if WGET_SSL is not empty
+WGET_SSL=$("$WGET" -V 2>/dev/null | grep -F +https)
 
 CURL=$(command -v curl)
 # CURL_SSL not empty then SSL support available
@@ -711,8 +712,8 @@ do_transfer() {
        [ -z "$bind_network" ] && [ "$ip_source" = "network" ] && [ "$ip_network" ] && bind_network="$ip_network"
 
        # lets prefer GNU Wget because it does all for us - IPv4/IPv6/HTTPS/PROXY/force IP version
-       if [ -n "$WGET_SSL" -a $USE_CURL -eq 0 ]; then                  # except global option use_curl is set to "1"
-               __PROG="$WGET_SSL --hsts-file=/tmp/.wget-hsts -nv -t 1 -O $DATFILE -o $ERRFILE" # non_verbose no_retry outfile errfile
+       if [ -n "$WGET_SSL" ] && [ $USE_CURL -eq 0 ]; then                      # except global option use_curl is set to "1"
+               __PROG="$WGET --hsts-file=/tmp/.wget-hsts -nv -t 1 -O $DATFILE -o $ERRFILE"     # non_verbose no_retry outfile errfile
                # force network/ip to use for communication
                if [ -n "$bind_network" ]; then
                        local __BINDIP