grilo: add new package 1812/head
authorW. Michael Petullo <mike@flyn.org>
Sun, 27 Sep 2015 00:45:14 +0000 (20:45 -0400)
committerW. Michael Petullo <mike@flyn.org>
Sun, 27 Sep 2015 00:45:14 +0000 (20:45 -0400)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
multimedia/grilo/Makefile [new file with mode: 0644]

diff --git a/multimedia/grilo/Makefile b/multimedia/grilo/Makefile
new file mode 100644 (file)
index 0000000..473344a
--- /dev/null
@@ -0,0 +1,68 @@
+#
+# Copyright (C) 2009-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=grilo
+PKG_VERSION:=0.2.14
+PKG_RELEASE:=1
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_LICENSE:=LGPLv2.1
+PKG_LICENSE_FILES:=COPYING
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://download.gnome.org/sources/grilo/0.2/
+PKG_MD5SUM:=7eba405ada20fefcb877d534d9d4f
+
+PKG_BUILD_DEPENDS:=glib2 libsoup libxml2
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+TARGET_LDFLAGS+= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/grilo
+  SECTION:=multimedia
+  CATEGORY:=Multimedia
+  TITLE:=grilo
+  URL:=https://wiki.gnome.org/Projects/Grilo
+  DEPENDS:=+glib2 +libsoup +libxml2
+endef
+
+define Package/grilo/decription
+  Grilo is a framework that provides access to different sources of
+  multimedia content, using a pluggable system. 
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/grilo-0.2/ \
+               $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+               $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
+               $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/grilo/install
+       $(INSTALL_DIR) $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/*.so* \
+               $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,grilo))