Add support for TL-WA801ND v4
authorRomain MARIADASSOU <roms2000@free.fr>
Sun, 1 Jul 2018 22:55:47 +0000 (00:55 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:48:23 +0000 (17:48 +0100)
This add support for TP-Link TL-WA801ND v4 (same as TL-WA801ND v3) :

Specification:

- System-On-Chip: Qualcomm Atheros QCA9533
- CPU/Speed: 650 MHz
- Flash-Chip: Winbond W25Q32BVSIG
- Flash size: 4096 KiB
- RAM: 32 MiB
- Wireless No1: SoC-integrated: QCA9533 2.4GHz 802.11bgn

Flash instructions:

1) To flash the image, rename the file
   openwrt-ar71xx-generic-tl-wa801nd-v4-squashfs-factory.bin
   to firmware.bin
2) Connect your device to the LAN port, then upload the firmware
   through web interface. It will try to download the image and
   flash it.

It can take up to 2-3 minutes to finish. When it reaches 100%, the
router will reboot itself.

Signed-off-by: Romain MARIADASSOU <roms2000@free.fr>
(backported from 02494fa35ca07f01598e8bddb14303486ba69ba4)

target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wa801nd-v3.c
target/linux/ar71xx/image/tiny-tp-link.mk

index 054c14ee73faf629e1faf1efb19e804734602981..1637382192f34a3121d34138dcc73b087e942e43 100644 (file)
@@ -1,5 +1,6 @@
 /*
  *  TP-LINK TL-WA801ND v3 adapted from TP-LINK TL-WR841N/ND v9
+ *  TP-LINK TL-WA801ND v4
  *
  *  Copyright (C) 2014 Matthias Schiffer <mschiffer@universe-factory.net>
  *  Copyright (C) 2016 Tiziano Bacocco <tizbac2@gmail.com>
index 2891b9654f4fe276777bf86f7bdc337f071b53f3..a7410783324d1f01fc3985ee5a454d22f1a78b5a 100644 (file)
@@ -203,6 +203,13 @@ define Device/tl-wa801nd-v3
 endef
 TARGET_DEVICES += tl-wa801nd-v3
 
+define Device/tl-wa801nd-v4
+  $(Device/tl-wa801nd-v3)
+  DEVICE_TITLE := TP-LINK TL-WA801N/ND v4
+  TPLINK_HWID := 0x08010004
+endef
+TARGET_DEVICES += tl-wa801nd-v4
+
 define Device/tl-wa830re-v1
   $(Device/tplink-4m)
   DEVICE_TITLE := TP-LINK TL-WA830RE v1