Merge pull request #4262 from tsl0922/ttyd-1.3.2
authorHannu Nyman <hannu.nyman@iki.fi>
Mon, 17 Apr 2017 17:33:09 +0000 (20:33 +0300)
committerGitHub <noreply@github.com>
Mon, 17 Apr 2017 17:33:09 +0000 (20:33 +0300)
ttyd: update to 1.3.2

14 files changed:
libs/icu/Makefile
libs/icu/patches/000-dont-cpy-files-from-topdirs.patch
libs/icu/patches/001-disable-strtod_l.patch
libs/libsoxr/Makefile
net/adblock/Makefile
net/adblock/files/adblock.conf
net/adblock/files/adblock.init
net/adblock/files/adblock.sh
net/ser2net/Makefile
net/ser2net/patches/0001-dataxfer.c-fix-possible-buffer-overruns-caused-by-ga.patch [new file with mode: 0644]
net/ser2net/patches/0002-dataxfer.c-truncate-error-message-to-fit-the-column-.patch [new file with mode: 0644]
net/ser2net/patches/0003-dataxfer.c-adjust-Remote-address-column-width.patch [new file with mode: 0644]
net/ser2net/patches/0004-dataxfer.c-in-case-port-is-not-connected-display-thi.patch [new file with mode: 0644]
utils/lcdproc/Makefile

index 58234d415c5491b63c013d46056a78d62180568b..d4c07c2f8974fc585c0cb9d4efbfc691b4a2f3b4 100644 (file)
@@ -8,12 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=icu4c
-PKG_VERSION:=58.2
-PKG_RELEASE:=5
+PKG_VERSION:=59.1
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-58_2-src.tgz
+PKG_SOURCE:=$(PKG_NAME)-59_1-src.tgz
 PKG_SOURCE_URL:=http://download.icu-project.org/files/$(PKG_NAME)/$(PKG_VERSION)
-PKG_MD5SUM:=fac212b32b7ec7ab007a12dff1f3aea1
+PKG_MD5SUM:=54923fa9fab5b2b83f235fb72523de37
+PKG_HASH:=7132fdaf9379429d004005217f10e00b7d2319d0fea22bdfddef8991c45b75fe
 
 PKG_LICENSE:=ICU-1.8.1+
 PKG_LICENSE_FILES:=LICENSE
index 8b8cb7bc05d1ad702960fd92168eec3b0c4be3bf..291530a530e6c2e8a28201f47db642de76f27c7f 100644 (file)
@@ -2,7 +2,7 @@ diff --git a/Makefile.in b/Makefile.in
 index 9db6c52..6aa2273 100644
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -180,7 +180,6 @@ install-icu: $(INSTALLED_BUILT_FILES)
+@@ -184,7 +184,6 @@ install-icu: $(INSTALLED_BUILT_FILES)
        $(INSTALL_SCRIPT) $(top_srcdir)/install-sh $(DESTDIR)$(pkgdatadir)/install-sh
        @$(MKINSTALLDIRS) $(DESTDIR)$(libdir)/pkgconfig
        $(INSTALL_DATA) $(ALL_PKGCONFIG_FILES) $(DESTDIR)$(libdir)/pkgconfig/
index b84d14fc40efce8a820c65947e9bace768af9a3d..7ee9732ac721c7695fe6a8bfaee54c484829fd0f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -893,8 +893,8 @@
+@@ -883,8 +883,8 @@
  AC_CHECK_FUNC(strtod_l)
  if test x$ac_cv_func_strtod_l = xyes
  then
@@ -13,7 +13,7 @@
       U_HAVE_STRTOD_L=0
 --- a/configure
 +++ b/configure
-@@ -7053,8 +7053,8 @@
+@@ -7093,8 +7093,8 @@
  
  if test x$ac_cv_func_strtod_l = xyes
  then
index 9881fbb9d8717b708ffa4ae7ff2f3ca68d46f8a0..bbb16e5850c946633855718f4b8904e065964f64 100644 (file)
@@ -48,6 +48,7 @@ endef
 
 CMAKE_OPTIONS:= -DBUILD_TESTS=0 -DBUILD_EXAMPLES=0
 CMAKE_OPTIONS+= -DHAVE_WORDS_BIGENDIAN_EXITCODE=$(if $(CONFIG_BIG_ENDIAN),0,1)
+CMAKE_OPTIONS+= -DWITH_OPENMP=0
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
index 5b25930c016135045b29d52cb1ccf80737ca6f08..e197127c78f0ab5692a8442e949ea808557618c7 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
 PKG_VERSION:=2.6.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
 
index acc5518ac1bded6ab96b5dff8124a7a60b7537cf..7c114348347ce31c322a703fb560f64620e8d08c 100644 (file)
@@ -5,7 +5,7 @@ config adblock 'global'
        option adb_enabled '1'
        option adb_debug '0'
        option adb_iface 'wan'
-       option adb_triggerdelay '1'
+       option adb_triggerdelay '2'
        option adb_whitelist '/etc/adblock/adblock.whitelist'
        option adb_whitelist_rset '\$1 ~/^([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\"^\"\$1\"\\\|[.]\"\$1)}'
        option adb_backup '0'
index ad22abb9783706d3bb6ddfd85d587311f90b7077..ee94aa8228dabe6574a029c83bee18650cf6c3ab 100755 (executable)
@@ -1,7 +1,7 @@
 #!/bin/sh /etc/rc.common
 #
 
-START=90
+START=50
 USE_PROCD=1
 
 EXTRA_COMMANDS="suspend resume query status"
@@ -72,10 +72,11 @@ service_triggers()
     local iface="$(uci -q get adblock.global.adb_iface)"
     local delay="$(uci -q get adblock.global.adb_triggerdelay)"
 
-    PROCD_RELOAD_DELAY=$((${delay:=1} * 1000))
+    PROCD_RELOAD_DELAY=$((${delay:=2} * 1000))
     for name in ${iface}
     do
         procd_add_interface_trigger "interface.*.up" "${name}" "${adb_init}" start
     done
+    PROCD_RELOAD_DELAY=1000
     procd_add_config_trigger "config.change" "adblock" "${adb_init}" start
 }
index c81f6ac0b69cc37892534f42597dee338d3d5588..f886723bb6c1d703ba86e9e3b5822dfe984faa4e 100755 (executable)
@@ -10,7 +10,7 @@
 #
 LC_ALL=C
 PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-adb_ver="2.6.0"
+adb_ver="2.6.0-2"
 adb_sysver="$(ubus -S call system board | jsonfilter -e '@.release.description')"
 adb_enabled=1
 adb_debug=0
index 793ff13f3ba672a3782d0dc7049bc85288d4c6c0..a433fbe98c03c5ec804a56c7b74b69bc55111a0b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ser2net
 PKG_VERSION:=3.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ser2net
diff --git a/net/ser2net/patches/0001-dataxfer.c-fix-possible-buffer-overruns-caused-by-ga.patch b/net/ser2net/patches/0001-dataxfer.c-fix-possible-buffer-overruns-caused-by-ga.patch
new file mode 100644 (file)
index 0000000..83874eb
--- /dev/null
@@ -0,0 +1,64 @@
+From 8614cf0ad4a017184285e814a704322f59a28869 Mon Sep 17 00:00:00 2001
+From: Michael Heimpold <mhei@heimpold.de>
+Date: Wed, 12 Apr 2017 23:36:17 +0200
+Subject: [PATCH] dataxfer.c: fix possible buffer overruns caused by
+ gai_strerror
+
+This fixes a possible buffer overrun that could occur due to
+gai_strerror() returning a string which is longer than the portbuff
+array, i.e. longer than 32 byte.
+
+Reported-by: David Thornley <david.thornley@touchstargroup.com>
+Signed-off-by: Michael Heimpold <mhei@heimpold.de>
+Signed-off-by: Corey Minyard <cminyard@mvista.com>
+
+diff --git a/dataxfer.c b/dataxfer.c
+index 3d1e713..988f4e4 100644
+--- a/dataxfer.c
++++ b/dataxfer.c
+@@ -3702,18 +3702,20 @@ showshortport(struct controller_info *cntlr, port_info_t *port)
+                     portbuff, sizeof(portbuff),
+                     NI_NUMERICHOST | NI_NUMERICSERV);
+     if (err) {
+-      strcpy(buffer, "*err*");
+-      sprintf(portbuff, "%s", gai_strerror(err));
++      snprintf(buffer, sizeof(buffer), "*err*,%s", gai_strerror(err));
++      count = controller_outputf(cntlr, "%s", buffer);
++    } else {
++      count = controller_outputf(cntlr, "%s,%s", buffer, portbuff);
+     }
+-    bytes_recv = netcon->bytes_received;
+-    bytes_sent = netcon->bytes_sent;
+-    count = controller_outputf(cntlr, "%s,%s", buffer, portbuff);
+     while (count < 23) {
+       controller_outs(cntlr, " ");
+       count++;
+     }
++    bytes_recv = netcon->bytes_received;
++    bytes_sent = netcon->bytes_sent;
++
+     controller_outputf(cntlr, "%-22s ", port->io.devname);
+     controller_outputf(cntlr, "%-14s ", state_str[port->net_to_dev_state]);
+     controller_outputf(cntlr, "%-14s ", state_str[port->dev_to_net_state]);
+@@ -3758,11 +3760,12 @@ showport(struct controller_info *cntlr, port_info_t *port)
+                         portbuff, sizeof(portbuff),
+                         NI_NUMERICHOST | NI_NUMERICSERV);
+       if (err) {
+-          strcpy(buffer, "*err*");
+-          sprintf(portbuff, "%s", gai_strerror(err));
++          snprintf(buffer, sizeof(buffer), "*err*,%s", gai_strerror(err));
++          controller_outputf(cntlr, "  connected to: %s\r\n", buffer);
++      } else {
++          controller_outputf(cntlr, "  connected to: %s,%s\r\n",
++                             buffer, portbuff);
+       }
+-      controller_outputf(cntlr, "  connected to: %s,%s\r\n",
+-                         buffer, portbuff);
+       controller_outputf(cntlr, "    bytes read from TCP: %d\r\n",
+                          netcon->bytes_received);
+       controller_outputf(cntlr, "    bytes written to TCP: %d\r\n",
+-- 
+2.7.4
+
diff --git a/net/ser2net/patches/0002-dataxfer.c-truncate-error-message-to-fit-the-column-.patch b/net/ser2net/patches/0002-dataxfer.c-truncate-error-message-to-fit-the-column-.patch
new file mode 100644 (file)
index 0000000..215a357
--- /dev/null
@@ -0,0 +1,30 @@
+From b303432f2dbd6a20afa99cb462aa0a1bb740b86d Mon Sep 17 00:00:00 2001
+From: Michael Heimpold <mhei@heimpold.de>
+Date: Wed, 12 Apr 2017 23:43:18 +0200
+Subject: [PATCH] dataxfer.c: truncate error message to fit the column width
+
+gai_strerror() could return a string which is longer than our current
+column width of "Remote address". To make the output nice again,
+truncate the error string in this case.
+
+Signed-off-by: Michael Heimpold <mhei@heimpold.de>
+Signed-off-by: Corey Minyard <cminyard@mvista.com>
+
+diff --git a/dataxfer.c b/dataxfer.c
+index 988f4e4..75c2777 100644
+--- a/dataxfer.c
++++ b/dataxfer.c
+@@ -3703,6 +3703,10 @@ showshortport(struct controller_info *cntlr, port_info_t *port)
+                     NI_NUMERICHOST | NI_NUMERICSERV);
+     if (err) {
+       snprintf(buffer, sizeof(buffer), "*err*,%s", gai_strerror(err));
++      /* gai_strerror could return an elongated string which could break
++         our pretty formatted output below, so truncate the string nicely */
++      if (strlen(buffer) > 22)
++          strcpy(&buffer[22 - 3], "...");
+       count = controller_outputf(cntlr, "%s", buffer);
+     } else {
+       count = controller_outputf(cntlr, "%s,%s", buffer, portbuff);
+-- 
+2.7.4
+
diff --git a/net/ser2net/patches/0003-dataxfer.c-adjust-Remote-address-column-width.patch b/net/ser2net/patches/0003-dataxfer.c-adjust-Remote-address-column-width.patch
new file mode 100644 (file)
index 0000000..fbc7aed
--- /dev/null
@@ -0,0 +1,59 @@
+From 81f3991e232fd45b05ff52b5091393532e4305e5 Mon Sep 17 00:00:00 2001
+From: Michael Heimpold <mhei@heimpold.de>
+Date: Thu, 13 Apr 2017 20:29:10 +0200
+Subject: [PATCH] dataxfer.c: adjust "Remote address" column width
+
+In case we are connected to an IPv6 address the current column width
+is too small to take the complete address and port number so adjust it.
+
+Signed-off-by: Michael Heimpold <mhei@heimpold.de>
+Signed-off-by: Corey Minyard <cminyard@mvista.com>
+
+diff --git a/dataxfer.c b/dataxfer.c
+index 75c2777..9955403 100644
+--- a/dataxfer.c
++++ b/dataxfer.c
+@@ -3674,6 +3674,9 @@ clear_old_port_config(int curr_config)
+     UNLOCK(ports_lock);
+ }
++#define REMOTEADDR_COLUMN_WIDTH \
++    (INET6_ADDRSTRLEN - 1 /* terminating NUL */ + 1 /* comma */ + 5 /* strlen("65535") */)
++
+ /* Print information about a port to the control port given in cntlr. */
+ static void
+ showshortport(struct controller_info *cntlr, port_info_t *port)
+@@ -3705,14 +3708,14 @@ showshortport(struct controller_info *cntlr, port_info_t *port)
+       snprintf(buffer, sizeof(buffer), "*err*,%s", gai_strerror(err));
+       /* gai_strerror could return an elongated string which could break
+          our pretty formatted output below, so truncate the string nicely */
+-      if (strlen(buffer) > 22)
+-          strcpy(&buffer[22 - 3], "...");
++      if (strlen(buffer) > REMOTEADDR_COLUMN_WIDTH)
++          strcpy(&buffer[REMOTEADDR_COLUMN_WIDTH - 3], "...");
+       count = controller_outputf(cntlr, "%s", buffer);
+     } else {
+       count = controller_outputf(cntlr, "%s,%s", buffer, portbuff);
+     }
+-    while (count < 23) {
++    while (count < REMOTEADDR_COLUMN_WIDTH + 1) {
+       controller_outs(cntlr, " ");
+       count++;
+     }
+@@ -3878,10 +3881,11 @@ showshortports(struct controller_info *cntlr, char *portspec)
+     port_info_t *port;
+     controller_outputf(cntlr,
+-          "%-22s %-6s %7s %-22s %-22s %-14s %-14s %9s %9s %9s %9s %s\r\n",
++          "%-22s %-6s %7s %-*s %-22s %-14s %-14s %9s %9s %9s %9s %s\r\n",
+           "Port name",
+           "Type",
+           "Timeout",
++          REMOTEADDR_COLUMN_WIDTH,
+           "Remote address",
+           "Device",
+           "TCP to device",
+-- 
+2.7.4
+
diff --git a/net/ser2net/patches/0004-dataxfer.c-in-case-port-is-not-connected-display-thi.patch b/net/ser2net/patches/0004-dataxfer.c-in-case-port-is-not-connected-display-thi.patch
new file mode 100644 (file)
index 0000000..04cbddc
--- /dev/null
@@ -0,0 +1,94 @@
+From 1479d3acc7ffb77225ea294f83a8d3fbdadfece6 Mon Sep 17 00:00:00 2001
+From: Michael Heimpold <mhei@heimpold.de>
+Date: Thu, 13 Apr 2017 20:37:35 +0200
+Subject: [PATCH] dataxfer.c: in case port is not connected display this
+ directly
+
+In this case we don't bother to call into getnameinfo but show
+directly "unconnected", this prevents showing an error message.
+
+Signed-off-by: Michael Heimpold <mhei@heimpold.de>
+Signed-off-by: Corey Minyard <cminyard@mvista.com>
+
+diff --git a/dataxfer.c b/dataxfer.c
+index 9955403..d6a59d9 100644
+--- a/dataxfer.c
++++ b/dataxfer.c
+@@ -3700,19 +3700,23 @@ showshortport(struct controller_info *cntlr, port_info_t *port)
+     if (!netcon)
+       netcon = &(port->netcons[0]);
+-    err = getnameinfo(netcon->raddr, netcon->raddrlen,
+-                    buffer, sizeof(buffer),
+-                    portbuff, sizeof(portbuff),
+-                    NI_NUMERICHOST | NI_NUMERICSERV);
+-    if (err) {
+-      snprintf(buffer, sizeof(buffer), "*err*,%s", gai_strerror(err));
+-      /* gai_strerror could return an elongated string which could break
+-         our pretty formatted output below, so truncate the string nicely */
+-      if (strlen(buffer) > REMOTEADDR_COLUMN_WIDTH)
+-          strcpy(&buffer[REMOTEADDR_COLUMN_WIDTH - 3], "...");
+-      count = controller_outputf(cntlr, "%s", buffer);
++    if (port->net_to_dev_state != PORT_UNCONNECTED) {
++      err = getnameinfo(netcon->raddr, netcon->raddrlen,
++                        buffer, sizeof(buffer),
++                        portbuff, sizeof(portbuff),
++                        NI_NUMERICHOST | NI_NUMERICSERV);
++      if (err) {
++          snprintf(buffer, sizeof(buffer), "*err*,%s", gai_strerror(err));
++          /* gai_strerror could return an elongated string which could break
++             our pretty formatted output below, so truncate the string nicely */
++          if (strlen(buffer) > REMOTEADDR_COLUMN_WIDTH)
++              strcpy(&buffer[REMOTEADDR_COLUMN_WIDTH - 3], "...");
++          count = controller_outputf(cntlr, "%s", buffer);
++      } else {
++          count = controller_outputf(cntlr, "%s,%s", buffer, portbuff);
++      }
+     } else {
+-      count = controller_outputf(cntlr, "%s,%s", buffer, portbuff);
++      count = controller_outputf(cntlr, "unconnected");
+     }
+     while (count < REMOTEADDR_COLUMN_WIDTH + 1) {
+@@ -3762,21 +3766,25 @@ showport(struct controller_info *cntlr, port_info_t *port)
+     controller_outputf(cntlr, "  timeout: %d\r\n", port->timeout);
+     for_each_connection(port, netcon) {
+-      err = getnameinfo(netcon->raddr, netcon->raddrlen,
+-                        buffer, sizeof(buffer),
+-                        portbuff, sizeof(portbuff),
+-                        NI_NUMERICHOST | NI_NUMERICSERV);
+-      if (err) {
+-          snprintf(buffer, sizeof(buffer), "*err*,%s", gai_strerror(err));
+-          controller_outputf(cntlr, "  connected to: %s\r\n", buffer);
++      if (port->net_to_dev_state != PORT_UNCONNECTED) {
++          err = getnameinfo(netcon->raddr, netcon->raddrlen,
++                            buffer, sizeof(buffer),
++                            portbuff, sizeof(portbuff),
++                            NI_NUMERICHOST | NI_NUMERICSERV);
++          if (err) {
++              snprintf(buffer, sizeof(buffer), "*err*,%s", gai_strerror(err));
++              controller_outputf(cntlr, "  connected to: %s\r\n", buffer);
++          } else {
++              controller_outputf(cntlr, "  connected to: %s,%s\r\n",
++                                 buffer, portbuff);
++          }
++          controller_outputf(cntlr, "    bytes read from TCP: %d\r\n",
++                             netcon->bytes_received);
++          controller_outputf(cntlr, "    bytes written to TCP: %d\r\n",
++                             netcon->bytes_sent);
+       } else {
+-          controller_outputf(cntlr, "  connected to: %s,%s\r\n",
+-                             buffer, portbuff);
++          controller_outputf(cntlr, "  unconnected\r\n");
+       }
+-      controller_outputf(cntlr, "    bytes read from TCP: %d\r\n",
+-                         netcon->bytes_received);
+-      controller_outputf(cntlr, "    bytes written to TCP: %d\r\n",
+-                         netcon->bytes_sent);
+     }
+     controller_outputf(cntlr, "  device: %s\r\n", port->io.devname);
+-- 
+2.7.4
+
index fc6d9fb5c56e4a4b9280cf229b8f860a46ca7082..630c15c26b29e411790ebebd86e70b8030a45116 100644 (file)
@@ -11,7 +11,7 @@ PKG_NAME:=lcdproc
 # PKG_VERSION:=0.5.8
 PKG_BASE_VERSION:=0.5.8
 PKG_VERSION:=$(PKG_BASE_VERSION)+git2070222
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/lcdproc/lcdproc.git
@@ -121,7 +121,7 @@ endef
 
 
 # not everything groks --disable-nls
-CONFIGURE_ARGS := $(filter-out --%-nls,$(CONFIGURE_ARGS))
+DISABLE_NLS:=
 
 CONFIGURE_ARGS += \
        --disable-libX11 \