Force dlopen_deplibs since cross-compilation test does not set it. Closes #375
authorFlorian Fainelli <florian@openwrt.org>
Sun, 16 Apr 2006 09:22:06 +0000 (09:22 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 16 Apr 2006 09:22:06 +0000 (09:22 +0000)
SVN-Revision: 3659

openwrt/package/libtool/Makefile
openwrt/package/libtool/patches/01-force_dlopen_deplibs.patch [new file with mode: 0644]

index 2342fb0b0c40f9c746a9f5cd7252cf88939c7259..e1047e1ec697bbf6b57f3a1dd6e2dc9de5e9609d 100644 (file)
@@ -25,6 +25,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
+               libltdl_cv_sys_dlopen_deplibs=yes \
                ./configure \
                  --target=$(GNU_TARGET_NAME) \
                  --host=$(GNU_TARGET_NAME) \
diff --git a/openwrt/package/libtool/patches/01-force_dlopen_deplibs.patch b/openwrt/package/libtool/patches/01-force_dlopen_deplibs.patch
new file mode 100644 (file)
index 0000000..71a75d4
--- /dev/null
@@ -0,0 +1,14 @@
+diff -urN libtool-1.5.14/libltdl/acinclude.m4 libtool-1.5.14.new/libltdl/acinclude.m4
+--- libtool-1.5.14/libltdl/acinclude.m4        2005-02-12 13:20:02.000000000 +0100
++++ libtool-1.5.14.new/libltdl/acinclude.m4    2006-04-16 11:14:48.000000000 +0200
+@@ -6228,10 +6228,8 @@
+     ;;
+   esac
+   ])
+-if test "$libltdl_cv_sys_dlopen_deplibs" != yes; then
+  AC_DEFINE([LTDL_DLOPEN_DEPLIBS], [1],
+     [Define if the OS needs help to load dependent libraries for dlopen().])
+-fi
+ ])# AC_LTDL_SYS_DLOPEN_DEPLIBS