banip: update 0.1.1 9003/head
authorDirk Brenken <dev@brenken.org>
Thu, 16 May 2019 09:16:03 +0000 (11:16 +0200)
committerDirk Brenken <dev@brenken.org>
Thu, 16 May 2019 09:16:03 +0000 (11:16 +0200)
* remove needless sort step to reduce system load
* change maxqueue default in backend and LuCI frontend
  to '4' to reduce (default) system load
* cosmetics

Signed-off-by: Dirk Brenken <dev@brenken.org>
net/banip/Makefile
net/banip/files/banip.conf
net/banip/files/banip.sh

index 612825cbcdec58755517c19ad88108704a0c03e2..5cf2127c3e8e4c0e0ca480f3677314f438729d4c 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=banip
-PKG_VERSION:=0.1.0
+PKG_VERSION:=0.1.1
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
index 7de03e8af66d383b8276a1b7db2a1d9d254d90b3..f658c445ba2e38db04dd98dbcd5b4ea186628b14 100644 (file)
@@ -10,7 +10,7 @@ config banip 'global'
 config banip 'extra'
        option ban_debug '0'
        option ban_backup '0'
-       option ban_maxqueue '8'
+       option ban_maxqueue '4'
 
 config source 'whitelist'
        option ban_src '/etc/banip/banip.whitelist'
index b12aed6b1aec7a1e3957cc3c366f461e0f6d8313..a55db3e02d454edb59e4d1ee3f98852c0511e2fb 100755 (executable)
@@ -10,7 +10,7 @@
 #
 LC_ALL=C
 PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-ban_ver="0.1.0"
+ban_ver="0.1.1"
 ban_sysver="unknown"
 ban_enabled=0
 ban_automatic="1"
@@ -19,7 +19,7 @@ ban_debug=0
 ban_backup=0
 ban_backupboot=0
 ban_backupdir="/mnt"
-ban_maxqueue=8
+ban_maxqueue=4
 ban_fetchutil="uclient-fetch"
 ban_ip="$(command -v ip)"
 ban_ipt="$(command -v iptables)"
@@ -257,7 +257,7 @@ f_iptrule()
                rc="$("${ban_ipt6}" "${timeout}" -C ${rule} 2>/dev/null; printf '%u' ${?})"
 
                if ([ ${rc} -ne 0 ] && ([ "${action}" = "-A" ] || [ "${action}" = "-I" ])) \
-                  || ([ ${rc} -eq 0 ] && [ "${action}" = "-D" ])
+                       || ([ ${rc} -eq 0 ] && [ "${action}" = "-D" ])
                then
                        "${ban_ipt6}" "${timeout}" "${action}" ${rule}
                fi
@@ -265,7 +265,7 @@ f_iptrule()
                rc="$("${ban_ipt}" "${timeout}" -C ${rule} 2>/dev/null; printf '%u' ${?})"
 
                if ([ ${rc} -ne 0 ] && ([ "${action}" = "-A" ] || [ "${action}" = "-I" ])) \
-                  || ([ ${rc} -eq 0 ] && [ "${action}" = "-D" ])
+                       || ([ ${rc} -eq 0 ] && [ "${action}" = "-D" ])
                then
                        "${ban_ipt}" "${timeout}" "${action}" ${rule}
                fi
@@ -678,7 +678,7 @@ f_main()
 
                        if [ ${ban_rc} -eq 0 ]
                        then
-                               awk "${src_rset}" "${tmp_load}" 2>/dev/null | sort -u > "${tmp_file}"
+                               awk "${src_rset}" "${tmp_load}" 2>/dev/null > "${tmp_file}"
                                ban_rc=${?}
                                if [ ${ban_rc} -eq 0 ]
                                then