add in a couple more of the helper files and link postmaster to postgres, changing...
authorTim Yardley <lst@openwrt.org>
Fri, 18 Jan 2008 19:21:07 +0000 (19:21 +0000)
committerTim Yardley <lst@openwrt.org>
Fri, 18 Jan 2008 19:21:07 +0000 (19:21 +0000)
SVN-Revision: 10223

libs/postgresql/Makefile
libs/postgresql/files/postgresql.init

index 49bbf47aa5069d082b556848340b28cadb74a15c..a9130dacb6d47a0e81699cb697b38fe318076dfc 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
 PKG_VERSION:=8.2.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -158,6 +158,8 @@ define Build/Configure
        );
        $(SED) 's@ECPG = ../../preproc/ecpg@ECPG = ../../preproc/ecpg.host@' $(PKG_BUILD_DIR)/src/interfaces/ecpg/test/Makefile.regress
        $(SED) 's@\./zic -d@./zic.host -d@' $(PKG_BUILD_DIR)/src/timezone/Makefile
+       # note: unclear if this is needed yet, commenting out for the moment
+       #$(SED) 's@US/Eastern@America/New_York@' $(PKG_BUILD_DIR)/src/timezone/Makefile
 endef
 
 define Build/Compile
@@ -185,19 +187,28 @@ define Package/pgsql-server/install
        $(INSTALL_BIN) \
                $(PKG_INSTALL_DIR)/usr/bin/postgres \
                $(PKG_INSTALL_DIR)/usr/bin/dropdb \
+               $(PKG_INSTALL_DIR)/usr/bin/clusterdb \
                $(PKG_INSTALL_DIR)/usr/bin/createdb \
+               $(PKG_INSTALL_DIR)/usr/bin/createlang \
                $(PKG_INSTALL_DIR)/usr/bin/createuser \
+               $(PKG_INSTALL_DIR)/usr/bin/dropdb \
+               $(PKG_INSTALL_DIR)/usr/bin/droplang \
                $(PKG_INSTALL_DIR)/usr/bin/dropuser \
                $(PKG_INSTALL_DIR)/usr/bin/initdb \
+               $(PKG_INSTALL_DIR)/usr/bin/ipcclean \
                $(PKG_INSTALL_DIR)/usr/bin/pg_config \
                $(PKG_INSTALL_DIR)/usr/bin/pg_controldata \
                $(PKG_INSTALL_DIR)/usr/bin/pg_ctl \
                $(PKG_INSTALL_DIR)/usr/bin/pg_dump \
                $(PKG_INSTALL_DIR)/usr/bin/pg_dumpall \
                $(PKG_INSTALL_DIR)/usr/bin/pg_restore \
+               $(PKG_INSTALL_DIR)/usr/bin/pg_resetxlog \
+               $(PKG_INSTALL_DIR)/usr/bin/reindexdb \
                $(PKG_INSTALL_DIR)/usr/bin/vacuumdb \
                $(1)/usr/bin
 
+       $(LN) -s postgres $(1)/usr/bin/postmaster
+
        $(INSTALL_BIN) ./files/postgresql.init $(1)/etc/init.d/postgresql
 
        $(INSTALL_DATA) \
index 112e500cdac685e8ecf2ac0f8615ed32ec3dd970..e32a983321d7f1bdbf5d4d46edd4cbe1f4a99d19 100755 (executable)
@@ -36,7 +36,7 @@ start() {
     if [ -n "${pgopts}" ]; then
         pgopts="-o ${pgopts}"
     fi
-    /bin/su ${pguser} -c "/usr/bin/postgres -D '${pgdata}' &" >> ${pglog} 2>&1
+    /bin/su ${pguser} -c "/usr/bin/postmaster -D '${pgdata}' &" >> ${pglog} 2>&1
 
     while :
     do
@@ -75,7 +75,7 @@ restart() {
     if [ -f ${pgdata}/postmaster.pid ]; then
         rm ${pgdata}/postmaster.pid
     fi
-    /bin/su ${pguser} -c "/usr/bin/postgres -D '${pgdata}' &" >> ${pglog} 2>&1
+    /bin/su ${pguser} -c "/usr/bin/postmaster -D '${pgdata}' &" >> ${pglog} 2>&1
     echo "ok"
     return $?
 }