libsrtp2: fix compilation with GCC 10 546/head
authorRosen Penev <rosenp@gmail.com>
Sun, 19 Jul 2020 07:03:58 +0000 (00:03 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 19 Jul 2020 21:54:24 +0000 (14:54 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libsrtp2/Makefile
libs/libsrtp2/patches/010-gcc10.patch [new file with mode: 0644]

index 9059fb1996ebf0522df2c9fa94e5ffabe994c8c2..345fc2951c78bb8502541e6b6085057e8ec62508 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsrtp2
 PKG_VERSION:=2.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/cisco/libsrtp.git
diff --git a/libs/libsrtp2/patches/010-gcc10.patch b/libs/libsrtp2/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..70723f7
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/crypto/math/datatypes.c
++++ b/crypto/math/datatypes.c
+@@ -79,7 +79,7 @@ int octet_get_weight(uint8_t octet)
+ /* the value MAX_PRINT_STRING_LEN is defined in datatypes.h */
+-char bit_string[MAX_PRINT_STRING_LEN];
++static char bit_string[MAX_PRINT_STRING_LEN];
+ uint8_t srtp_nibble_to_hex_char(uint8_t nibble)
+ {