package: add om2p-watchdog script
authorGabor Juhos <juhosg@openwrt.org>
Sat, 12 Nov 2011 10:54:06 +0000 (10:54 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 12 Nov 2011 10:54:06 +0000 (10:54 +0000)
Based on a patch by: Marek Lindner <lindner_marek@yahoo.de>

SVN-Revision: 28972

package/om2p-watchdog/Makefile [new file with mode: 0644]
package/om2p-watchdog/files/om2p-watchdog [new file with mode: 0755]
package/om2p-watchdog/files/om2p-watchdog.init [new file with mode: 0755]

diff --git a/package/om2p-watchdog/Makefile b/package/om2p-watchdog/Makefile
new file mode 100644 (file)
index 0000000..965e51f
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=om2p-watchdog
+PKG_RELEASE:=1
+PKG_VERSION:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/om2p-watchdog
+  SECTION:=base
+  CATEGORY:=Base system
+  DEPENDS:=@TARGET_ar71xx
+  TITLE:=om2p watchdog
+  URL:=http://openwrt.org/
+endef
+
+define Package/om2p-watchdog/description
+ This package contains the hw watchdog script for the OM2P device.
+endef
+
+define Build/Prepare
+endef
+
+define Build/Compile
+endef
+
+define Build/Compile
+endef
+
+define Package/om2p-watchdog/install
+       $(INSTALL_DIR) $(1)/etc/init.d/
+       $(INSTALL_DIR) $(1)/sbin/
+       $(INSTALL_BIN) ./files/om2p-watchdog.init $(1)/etc/init.d/om2p-watchdog
+       $(INSTALL_BIN) ./files/om2p-watchdog $(1)/sbin/om2p-watchdog
+endef
+
+
+$(eval $(call BuildPackage,om2p-watchdog))
+
diff --git a/package/om2p-watchdog/files/om2p-watchdog b/package/om2p-watchdog/files/om2p-watchdog
new file mode 100755 (executable)
index 0000000..9f861f6
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+GPIO=12
+
+echo $GPIO > /sys/class/gpio/export
+echo out > /sys/class/gpio/gpio${GPIO}/direction
+
+while true; do
+       echo 1 > /sys/class/gpio/gpio${GPIO}/value
+       sleep 1
+       echo 0 > /sys/class/gpio/gpio${GPIO}/value
+       sleep 180
+done
diff --git a/package/om2p-watchdog/files/om2p-watchdog.init b/package/om2p-watchdog/files/om2p-watchdog.init
new file mode 100755 (executable)
index 0000000..ddec85f
--- /dev/null
@@ -0,0 +1,14 @@
+#!/bin/sh /etc/rc.common
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+
+START=11
+
+boot() {
+       . /lib/ar71xx.sh
+
+       local board=$(ar71xx_board_name)
+
+       [ "$board" = "om2p" ] && /sbin/om2p-watchdog &
+}