Merge pull request #12270 from neheb/taglib
authorRosen Penev <rosenp@gmail.com>
Sat, 23 May 2020 23:48:26 +0000 (16:48 -0700)
committerGitHub <noreply@github.com>
Sat, 23 May 2020 23:48:26 +0000 (16:48 -0700)
taglib: fix taglib-config paths

libs/nss/Makefile
libs/nss/patches/003-openwrt_fix.patch
net/adblock/Makefile
net/adblock/files/README.md
net/adblock/files/adblock.init
net/adblock/files/adblock.sh
net/adblock/files/adblock.sources
net/dawn/Makefile
utils/lxc/Makefile

index 962b8b7b16615a6e8749c37e1f016a0ea7da401c..aea986c7987785594e73106c57743330bcaaf8b4 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nss
 PKG_VERSION:=3.52
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
@@ -62,8 +62,15 @@ ifeq ($(CONFIG_CPU_TYPE),"xscale")
 TARGET_CFLAGS+= -mfloat-abi=softfp
 endif
 
+ifneq ($(findstring arm,$(CONFIG_ARCH)),)
+ifeq ($(findstring neon,$(CONFIG_CPU_TYPE)),)
+export NSS_DISABLE_ARM32_NEON
+endif
+endif
+
 export NATIVE_CC=$(HOSTCC)
 export NATIVE_FLAGS=$(HOST_CFLAGS)
+export NSS_ENABLE_WERROR=0
 
 MAKE_FLAGS += \
        CROSS_COMPILE=1 \
index e3eb2ceddd27ae054663d06bc6106969791ce73c..9f75850ff9b62b293e19fb54bf631ff9af130afe 100644 (file)
@@ -22,7 +22,7 @@
  
 --- a/nss/coreconf/arch.mk     2019-03-31 23:38:34.374931416 +0300
 +++ b/nss/coreconf/arch.mk     2019-03-31 23:38:44.667236102 +0300
-@@ -305,7 +305,7 @@
+@@ -334,7 +334,7 @@
      OBJDIR_NAME_COMPILER = $(COMPILER_TAG)
  endif
  OBJDIR_NAME_BASE = $(OS_TARGET)$(OS_RELEASE)$(CPU_TAG)$(OBJDIR_NAME_COMPILER)$(LIBC_TAG)$(IMPL_STRATEGY)$(OBJDIR_TAG)
index 1a4b7f5569f1189922a8b159f48e55454cdce194..0ce108baa746fa5f64b4d23f2c544a32cfe46093 100644 (file)
@@ -6,8 +6,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
-PKG_VERSION:=4.0.4
-PKG_RELEASE:=4
+PKG_VERSION:=4.0.5
+PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
 
@@ -17,7 +17,7 @@ define Package/adblock
        SECTION:=net
        CATEGORY:=Network
        TITLE:=Powerful adblock script to block ad/abuse domains by using DNS
-       DEPENDS:=+jshn +jsonfilter +coreutils +coreutils-sort +ca-bundle
+       DEPENDS:=+jshn +jsonfilter +coreutils +coreutils-sort +ca-bundle +opkg
        PKGARCH:=all
 endef
 
index a196e590d6b2b188041b060b22ee154a64fbd223..f399cb8e1681cbc536f5b643b253ab037054051b 100644 (file)
@@ -15,10 +15,11 @@ A lot of people already use adblocker plugins within their desktop browsers, but
 | bitcoin             |         | S    | mining           | [Link](https://github.com/hoshsadiq/adblock-nocoin-list)         |
 | disconnect          | x       | S    | general          | [Link](https://disconnect.me)                                    |
 | dshield             |         | XL   | general          | [Link](https://dshield.org)                                      |
-| energized_blugo     |         | XL   | compilation      | [Link](https://github.com/EnergizedProtection/block)             |
-| energized_blu       |         | XL   | compilation      | [Link](https://github.com/EnergizedProtection/block)             |
-| energized_porn      |         | XXL  | compilation+porn | [Link](https://github.com/EnergizedProtection/block)             |
-| energized_unified   |         | XXL  | compilation      | [Link](https://github.com/EnergizedProtection/block)             |
+| energized_blugo     |         | XL   | compilation      | [Link](https://energized.pro)                                    |
+| energized_blu       |         | XL   | compilation      | [Link](https://energized.pro)                                    |
+| energized_porn      |         | XXL  | compilation+porn | [Link](https://energized.pro)                                    |
+| energized_ultimate  |         | XXL  | compilation      | [Link](https://energized.pro)                                    |
+| energized_unified   |         | XXL  | compilation      | [Link](https://energized.pro)                                    |
 | malwaredomains      |         | M    | malware          | [Link](https://malwaredomains.com)                               |
 | malwarelist         |         | S    | malware          | [Link](https://www.malwaredomainlist.com)                        |
 | notracking          |         | XL   | tracking         | [Link](https://github.com/notracking/hosts-blocklists)           |
@@ -35,11 +36,12 @@ A lot of people already use adblocker plugins within their desktop browsers, but
 | reg_ro              |         | M    | reg_romania      | [Link](https://easylist.to)                                      |
 | reg_ru              |         | M    | reg_russia       | [Link](https://easylist.to)                                      |
 | reg_vn              |         | M    | reg_vietnam      | [Link](https://bigdargon.github.io/hostsVN)                      |
-| shallalist          |         | L    | general          | [Link](https://www.shallalist.de)                                |
-| shallalist_porn     |         | XXL  | general+porn     | [Link](https://www.shallalist.de)                                |
+| shallalist          |         | L    | general          | [Link](http://www.shallalist.de)                                 |
+| shallalist_porn     |         | XXL  | general+porn     | [Link](http://www.shallalist.de)                                 |
 | smarttv             |         | S    | smarttv          | [Link](https://github.com/Perflyst/PiHoleBlocklist)              |
 | spam404             |         | S    | general          | [Link](https://github.com/Dawsey21)                              |
-| stevenblack         |         | L    | compilation      | [Link](https://github.com/StevenBlack/hosts)                     |
+| stevenblack         |         | L    | compilation+porn | [Link](https://github.com/StevenBlack/hosts)                     |
+| stevenblack_porn    |         | L    | compilation+porn | [Link](https://github.com/StevenBlack/hosts)                     |
 | stopforumspam       |         | S    | spam             | [Link](https://www.stopforumspam.com)                            |
 | sysctl              |         | M    | general          | [Link](http://sysctl.org/cameleon)                               |
 | utcapitole          |         | L    | general          | [Link](https://dsi.ut-capitole.fr/blacklists/index_en.php)       |
index c3fd46c83b0314c422b94a926414732e08e09d58..3471cc8df56a557b3f67bf7aca223d3030fcb85a 100755 (executable)
@@ -134,8 +134,8 @@ list()
                        src_enabled="${src_enabled//\'}"
                        printf "%s\\n" "::: Available adblock sources"
                        printf "%s\\n" ":::"
-                       printf "%-25s%-10s%-7s%-20s%s\\n" "    Name" "Enabled" "Size" "Focus" "Info URL"
-                       printf "%s\\n" "    ------------------------------------------------------------------"
+                       printf "%-25s%-10s%-7s%-21s%s\\n" "    Name" "Enabled" "Size" "Focus" "Info URL"
+                       printf "%s\\n" "    -------------------------------------------------------------------"
                        json_load_file "${src_file}"
                        json_get_keys keylist
                        for key in ${keylist}
@@ -155,7 +155,7 @@ list()
                                                enabled=" "
                                        fi
                                        src_enabled="${src_enabled/${key}}"
-                                       printf "  + %-21s%-10s%-7s%-20s%s\\n" "${key}" "${enabled}" "${size}" "${focus}" "${descurl}"
+                                       printf "  + %-21s%-10s%-7s%-21s%s\\n" "${key:0:20}" "${enabled}" "${size:0:3}" "${focus:0:20}" "${descurl:0:50}"
                                else
                                        src_enabled="${src_enabled} ${key}"
                                fi
@@ -168,7 +168,7 @@ list()
                                printf "%s\\n" "    ----------------------------------------------"
                                for key in ${src_enabled}
                                do
-                                       printf "  - %s\\n" "${key}"
+                                       printf "  - %s\\n" "${key:0:20}"
                                done
                        fi
                else
index 4fa4902ca74256292e443574ec31c307d409cadd..8098f2db6103f36a3586df20eb927b7204689d72 100755 (executable)
@@ -11,7 +11,7 @@
 export LC_ALL=C
 export PATH="/usr/sbin:/usr/bin:/sbin:/bin"
 set -o pipefail
-adb_ver="4.0.4"
+adb_ver="4.0.5"
 adb_enabled=0
 adb_debug=0
 adb_forcedns=0
@@ -125,13 +125,20 @@ f_conf()
 
        if [ ! -r "/etc/config/adblock" ] || [ -n "$(uci -q show adblock.@source[0])" ]
        then
-               if [ -r "/etc/config/adblock-opkg" ] && [ -z "$(uci -q show adblock-opkg.@source[0])" ]
+               if { [ -r "/etc/config/adblock-opkg" ] && [ -z "$(uci -q show adblock-opkg.@source[0])" ]; } || \
+                       { [ -r "/rom/etc/config/adblock" ] && [ -z "$(uci -q show /rom/etc/config/adblock.@source[0])" ]; }
                then
                        if [ -r "/etc/config/adblock" ]
                        then
                                cp -pf "/etc/config/adblock" "/etc/config/adblock-backup"
                        fi
-                       cp -pf "/etc/config/adblock-opkg" "/etc/config/adblock"
+                       if [ -r "/etc/config/adblock-opkg" ]
+                       then
+                               cp -pf "/etc/config/adblock-opkg" "/etc/config/adblock"
+                       elif [ -r "/rom/etc/config/adblock" ]
+                       then
+                               cp -pf "/rom/etc/config/adblock" "/etc/config/adblock"
+                       fi
                        f_log "info" "missing or old adblock config replaced with new valid default config"
                else
                        f_log "err" "unrecoverable adblock config error, please re-install the package via opkg with the '--force-reinstall --force-maintainer' options"
@@ -242,7 +249,7 @@ f_dns()
                                adb_dnsinstance="${adb_dnsinstance:-"0"}"
                                adb_dnsuser="${adb_dnsuser:-"root"}"
                                adb_dnsdir="${adb_dnsdir:-"/etc/kresd"}"
-                               adb_dnsheader="${adb_dnsheader:-"\$TTL 2h\n@ IN SOA localhost. root.localhost. (1 6h 1h 1w 2h)\n  IN NS  localhost.\n"}"
+                               adb_dnsheader="${adb_dnsheader:-"\$TTL 2h\n@ IN SOA localhost. root.localhost. (1 6h 1h 1w 2h)\n"}"
                                adb_dnsdeny="${adb_dnsdeny:-"${adb_awk} '{print \"\"\$0\" CNAME .\\n*.\"\$0\" CNAME .\"}'"}"
                                adb_dnsallow="${adb_dnsallow:-"${adb_awk} '{print \"\"\$0\" CNAME rpz-passthru.\\n*.\"\$0\" CNAME rpz-passthru.\"}'"}"
                                adb_dnssafesearch="${adb_dnssafesearch:-"0"}"
index 425b739c287d3129f7a08b77f22cab697497f931..129835388ebd3f9c072f80846b10b5f989f47103 100644 (file)
                "descurl": "https://www.dshield.org"
        },
        "energized_blugo": {
-               "url": "https://raw.githubusercontent.com/EnergizedProtection/block/master/bluGo/formats/domains.txt",
+               "url": "https://block.energized.pro/bluGo/formats/domains.txt",
                "rule": "/^([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
                "size": "XL",
                "focus": "compilation",
-               "descurl": "https://github.com/EnergizedProtection/block"
+               "descurl": "https://energized.pro"
        },
        "energized_blu": {
-               "url": "https://raw.githubusercontent.com/EnergizedProtection/block/master/blu/formats/domains.txt",
+               "url": "https://block.energized.pro/blu/formats/domains.txt",
                "rule": "/^([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
                "size": "XL",
                "focus": "compilation",
-               "descurl": "https://github.com/EnergizedProtection/block"
+               "descurl": "https://energized.pro"
        },
        "energized_porn": {
-               "url": "https://raw.githubusercontent.com/EnergizedProtection/block/master/porn/formats/domains.txt",
+               "url": "https://block.energized.pro/porn/formats/domains.txt",
                "rule": "/^([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
                "size": "XXL",
                "focus": "compilation+porn",
-               "descurl": "https://github.com/EnergizedProtection/block"
+               "descurl": "https://energized.pro"
+       },
+       "energized_ultimate": {
+               "url": "https://block.energized.pro/ultimate/formats/domains.txt",
+               "rule": "/^([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
+               "size": "XXL",
+               "focus": "compilation",
+               "descurl": "https://energized.pro"
        },
        "energized_unified": {
-               "url": "https://raw.githubusercontent.com/EnergizedProtection/block/master/unified/formats/domains.txt",
+               "url": "https://block.energized.pro/unified/formats/domains.txt",
                "rule": "/^([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
                "size": "XXL",
                "focus": "compilation",
-               "descurl": "https://github.com/EnergizedProtection/block"
+               "descurl": "https://energized.pro"
        },
        "malwaredomains": {
                "url": "http://mirror.espoch.edu.ec/malwaredomains/justdomains",
                "descurl": "https://bigdargon.github.io/hostsVN"
        },
        "shallalist": {
-               "url": "https://www.shallalist.de/Downloads/shallalist.tar.gz",
+               "url": "http://www.shallalist.de/Downloads/shallalist.tar.gz",
                "rule": "/^([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
                "categories": [
                                "adv", "costtraps", "spyware", "tracker", "warez"
                ],
                "size": "L",
                "focus": "general",
-               "descurl": "https://www.shallalist.de"
+               "descurl": "http://www.shallalist.de"
        },
        "shallalist_porn": {
-               "url": "https://www.shallalist.de/Downloads/shallalist.tar.gz",
+               "url": "http://www.shallalist.de/Downloads/shallalist.tar.gz",
                "rule": "/^([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
                "categories": [
                                "adv", "costtraps", "porn", "spyware", "tracker", "warez"
                ],
                "size": "XXL",
                "focus": "general+porn",
-               "descurl": "https://www.shallalist.de"
+               "descurl": "http://www.shallalist.de"
        },
        "smarttv": {
                "url": "https://raw.githubusercontent.com/Perflyst/PiHoleBlocklist/master/SmartTV.txt",
                "descurl": "https://github.com/Dawsey21"
        },
        "stevenblack": {
+               "url": "https://raw.githubusercontent.com/StevenBlack/hosts/master/hosts",
+               "rule": "/^0\\.0\\.0\\.0[[:space:]]+([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($2)}",
+               "size": "L",
+               "focus": "compilation",
+               "descurl": "https://github.com/StevenBlack/hosts"
+       },
+       "stevenblack_porn": {
                "url": "https://raw.githubusercontent.com/StevenBlack/hosts/master/alternates/fakenews-gambling-porn-social/hosts",
                "rule": "/^0\\.0\\.0\\.0[[:space:]]+([[:alnum:]_-]+\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($2)}",
                "size": "L",
index 45ff9dbd05c713b05ec8405457715389fb9aac2f..beab6220989f08d9343958715c46849e38ada78d 100644 (file)
@@ -5,13 +5,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dawn
-PKG_SOURCE_DATE:=2020-04-17
-PKG_RELEASE:=2
+PKG_SOURCE_DATE:=2020-05-20
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/berlin-open-wireless-lab/DAWN.git
-PKG_SOURCE_VERSION:=2ff3b3017fc5e5477f494e6aa85d6b0b4acd68bb
-PKG_MIRROR_HASH:=b9260dad56f40a371157a6d9c54ac295bdbfc5f853915df18e4152eb8f3110f9
+PKG_SOURCE_VERSION:=73c79989676f5b89f4547f4effc4497f5aaeea44
+PKG_MIRROR_HASH:=a5bf4bf58e3352316800a1f5d4cfb750a09f4f43c1494c5560d71a22fa267c55
 
 PKG_MAINTAINER:=Nick Hainke <vincent@systemli.org>
 PKG_LICENSE:=GPL-2.0-only
index f31c5f3b83c3b8af74f902febb17e07bfed9945f..0a5c37992963875e749799546452679adcacb7db 100644 (file)
@@ -142,7 +142,9 @@ CONFIGURE_ARGS += \
        --enable-capabilities \
        --disable-examples
 
-TARGET_CFLAGS += -minterlink-mips16
+ifdef CONFIG_USE_MIPS16
+  TARGET_CFLAGS += -minterlink-mips16
+endif
 TARGET_LDFLAGS += -lgcc_eh
 
 define Build/InstallDev