mtr: fix UNKNOWN version reporting
authorYousong Zhou <yszhou4tech@gmail.com>
Wed, 16 Jan 2019 02:27:09 +0000 (02:27 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Wed, 16 Jan 2019 02:53:08 +0000 (02:53 +0000)
Supersedes openwrt/packages#7634

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
net/mtr/Makefile

index 67921de4c776b85e65ab1cebb43f83e15ee37307..6743e190b64260e3955623435c455ae3075dd446 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtr
 PKG_VERSION:=0.92
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.bitwizard.nl/mtr/files
@@ -26,6 +26,16 @@ PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
+# Creation of .tarball-version is an attempt to make it explicit to configure
+# script the program version.  See discussions at link [1] for more details
+#
+#  [1] mtr: add autoreconf, https://github.com/openwrt/packages/pull/6962#issuecomment-419156300
+#
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       echo "$(PKG_VERSION)" >$(PKG_BUILD_DIR)/.tarball-version
+endef
+
 define Package/mtr
   SECTION:=net
   CATEGORY:=Network