Add uclibc++ 0.2.0
authorFlorian Fainelli <florian@openwrt.org>
Sat, 1 Jul 2006 09:35:15 +0000 (09:35 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 1 Jul 2006 09:35:15 +0000 (09:35 +0000)
SVN-Revision: 4101

libs/uclibc++/Makefile [new file with mode: 0644]
libs/uclibc++/files/config.i386 [new file with mode: 0644]
libs/uclibc++/files/config.mips [new file with mode: 0644]

diff --git a/libs/uclibc++/Makefile b/libs/uclibc++/Makefile
new file mode 100644 (file)
index 0000000..b006c84
--- /dev/null
@@ -0,0 +1,83 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 3843 2006-05-30 18:55:52Z florian $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=uclibc++
+PKG_VERSION:=0.2.0
+PKG_RELEASE:=1
+PKG_MD5SUM:=33e01302511c9a1987fb104f12d173e1
+
+PKG_SOURCE_URL:=http://cxx.uclibc.org/src/
+PKG_SOURCE:=uClibc++-$(PKG_VERSION).tbz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/uClibc++-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/uclibcxx
+NAME:=uclibc++
+SECTION:=libs
+CATEGORY:=Libraries
+TITLE:=C++ library for embedded systems
+DESCRIPTION:=A standard C++ library for embedded systems
+URL:=http://cxx.uclibc.org/src/
+endef
+
+UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
+                -e 's/i.86/i386/' \
+                -e 's/sparc.*/sparc/' \
+                -e 's/arm.*/arm/g' \
+                -e 's/m68k.*/m68k/' \
+                -e 's/ppc/powerpc/g' \
+                -e 's/v850.*/v850/g' \
+                -e 's/sh64/sh/' \
+                -e 's/sh[234].*/sh/' \
+                -e 's/mips.*/mips/' \
+                -e 's/mipsel.*/mips/' \
+                -e 's/cris.*/cris/' \
+)
+
+define Build/Configure
+       cp ./files/config.$(UCLIBC_TARGET_ARCH) $(PKG_BUILD_DIR)/.config
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               TOPDIR="$(PKG_BUILD_DIR)/" \
+               $(TARGET_CONFIGURE_OPTS) \
+               ARCH_CFLAGS="$(TARGET_CFLAGS)" \
+               CROSS="$(TARGET_CROSS)" \
+               all
+endef
+
+define Package/uclibcxx/install
+       install -m0755 -d $(1)/lib
+       $(CP) $(PKG_BUILD_DIR)/src/libuClibc++*.so.* $(1)/lib/
+endef
+
+define Build/InstallDev
+       mkdir -p $(STAGING_DIR)/usr/include
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               TOPDIR="$(PKG_BUILD_DIR)/" \
+                $(TARGET_CONFIGURE_OPTS) \
+                ARCH_CFLAGS="$(TARGET_CFLAGS)" \
+                CROSS="$(TARGET_CROSS)" \
+               DESTDIR="$(STAGING_DIR)" \
+               install
+endef
+       
+define Build/UninstallDev
+       rm -rf $(STAGING_DIR)/usr/lib/libuClibc++.{a,so*}
+endef
+
+$(eval $(call BuildPackage,uclibcxx))
diff --git a/libs/uclibc++/files/config.i386 b/libs/uclibc++/files/config.i386
new file mode 100644 (file)
index 0000000..e90d77e
--- /dev/null
@@ -0,0 +1,87 @@
+#
+# Automatically generated make config: don't edit
+#
+# TARGET_alpha is not set
+# TARGET_arm is not set
+TARGET_i386=y
+# TARGET_mips is not set
+# TARGET_parisc is not set
+# TARGET_powerpc is not set
+# TARGET_x86_64 is not set
+
+#
+# Target Architecture Features and Options
+#
+TARGET_ARCH="i386"
+ARCH_SUPPORTS_LITTLE_ENDIAN=y
+CONFIG_GENERIC_386=y
+# CONFIG_386 is not set
+# CONFIG_486 is not set
+# CONFIG_586 is not set
+# CONFIG_586MMX is not set
+# CONFIG_686 is not set
+# CONFIG_PENTIUMIII is not set
+# CONFIG_PENTIUM4 is not set
+# CONFIG_K6 is not set
+# CONFIG_K7 is not set
+# CONFIG_CRUSOE is not set
+# CONFIG_WINCHIPC6 is not set
+# CONFIG_WINCHIP2 is not set
+# CONFIG_CYRIXIII is not set
+# CONFIG_MIPS_ISA_1 is not set
+# CONFIG_MIPS_ISA_2 is not set
+# CONFIG_MIPS_ISA_3 is not set
+# CONFIG_MIPS_ISA_4 is not set
+# CONFIG_MIPS_ISA_MIPS32 is not set
+# CONFIG_MIPS_ISA_MIPS64 is not set
+ARCH_LITTLE_ENDIAN=y
+# ARCH_BIG_ENDIAN is not set
+UCLIBCXX_HAS_FLOATS=y
+UCLIBCXX_HAS_LONG_DOUBLE=y
+WARNINGS="-Wall"
+HAVE_DOT_CONFIG=y
+
+#
+# String and I/O Stream Support
+#
+UCLIBCXX_HAS_WCHAR=y
+UCLIBCXX_IOSTREAM_BUFSIZE=32
+UCLIBCXX_HAS_LFS=y
+UCLIBCXX_SUPPORT_CDIR=y
+UCLIBCXX_SUPPORT_CIN=y
+UCLIBCXX_SUPPORT_COUT=y
+UCLIBCXX_SUPPORT_CERR=y
+UCLIBCXX_SUPPORT_CLOG=y
+UCLIBCXX_SUPPORT_WCIN=y
+UCLIBCXX_SUPPORT_WCOUT=y
+UCLIBCXX_SUPPORT_WCERR=y
+UCLIBCXX_SUPPORT_WCLOG=y
+
+#
+# STL and Code Expansion
+#
+UCLIBCXX_STL_BUFFER_SIZE=32
+UCLIBCXX_CODE_EXPANSION=y
+UCLIBCXX_EXPAND_CONSTRUCTORS_DESTRUCTORS=y
+UCLIBCXX_EXPAND_STRING_CHAR=y
+UCLIBCXX_EXPAND_VECTOR_BASIC=y
+UCLIBCXX_EXPAND_IOS_CHAR=y
+UCLIBCXX_EXPAND_STREAMBUF_CHAR=y
+UCLIBCXX_EXPAND_ISTREAM_CHAR=y
+UCLIBCXX_EXPAND_OSTREAM_CHAR=y
+UCLIBCXX_EXPAND_FSTREAM_CHAR=y
+UCLIBCXX_EXPAND_SSTREAM_CHAR=y
+
+#
+# Library Installation Options
+#
+UCLIBCXX_RUNTIME_PREFIX=""
+UCLIBCXX_RUNTIME_INCLUDE_SUBDIR="/include"
+UCLIBCXX_RUNTIME_LIB_SUBDIR="/lib"
+UCLIBCXX_RUNTIME_BIN_SUBDIR="/bin"
+UCLIBCXX_EXCEPTION_SUPPORT=y
+IMPORT_LIBSUP=y
+# IMPORT_LIBGCC_EH is not set
+BUILD_STATIC_LIB=y
+# BUILD_ONLY_STATIC_LIB is not set
+# DODEBUG is not set
diff --git a/libs/uclibc++/files/config.mips b/libs/uclibc++/files/config.mips
new file mode 100644 (file)
index 0000000..9137af6
--- /dev/null
@@ -0,0 +1,75 @@
+#
+# Automatically generated make config: don't edit
+#
+# TARGET_alpha is not set
+# TARGET_arm is not set
+# TARGET_i386 is not set
+TARGET_mips=y
+# TARGET_parisc is not set
+# TARGET_powerpc is not set
+# TARGET_x86_64 is not set
+
+#
+# Target Architecture Features and Options
+#
+TARGET_ARCH="mips"
+ARCH_SUPPORTS_LITTLE_ENDIAN=y
+ARCH_CFLAGS="-mno-split-addresses"
+ARCH_SUPPORTS_BIG_ENDIAN=y
+# CONFIG_MIPS_ISA_1 is not set
+# CONFIG_MIPS_ISA_2 is not set
+# CONFIG_MIPS_ISA_3 is not set
+# CONFIG_MIPS_ISA_4 is not set
+CONFIG_MIPS_ISA_MIPS32=y
+# CONFIG_MIPS_ISA_MIPS64 is not set
+ARCH_LITTLE_ENDIAN=y
+# ARCH_BIG_ENDIAN is not set
+UCLIBCXX_HAS_FLOATS=y
+# UCLIBCXX_HAS_LONG_DOUBLE is not set
+WARNINGS="-Wall"
+HAVE_DOT_CONFIG=y
+
+#
+# String and I/O Stream Support
+#
+UCLIBCXX_HAS_WCHAR=y
+UCLIBCXX_IOSTREAM_BUFSIZE=32
+UCLIBCXX_HAS_LFS=y
+UCLIBCXX_SUPPORT_CDIR=y
+UCLIBCXX_SUPPORT_CIN=y
+UCLIBCXX_SUPPORT_COUT=y
+UCLIBCXX_SUPPORT_CERR=y
+UCLIBCXX_SUPPORT_CLOG=y
+UCLIBCXX_SUPPORT_WCIN=y
+UCLIBCXX_SUPPORT_WCOUT=y
+UCLIBCXX_SUPPORT_WCERR=y
+UCLIBCXX_SUPPORT_WCLOG=y
+
+#
+# STL and Code Expansion
+#
+UCLIBCXX_STL_BUFFER_SIZE=32
+UCLIBCXX_CODE_EXPANSION=y
+UCLIBCXX_EXPAND_CONSTRUCTORS_DESTRUCTORS=y
+UCLIBCXX_EXPAND_STRING_CHAR=y
+UCLIBCXX_EXPAND_VECTOR_BASIC=y
+UCLIBCXX_EXPAND_IOS_CHAR=y
+UCLIBCXX_EXPAND_STREAMBUF_CHAR=y
+UCLIBCXX_EXPAND_ISTREAM_CHAR=y
+UCLIBCXX_EXPAND_OSTREAM_CHAR=y
+UCLIBCXX_EXPAND_FSTREAM_CHAR=y
+UCLIBCXX_EXPAND_SSTREAM_CHAR=y
+
+#
+# Library Installation Options
+#
+UCLIBCXX_RUNTIME_PREFIX=""
+UCLIBCXX_RUNTIME_INCLUDE_SUBDIR="/include"
+UCLIBCXX_RUNTIME_LIB_SUBDIR="/lib"
+UCLIBCXX_RUNTIME_BIN_SUBDIR="/bin"
+UCLIBCXX_EXCEPTION_SUPPORT=y
+IMPORT_LIBSUP=y
+# IMPORT_LIBGCC_EH is not set
+BUILD_STATIC_LIB=y
+# BUILD_ONLY_STATIC_LIB is not set
+# DODEBUG is not set