Merge pull request #19 from dangowrt/packages-updates
authorMirko Vogt <mirko-openwrt@nanl.de>
Wed, 24 Nov 2021 15:40:25 +0000 (16:40 +0100)
committerGitHub <noreply@github.com>
Wed, 24 Nov 2021 15:40:25 +0000 (16:40 +0100)
update some packages

frameworks/wayland-protocols/Makefile
frameworks/wayland/Makefile
frameworks/wayland/patches/001-fix-wayland-scanner-detect.patch
libs/mesa/Makefile
libs/mesa/patches/001-fix-wayland-scanner-detect.patch
libs/pango/Makefile
libs/seatd/Makefile
libs/seatd/files/seatd.init [new file with mode: 0644]
libs/weston/Makefile

index b5a159e98550cda6bd621aa9be987d092a8b33cc..446cae4388a678e1d459ae06bb3a058eb16d67df 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wayland-protocols
-PKG_VERSION:=1.21
+PKG_VERSION:=1.24
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://wayland.freedesktop.org/releases/
-PKG_HASH:=b99945842d8be18817c26ee77dafa157883af89268e15f4a5a1a1ff3ffa4cde5
+PKG_HASH:=bff0d8cffeeceb35159d6f4aa6bab18c807b80642c9d50f66cba52ecf7338bc2
 
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=MIT
@@ -15,6 +15,7 @@ PKG_LICENSE_FILES:=COPYING
 PKG_INSTALL:=1
 
 PKG_BUILD_DEPENDS:=wayland
+HOST_BUILD_DEPENDS:=wayland/host
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/meson.mk
index 05be356c9228dc10f798811a2680e4749efb0d87..48d53bd248e0538320fdc85338706f7f12f9d46d 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wayland
-PKG_VERSION:=1.19.0
+PKG_VERSION:=1.19.92
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=https://wayland.freedesktop.org/releases/
-PKG_HASH:=baccd902300d354581cd5ad3cc49daa4921d55fb416a5883e218750fef166d15
+PKG_SOURCE_URL:=https://wayland.freedesktop.org/releases
+PKG_HASH:=f8cbd8a8c713ed393e63e7c6ac81c6b9ef5a49a2b631717377fa78b80ac34cfa
 
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=MIT
@@ -14,6 +14,7 @@ PKG_LICENSE_FILES:=COPYING
 
 PKG_INSTALL:=1
 PKG_BUILD_DEPENDS:=libffi/host libxml2/host expat/host wayland/host
+HOST_BUILD_DEPENDS:=$(PKG_BUILD_DEPENDS)
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
@@ -49,6 +50,8 @@ MESON_HOST_ARGS += \
        -Ddocumentation=false \
        -Ddtd_validation=true
 
+HOST_LDFLAGS += $(STAGING_DIR_HOST)/lib/libz.a -lm
+
 MESON_ARGS += \
        -Dscanner=true \
        -Dlibraries=true \
index b9d462fccd022147b69b89b8cb705cae91813549..6a066019928864c7abccd0609f698fd959b582b5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/meson.build
 +++ b/src/meson.build
-@@ -59,8 +59,12 @@ if get_option('scanner')
+@@ -70,8 +70,12 @@ if get_option('scanner')
  endif
  
  if meson.is_cross_build() or not get_option('scanner')
@@ -17,8 +17,8 @@
  endif
 --- a/meson_options.txt
 +++ b/meson_options.txt
-@@ -6,6 +6,10 @@ option('scanner',
-   description: 'Compile wayland-scanner binary',
+@@ -10,6 +10,10 @@ option('tests',
+   description: 'Compile Wayland tests',
    type: 'boolean',
    value: 'true')
 +option('scanner_bin',
index c61f558d9ee59287285f1e5b615089e849524ed8..66220d3c62947501a121effdb5a8dd2aef20566a 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mesa
-PKG_VERSION:=21.1.7
+PKG_VERSION:=21.3.0
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://archive.mesa3d.org/
-PKG_HASH:=e9e67c10654f2e4bf15b944bb048007a614292aa4792b1b7512eb700b7b3a7bb
+PKG_HASH:=a2753c09deef0ba14d35ae8a2ceff3fe5cd13698928c7bb62c2ec8736eb09ce1
 
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=BSD-3-Clause
@@ -70,7 +70,7 @@ define Package/libxatracker
   SUBMENU:=Video
   TITLE:=Mesa3D libxatracker
   URL:=https://www.mesa3d.org
-  DEPENDS:=+libstdcpp +zlib +libdrm +libexpat
+  DEPENDS:=+libstdcpp +zlib +libdrm +libexpat @(aarch64||arm||i386||i686||x86_64)
 endef
 
 define Package/libxatracker/description
@@ -116,7 +116,7 @@ define Package/libvulkan-broadcom
   SECTION:=libs
   CATEGORY:=Libraries
   SUBMENU:=Video
-  DEPENDS:=libmesa @(arm||aarch64)
+  DEPENDS:=libmesa @(arm||aarch64) @BROKEN
   TITLE:=Broadcom Vulkan driver
   URL:=https://www.mesa3d.org
 endef
@@ -169,7 +169,6 @@ GALLIUM_DRIVERS:=kmsro swrast vc4 virgl
 
 ifneq ($(CONFIG_LIBDRM_INTEL),)
   DRI_DRIVERS+=i965
-  VULKAN_DRIVERS+=intel
   GALLIUM_DRIVERS+=i915
 endif
 
@@ -184,21 +183,8 @@ ifneq ($(CONFIG_LIBDRM_RADEON),)
 # r600 and radeonsi require LLVM
 endif
 
-ifeq ($(ARCH),x86_64)
-  GALLIUM_DRIVERS+=svga
-endif
-
-ifeq ($(ARCH),i386)
-  GALLIUM_DRIVERS+=svga
-endif
-
-ifeq ($(ARCH),i686)
-  GALLIUM_DRIVERS+=svga
-endif
-
 ifeq ($(ARCH),aarch64)
   GALLIUM_DRIVERS+=freedreno etnaviv panfrost lima
-  VULKAN_DRIVERS+=broadcom freedreno
 ifneq ($(CONFIG_LIBDRM_NOUVEAU),)
   GALLIUM_DRIVERS+=tegra
 endif
@@ -206,7 +192,6 @@ endif
 
 ifeq ($(ARCH),arm)
   GALLIUM_DRIVERS+=freedreno etnaviv panfrost lima
-  VULKAN_DRIVERS+=broadcom freedreno
 ifneq ($(CONFIG_LIBDRM_NOUVEAU),)
   GALLIUM_DRIVERS+=tegra
 endif
@@ -220,6 +205,29 @@ ifeq ($(ARCH),mipsel)
   GALLIUM_DRIVERS+=etnaviv
 endif
 
+ifeq ($(ARCH),x86_64)
+  GALLIUM_DRIVERS+=svga
+endif
+
+ifeq ($(ARCH),i386)
+  GALLIUM_DRIVERS+=svga
+endif
+
+ifeq ($(ARCH),i686)
+  GALLIUM_DRIVERS+=svga
+endif
+
+ifneq ($(CONFIG_PACKAGE_libvulkan-broadcom),)
+  VULKAN_DRIVERS+=broadcom
+endif
+
+ifneq ($(CONFIG_PACKAGE_libvulkan-freedreno),)
+  VULKAN_DRIVERS+=freedreno
+endif
+
+ifneq ($(CONFIG_PACKAGE_libvulkan-intel),)
+  VULKAN_DRIVERS+=intel
+endif
 
 MESON_ARGS += \
        -Dplatforms=wayland \
@@ -242,6 +250,8 @@ MESON_ARGS += \
        -Ddraw-use-llvm=false \
        -Dscanner_bin="$(STAGING_DIR_HOSTPKG)/bin/wayland-scanner"
 
+TARGET_CFLAGS += -I$(MESON_BUILD_DIR)/src/broadcom/
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
index 482c6bcc63d2eb850a7b49832e771c9709e82fbb..278a47931b5e9b04cac50b21c1686577b44a3b0f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/meson.build
 +++ b/meson.build
-@@ -1830,12 +1830,17 @@ endif
+@@ -1973,12 +1973,17 @@ endif
  # TODO: symbol mangling
  
  if with_platform_wayland
@@ -25,7 +25,7 @@
    dep_wayland_client = dependency('wayland-client', version : '>=1.18')
 --- a/meson_options.txt
 +++ b/meson_options.txt
-@@ -456,6 +456,11 @@ option(
+@@ -486,6 +486,11 @@ option(
    value : 25,
    description : 'Android Platform SDK version. Default: Nougat version.'
  )
index 25c74f8e99f00d7ac0cd4649fa462c62f9c8283c..af8117d171fdcefaf075e4ab40b3769279100ddd 100644 (file)
@@ -30,12 +30,8 @@ define Package/libpango
 endef
 
 MESON_ARGS += \
-       -Dgnome=false \
        -Dintrospection=disabled \
-       -Dvapi=disabled \
        -Dgtk_doc=false \
-       -Dtests=false \
-       -Dinstalled_tests=false \
        -Dsysprof=disabled
 
 define package/libpango/decription
index f2cd1db33db6f99f987b2834d501976ce6ed966c..0f830ba6dd90bb5c0f7900c74732c25f70882ed2 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=seatd
-PKG_VERSION:=0.5.0
+PKG_VERSION:=0.6.3
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://git.sr.ht/~kennylevinsen/seatd
 PKG_SOURCE_VERSION:=$(PKG_VERSION)
-PKG_MIRROR_HASH:=9b899307e8717dc21735b02c80ebc91d6925c6bc5037f4a438d01258f472bc77
+PKG_MIRROR_HASH:=f3bcdf68b67ec48e637851031a839bff1835ca8462a03fa4f7556f431217af37
 
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=MIT
@@ -27,6 +27,7 @@ define Package/libseat
 endef
 
 define Package/libseat/description
+  A universal seat management library.
 endef
 
 define Package/seatd
@@ -39,12 +40,13 @@ define Package/seatd
 endef
 
 define Package/seatd/description
+  A minimal seat management daemon.
 endef
 
 MESON_ARGS += \
-       -Dlogind=disabled \
-       -Dseatd=enabled \
-       -Dbuiltin=disabled \
+       -Dlibseat-logind=disabled \
+       -Dlibseat-seatd=enabled \
+       -Dlibseat-builtin=disabled \
        -Dserver=enabled \
        -Dexamples=disabled \
        -Dman-pages=disabled \
@@ -67,6 +69,8 @@ endef
 define Package/seatd/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/seatd $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/seatd.init $(1)/etc/init.d/seatd
 endef
 
 $(eval $(call BuildPackage,libseat))
diff --git a/libs/seatd/files/seatd.init b/libs/seatd/files/seatd.init
new file mode 100644 (file)
index 0000000..f2d1006
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/sh /etc/rc.common
+
+START=90
+STOP=10
+
+USE_PROCD=1
+PROG=/usr/bin/seatd
+
+start_service() {
+       procd_open_instance
+       procd_set_param command "$PROG"
+       procd_close_instance
+}
index 406b55583cb670609ad5e4cd11265ba9f6b079a4..daf5ae1f16f92fd2dadfebb92fb88bd1e2321cd3 100644 (file)
@@ -10,10 +10,10 @@ PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://gitlab.freedesktop.org/wayland/weston.git
-PKG_SOURCE_DATE:=2021-08-13
+PKG_SOURCE_DATE:=2021-11-23
 PKG_VERSION:=10.0.0~pre0-$(PKG_SOURCE_DATE)
-PKG_SOURCE_VERSION:=d259bbeccdd321b5327537ddcdde06b8c5671d48
-PKG_MIRROR_HASH:=45f6f7ff0a18f11222a09813064ef1a4bc6539eee4e73430d93ce38feea9c9cc
+PKG_SOURCE_VERSION:=a8827940274391d658ef2ea69bce4fade45bff5f
+PKG_MIRROR_HASH:=a24b98f7a1ae5a75a690af81a5b194d20379679c4e7be33867d8edb8f3b2bc7d
 
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=MIT