krb5: install krb5-config to host 14163/head
authorRosen Penev <rosenp@gmail.com>
Tue, 8 Dec 2020 02:47:49 +0000 (18:47 -0800)
committerRosen Penev <rosenp@gmail.com>
Tue, 8 Dec 2020 04:10:13 +0000 (20:10 -0800)
Helps old packages that don't use pkgconfig.

Fix prefix paths.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/krb5/Makefile

index 54bf36c594f73a56b357869abd688283a611d576..6ea88b0ddec9c55fe41006400bb83a22fcd924a5 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=krb5
 PKG_VERSION:=1.18.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
@@ -102,6 +102,9 @@ define Build/InstallDev
        # needed for samba4, to detect system-krb5
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/krb5-config $(1)/usr/bin
+       $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(1)/usr/bin/krb5-config
+       $(INSTALL_DIR) $(2)/bin
+       $(LN) ../../usr/bin/krb5-config $(2)/bin/krb5-config
 endef
 
 define Package/krb5-libs/install