clamsmtp: Really fix compilation 8773/head
authorRosen Penev <rosenp@gmail.com>
Mon, 12 Nov 2018 20:32:14 +0000 (12:32 -0800)
committerRosen Penev <rosenp@gmail.com>
Tue, 23 Apr 2019 18:46:45 +0000 (11:46 -0700)
It seems Linux headers are broken/incompatible with musl for some reason.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
mail/clamsmtp/Makefile
mail/clamsmtp/patches/010-fix-build.patch [new file with mode: 0644]

index 449594b35b19cbc04acb74a81f7f88cea35d48d8..3eb6d88beb859785823a8eac9042878e98f9fabd 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=clamsmtp
 PKG_VERSION:=1.10
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE_URL:=http://thewalter.net/stef/software/clamsmtp/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/mail/clamsmtp/patches/010-fix-build.patch b/mail/clamsmtp/patches/010-fix-build.patch
new file mode 100644 (file)
index 0000000..a285a77
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/configure.in
++++ b/configure.in
+@@ -78,16 +78,6 @@ AC_CHECK_HEADERS([limits.h err.h paths.h],,)
+ AC_CHECK_HEADERS([unistd.h stdio.h stddef.h fcntl.h stdlib.h assert.h errno.h stdarg.h string.h netdb.h], ,
+     [echo "ERROR: Required C header missing"; exit 1])
+-# Check for linux type transparent proxy support
+-AC_CHECK_HEADERS([linux/netfilter_ipv4.h],
+-   AC_DEFINE(LINUX_TRANSPARENT_PROXY, 1, [Whether the system supports a linux type transparent proxy]),
+-   , 
+-   [[
+-   #ifdef HAVE_LIMITS_H
+-   #include <limits.h>
+-   #endif
+-   ]] )
+-
+ # Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+ AC_TYPE_SIZE_T