[packages_10.03.2] sqlite3: merge r28481, r29154, r29736
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 4 Feb 2012 18:50:46 +0000 (18:50 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 4 Feb 2012 18:50:46 +0000 (18:50 +0000)
SVN-Revision: 30065

libs/sqlite3/Makefile

index a2101db4ede748db225aecc59f12007d04befc0c..481951bc64e48fad6afddb09a8b61996f27a54e8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sqlite
-PKG_VERSION:=3070701
+PKG_VERSION:=3070900
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-autoconf-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sqlite.org
-PKG_MD5SUM:=554026fe7fac47b1cf61c18d5fe43419
+PKG_MD5SUM:=dce303524736fe89a76b8ed29d566352
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-autoconf-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=libncurses libreadline
@@ -64,7 +64,8 @@ $(call Package/sqlite3/Default/description)
  formats.
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) \
+       -DSQLITE_ENABLE_UNLOCK_NOTIFY \
 
 CONFIGURE_ARGS += \
        --enable-shared \
@@ -80,7 +81,7 @@ CONFIGURE_VARS += \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite3.h $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/sqlite3{,ext}.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsqlite3.{a,so*} $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig