Merge pull request #12964 from neheb/bim
authorRosen Penev <rosenp@gmail.com>
Wed, 29 Jul 2020 23:34:29 +0000 (16:34 -0700)
committerGitHub <noreply@github.com>
Wed, 29 Jul 2020 23:34:29 +0000 (16:34 -0700)
vim: update to 8.2

libs/libqmi/Makefile
libs/libupnp/Makefile
libs/zmq/Makefile
net/fping/Makefile
net/fping/patches/010-ipv6.patch [deleted file]
utils/ttyd/Makefile
utils/ttyd/patches/100-log-to-syslog.patch

index c118a9955f22944b877a1d7151ea74f896c4c624..9d46a76b47f029e1c77eae3b1f582914e3956c2b 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libqmi
-PKG_VERSION:=1.26.0
+PKG_VERSION:=1.26.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://www.freedesktop.org/software/libqmi
-PKG_HASH:=7f0429e0ae58792e21512d09ca2412537840ea42696762795af1284a65fd6e40
+PKG_HASH:=133467b2fe0706850eb587c0103ae6e61b97ce6e2c440d66358f2b72b0db7b03
 
 PKG_MAINTAINER:=Nicholas Smith <nicholas.smith@telcoantennas.com.au>
 
index 951ba5a050a6344685097286bd91ec8c1cb14036..4041d69054569b0dde060376a1b98a175391d5be 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libupnp
-PKG_VERSION:=1.12.1
+PKG_VERSION:=1.14.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/pupnp
-PKG_HASH:=fc36642b1848fe5a81296d496291d350ecfc12b85fd0b268478ab230976d4009
+PKG_HASH:=ecb23d4291968c8a7bdd4eb16fc2250dbacc16b354345a13342d67f571d35ceb
 
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
 PKG_LICENSE:=BSD-3-Clause
@@ -67,9 +67,6 @@ CONFIGURE_ARGS += \
        --disable-scriptsupport \
        --disable-postwrite
 
-TARGET_CFLAGS += -flto
-TARGET_LDFLAGS += -flto
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/upnp $(1)/usr/include/
index 2e9778429bf784fbbe0b19b04af2f583da2369db..1754af8801993e348973a30666a4e7c71f9438d7 100644 (file)
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zeromq
 PKG_VERSION:=4.3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/zeromq/libzmq/releases/download/v$(PKG_VERSION)
@@ -91,6 +91,8 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libzmq.so* $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libzmq.pc $(1)/usr/lib/pkgconfig/
+       $(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/libzmq.pc
+       $(SED) 's,/usr/lib,$$$${exec_prefix}/lib,g' $(1)/usr/lib/pkgconfig/libzmq.pc
 endef
 
 define Package/libzmq-nc/install
index 8bd0bc2e108463ac59c5fba8245626adedc37885..3c0c9782d1de09314d3f2f46d22e07e19659ac97 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fping
-PKG_VERSION:=4.3
+PKG_VERSION:=4.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://fping.org/dist/
-PKG_HASH:=92040ae842f7b8942d5cf26d8f58702a8d84c40a1fd492b415bd01b622bf372d
+PKG_HASH:=9f854b65a52dc7b1749d6743e35d0a6268179d1a724267339fc9a066b2b72d11
 
 PKG_MAINTAINER:=Nikil Mehta <nikil.mehta@gmail.com>
 PKG_LICENSE:=BSD-4-Clause
@@ -31,17 +31,16 @@ define Package/fping
   URL:=https://fping.org/
 endef
 
-
 define Package/fping/description
-       fping is a ping like program which uses the Internet Control Message Protocol
-       (ICMP) echo request to determine if a target host is responding.  fping
-       differs from ping in that you can specify any number of targets on the command
-       line, or specify a file containing the lists of targets to ping.  Instead of
-       sending to one target until it times out or replies, fping will send out a
-       ping packet and move on to the next target in a round-robin fashion.
+  fping is a ping like program which uses the Internet Control Message Protocol
+  (ICMP) echo request to determine if a target host is responding.  fping
+  differs from ping in that you can specify any number of targets on the command
+  line, or specify a file containing the lists of targets to ping.  Instead of
+  sending to one target until it times out or replies, fping will send out a
+  ping packet and move on to the next target in a round-robin fashion.
 endef
 
-CONFIGURE_ARGS+= \
+CONFIGURE_ARGS += \
        --enable-ipv4 \
        $(if $(CONFIG_IPV6),en,dis)able-ipv6
 
diff --git a/net/fping/patches/010-ipv6.patch b/net/fping/patches/010-ipv6.patch
deleted file mode 100644 (file)
index 5eba631..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From 54e97d9e393e375820e9c6ca0a56c7a4092ea5de Mon Sep 17 00:00:00 2001
-From: Lars Wendler <polynomial-c@gentoo.org>
-Date: Sun, 12 Jul 2020 13:55:44 +0200
-Subject: [PATCH] Fix build with --disable-ipv6
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Otherwise build breaks with:
-
-fping.c:399:14: error: ‘ident6’ undeclared (first use in this function); did you mean ‘ident4’?
-  399 |     ident4 = ident6 = getpid() & 0xFFFF;
-      |              ^~~~~~
-      |              ident4
-
-Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
----
- src/fping.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/fping.c b/src/fping.c
-index 3522123..4304531 100644
---- a/src/fping.c
-+++ b/src/fping.c
-@@ -258,12 +258,12 @@ HOST_ENTRY* ev_last;
- char* prog;
- int ident4 = 0; /* our icmp identity field */
-+int ident6 = 0;
- int socket4 = -1;
- int using_sock_dgram4 = 0;
- #ifndef IPV6
- int hints_ai_family = AF_INET;
- #else
--int ident6 = 0;
- int socket6 = -1;
- int hints_ai_family = AF_UNSPEC;
- #endif
index 71e6f122cbed813a9a9d1ae1396474ab97971127..2e195f8216519ff23c1475bf30ffc26b492afa32 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ttyd
-PKG_VERSION:=1.6.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.6.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/tsl0922/ttyd/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=d14740bc82be0d0760dd0a3c97acbcbde490412a4edc61edabe46d311b068f83
+PKG_HASH:=d72dcca3dec00cda87b80a0a25ae4fee2f8b9098c1cdb558508dcb14fbb6fafc
 
 PKG_MAINTAINER:=Shuanglei Tao <tsl0922@gmail.com>
 PKG_LICENSE:=MIT
index 392673270f82afce0f4e0d3e70d7e562a2bf30d4..04a3027c2a40e73b3ebc2a58b03e4f345e29ad0b 100644 (file)
@@ -1,20 +1,20 @@
 --- a/src/server.c
 +++ b/src/server.c
-@@ -6,6 +6,7 @@
- #include <getopt.h>
- #include <signal.h>
+@@ -10,6 +10,7 @@
+ #include <stdlib.h>
+ #include <string.h>
  #include <sys/stat.h>
 +#include <syslog.h>
  
- #include <libwebsockets.h>
- #include <json.h>
-@@ -418,7 +419,8 @@ main(int argc, char **argv) {
-         return -1;
-     }
+ #include "utils.h"
  
--    lws_set_log_level(debug_level, NULL);
-+    openlog("ttyd", LOG_NDELAY | LOG_PID, LOG_DAEMON);
-+    lws_set_log_level(debug_level, lwsl_emit_syslog);
+@@ -441,7 +442,8 @@ int main(int argc, char **argv) {
+     return -1;
+   }
+-  lws_set_log_level(debug_level, NULL);
++  openlog("ttyd", LOG_NDELAY | LOG_PID, LOG_DAEMON);
++  lws_set_log_level(debug_level, lwsl_emit_syslog);
  
  #if LWS_LIBRARY_VERSION_MAJOR >= 2
-     char server_hdr[128] = "";
+   char server_hdr[128] = "";