nss: fix compilation with QUILT 15222/head
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Sun, 21 Mar 2021 15:28:54 +0000 (12:28 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Mon, 22 Mar 2021 11:23:29 +0000 (08:23 -0300)
Commit 657574f45 disabled building the host nsinstall program when using
QUILT.  However, the host nsinstall is needed to compile the package,
breaking compilation with QUILT.

Move the native compile to Build/Configure, which will not be called for
prepare, refresh, or update targets, but will be called before
Build/Compile.

nss does not have a configure script, so Build/Configure/Default is not
being called.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
libs/nss/Makefile

index 7aa48a66b9c851d801e10259e5a6f848384017a0..b7592263799915eeb51855aeaf74e79b6b9bc3de 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nss
 PKG_VERSION:=3.61
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
@@ -91,13 +91,10 @@ MAKE_FLAGS += \
        OS_REL_CFLAGS="$(TARGET_CFLAGS)"
 
 #native compile nsinstall
-define Build/Prepare
-       $(call Build/Prepare/Default)
-ifeq ($(QUILT),)
+define Build/Configure
        USE_NATIVE=1 OS_REL_CFLAGS="$(HOST_CFLAGS)" LDFLAGS="$(HOST_LDFLAGS)" \
        CC="$(HOSTCC)" CPU_ARCH="$(HOST_ARCH)" \
            $(MAKE) -C $(PKG_BUILD_DIR)/nss/coreconf/nsinstall
-endif
 endef
 
 define Build/Compile