boost: Fix building without hard float (fenv.h) 1723/head
authorTed Hess <thess@kitschensync.net>
Thu, 27 Aug 2015 18:31:29 +0000 (14:31 -0400)
committerTed Hess <thess@kitschensync.net>
Thu, 27 Aug 2015 18:31:29 +0000 (14:31 -0400)
Signed-off-by: Ted Hess <thess@kitschensync.net>
libs/boost/Makefile

index 2a6e9f3e5ef21da75ba609f0da72ab4fe7e424fa..92fb68b1bba5202c9b6a1d69a7e891057136b6d0 100644 (file)
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=boost
 PKG_VERSION:=1_59_0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/boost
@@ -177,6 +177,7 @@ endef
 CONFIGURE_PREFIX:=$(PKG_INSTALL_DIR)
 TARGET_LDFLAGS += -pthread -lrt
 
+TARGET_CFLAGS += $(if $(CONFIG_SOFT_FLOAT),-DBOOST_NO_FENV_H)
 
 ifneq ($(findstring mips,$(ARCH)),)
     BOOST_ABI = o32