pthsem: fix signal.h include path 1578/head
authorOthmar Truniger <github@truniger.ch>
Thu, 16 Jul 2015 19:29:19 +0000 (21:29 +0200)
committerOthmar Truniger <github@truniger.ch>
Thu, 16 Jul 2015 19:29:19 +0000 (21:29 +0200)
Signed-off-by: Othmar Truniger <github@truniger.ch>
libs/pthsem/Makefile
libs/pthsem/patches/002-fix-signal.h [new file with mode: 0644]

index 54d7737e1cce9b8d7884daf47e4bd69d8593f471..5d3effbba9b7485978a1f6927b7ab1d5d382215c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pthsem
 PKG_VERSION:=2.0.8
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
 PKG_LICENSE:=LGPL-2.1+
diff --git a/libs/pthsem/patches/002-fix-signal.h b/libs/pthsem/patches/002-fix-signal.h
new file mode 100644 (file)
index 0000000..0e4fdfc
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/pth.h.in 2015-07-16 21:14:48.786970549 +0200
++++ b/pth.h.in 2015-07-16 21:15:22.439416462 +0200
+@@ -43,7 +43,7 @@
+ #include <time.h>          /* for struct timespec */
+ #include <sys/time.h>      /* for struct timeval  */
+ #include <sys/socket.h>    /* for sockaddr        */
+-#include <sys/signal.h>    /* for sigset_t        */
++#include <signal.h>        /* for sigset_t        */
+ @EXTRA_INCLUDE_SYS_SELECT_H@
+     /* fallbacks for essential typedefs */
+--- a/pthread.h.in     2015-07-16 21:14:58.948310639 +0200
++++ b/pthread.h.in     2015-07-16 21:15:40.989869061 +0200
+@@ -111,7 +111,7 @@
+ #include <sys/types.h>     /* for ssize_t         */
+ #include <sys/time.h>      /* for struct timeval  */
+ #include <sys/socket.h>    /* for sockaddr        */
+-#include <sys/signal.h>    /* for sigset_t        */
++#include <signal.h>        /* for sigset_t        */
+ #include <time.h>          /* for struct timespec */
+ #include <unistd.h>        /* for off_t           */
+ @EXTRA_INCLUDE_SYS_SELECT_H@