upgrade freesmartphone.org framework to milestone5
authorMirko Vogt <mirko@openwrt.org>
Sat, 7 Feb 2009 16:51:14 +0000 (16:51 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 7 Feb 2009 16:51:14 +0000 (16:51 +0000)
SVN-Revision: 14431

phone/fso/Makefile
phone/fso/files/frameworkd.conf.om_gta02

index 530aaf380efcb88c217d4a83db292c789bffd695..d3aaddd0cd384f5ad4a1cbce5de16f7d1281d1b6 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fso
-PKG_VERSION:=20090112
-PKG_REV:=2c47aa00f530c4ec698c024b583f250373185b09
+PKG_VERSION:=ms5
+PKG_REV:=700ab8250582767628165b7cf6f671ef756ba56d
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -54,7 +54,7 @@ define Package/fso/install
                $(1)/usr/bin/
        $(INSTALL_BIN) ./files/frameworkd.init $(1)/etc/init.d/frameworkd
        $(CP) \
-               $(PKG_INSTALL_DIR)/etc/* \
+               $(PKG_INSTALL_DIR)/../etc/* \
                $(1)/etc/
        $(if $(CONFIG),$(INSTALL_CONF) ./files/frameworkd.conf.$(CONFIG) $(1)/etc/frameworkd.conf,$(CP) ./files/frameworkd.conf $(1)/etc/frameworkd.conf)
 endef
index ba62b896b56512f5888597d0c708c2d9a84b5615..c6aaa4987ac72e96e09b1165a7dca1e817babade 100644 (file)
@@ -57,9 +57,9 @@ disable = 0
 
 [ogsmd]
 disable = 0
-# chose your modem type, available types are: ti_calypso, freescale_neptune, singleline, muxed4line, option, ...
+# choose your modem type, available types are: ti_calypso, freescale_neptune, singleline, muxed4line, option, ...
 modemtype = ti_calypso
-# if you have a ti_calypso, you can chose the deep sleep mode. Valid values are: never, adaptive (default), always
+# if you have a ti_calypso, you can choose the deep sleep mode. Valid values are: never, adaptive (default), always
 ti_calypso_deep_sleep = adaptive
 # if you have a ti_calypso, you can choose the dsp mode for audio enhancement. Valid values are:
 #    "short-aec": Short Echo Cancellation (max)
@@ -85,6 +85,10 @@ channel = SerialChannel
 path = /dev/ttySAC1
 log_level = INFO
 
+[ousaged]
+# choose whether resources should be disabled at startup, at shutdown, always (default), or never.
+sync_resources_with_lifecycle = always
+
 [opreferencesd]
 log_level = DEBUG
 disable = 0
@@ -100,3 +104,9 @@ messages_default_folder = Unfiled
 messages_trash_folder = Trash
 sim_messages_default_folder = SMS
 rootdir = ../etc/freesmartphone/opim:/etc/freesmartphone/opim:/usr/etc/freesmartphone/opim
+
+[otimed]
+# a list of time/zone sources to use or NONE
+timesources = GPS,NTP
+zonesources = GSM
+