merge r15893 to 8.09
authorFlorian Fainelli <florian@openwrt.org>
Fri, 22 May 2009 10:31:22 +0000 (10:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 22 May 2009 10:31:22 +0000 (10:31 +0000)
SVN-Revision: 15984

package/broadcom-wl/Makefile
package/broadcom-wl/files/lib/wifi/broadcom.sh

index cc0af0f69ec212e2d011334734209c23dcf78fdf..d33524f2c9834eef09ba6f972691b43df63bdb1a 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=broadcom-wl
 PKG_VERSION:=4.150.10.5.3
-PKG_RELEASE:=3.1
+PKG_RELEASE:=3.2
 WLC_VERSION:=0.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 998a2f58ff7dd00588d63b4040359e2bb2d66f8b..9ce49ab6fbaddbbadc09b232fa9d0be8394929bf 100644 (file)
@@ -199,6 +199,7 @@ enable_broadcom() {
                                case "$enc" in
                                        wpa*+wpa2*|WPA*+WPA2*|*psk+*psk2|*PSK+*PSK2) auth=132; wsec=6;;
                                        wpa2*|WPA2*|*PSK2|*psk2) auth=128; wsec=4;;
+                                       *aes|*AES) auth=4; wsec=4;;
                                        *) auth=4; wsec=2;;
                                esac
                                eval "${vif}_key=\"\$key\""