Remove all other deprecated interfaces and files
authorAntonio Nino Diaz <antonio.ninodiaz@arm.com>
Tue, 25 Sep 2018 08:39:51 +0000 (09:39 +0100)
committerAntonio Nino Diaz <antonio.ninodiaz@arm.com>
Fri, 28 Sep 2018 14:31:53 +0000 (15:31 +0100)
Change-Id: Icd1cdd42afdc78895a9be6c46b414b0a155cfa63
Signed-off-by: Antonio Nino Diaz <antonio.ninodiaz@arm.com>
27 files changed:
drivers/auth/mbedtls/mbedtls_common.mk
include/common/aarch64/asm_macros.S
include/drivers/auth/mbedtls/mbedtls_config.h
include/lib/aarch32/arch.h
include/lib/aarch32/smcc_helpers.h [deleted file]
include/lib/aarch32/smcc_macros.S [deleted file]
include/lib/aarch64/arch.h
include/lib/aarch64/smcc_helpers.h [deleted file]
include/lib/cpus/aarch32/cortex_a53.h
include/lib/cpus/aarch32/cortex_a57.h
include/lib/cpus/aarch32/cortex_a72.h
include/lib/cpus/aarch64/cortex_a53.h
include/lib/cpus/aarch64/cortex_a57.h
include/lib/cpus/aarch64/cortex_a72.h
include/lib/smcc.h [deleted file]
include/lib/smccc.h
include/lib/smccc_v1.h
include/lib/utils.h
include/plat/common/platform.h
lib/aarch64/misc_helpers.S
lib/locks/exclusive/spinlock.S [deleted file]
lib/psci/aarch64/psci_helpers.S
plat/common/aarch64/plat_common.c
plat/common/aarch64/platform_helpers.S
plat/common/aarch64/platform_mp_stack.S
plat/common/aarch64/platform_up_stack.S
services/spd/tspd/tspd.mk

index 71c496eda4a78c7cfedbbeeac6abfe71560be323..cfbd86ab931bd1dbe385a9042bf40bc0d7645433 100644 (file)
@@ -60,16 +60,6 @@ ifeq (${TF_MBEDTLS_KEY_ALG},)
     endif
 endif
 
-# If MBEDTLS_KEY_ALG build flag is defined use it to set TF_MBEDTLS_KEY_ALG for
-# backward compatibility
-ifdef MBEDTLS_KEY_ALG
-    ifeq (${ERROR_DEPRECATED},1)
-        $(error "MBEDTLS_KEY_ALG is deprecated. Please use the new build flag TF_MBEDTLS_KEY_ALG")
-    endif
-    $(warning "MBEDTLS_KEY_ALG is deprecated. Please use the new build flag TF_MBEDTLS_KEY_ALG")
-    TF_MBEDTLS_KEY_ALG := ${MBEDTLS_KEY_ALG}
-endif
-
 ifeq (${HASH_ALG}, sha384)
     TF_MBEDTLS_HASH_ALG_ID     :=      TF_MBEDTLS_SHA384
 else ifeq (${HASH_ALG}, sha512)
index e613f1232cbdc01aaff13f3a007b45fb40dc7f4c..9621a1c02c8215dcf4d974a7fd044c77e9060a03 100644 (file)
        .fill   \label + (32 * 4) - .
        .endm
 
-       /*
-        * This macro verifies that the given vector doesn't exceed the
-        * architectural limit of 32 instructions. This is meant to be placed
-        * immediately after the last instruction in the vector. It takes the
-        * vector entry as the parameter
-        */
-       .macro check_vector_size since
-#if ERROR_DEPRECATED
-      .error "check_vector_size must not be used. Use end_vector_entry instead"
-#endif
-       end_vector_entry \since
-       .endm
-
        /*
         * This macro calculates the base address of the current CPU's MP stack
         * using the plat_my_core_pos() index, the name of the stack storage
index 59aeea99294b9863f80ac3e3835df513ada0ab90..cc57b7798499127a8ac532ad91a57ddf47a4c26d 100644 (file)
@@ -30,9 +30,6 @@
 /* Prevent mbed TLS from using snprintf so that it can use tf_snprintf. */
 #define MBEDTLS_PLATFORM_SNPRINTF_ALT
 
-#if !ERROR_DEPRECATED
-#define MBEDTLS_PKCS1_V15
-#endif
 #define MBEDTLS_PKCS1_V21
 
 #define MBEDTLS_X509_ALLOW_UNSUPPORTED_CRITICAL_EXTENSION
index be94887f40d81b4e829c95dc0fbb617477de4b38..3536d2032e8c26c2ef65518178f113a76b6bff2e 100644 (file)
 #define SDCR_SPD_ENABLE                U(0x3)
 #define SDCR_RESET_VAL         U(0x0)
 
-#if !ERROR_DEPRECATED
-#define SDCR_DEF_VAL           SDCR_SPD(SDCR_SPD_DISABLE)
-#endif
-
 /* HSCTLR definitions */
 #define HSCTLR_RES1    ((U(1) << 29) | (U(1) << 28) | (U(1) << 23) | \
                         (U(1) << 22) | (U(1) << 18) | (U(1) << 16) | \
 #define NSASEDIS_BIT           (U(1) << 15)
 #define NSTRCDIS_BIT           (U(1) << 20)
 /* NOTE: correct typo in the definitions */
-#if !ERROR_DEPRECATED
-#define NASCR_CP11_BIT         (U(1) << 11)
-#define NASCR_CP10_BIT         (U(1) << 10)
-#endif
 #define NSACR_CP11_BIT         (U(1) << 11)
 #define NSACR_CP10_BIT         (U(1) << 10)
 #define NSACR_IMP_DEF_MASK     (U(0x7) << 16)
diff --git a/include/lib/aarch32/smcc_helpers.h b/include/lib/aarch32/smcc_helpers.h
deleted file mode 100644 (file)
index 7f79f8f..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-/*
- * Copyright (c) 2016-2018, ARM Limited and Contributors. All rights reserved.
- *
- * SPDX-License-Identifier: BSD-3-Clause
- */
-
-#ifndef __SMCC_HELPERS_H__
-#define __SMCC_HELPERS_H__
-
-#if !ERROR_DEPRECATED
-#include <smccc_helpers.h>
-#endif
-
-#endif /* __SMCC_HELPERS_H__ */
diff --git a/include/lib/aarch32/smcc_macros.S b/include/lib/aarch32/smcc_macros.S
deleted file mode 100644 (file)
index 66f3d0e..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-/*
- * Copyright (c) 2016-2018, ARM Limited and Contributors. All rights reserved.
- *
- * SPDX-License-Identifier: BSD-3-Clause
- */
-#ifndef __SMCC_MACROS_S__
-#define __SMCC_MACROS_S__
-
-#if !ERROR_DEPRECATED
-#include <smccc_macros.S>
-
-#define smcc_save_gp_mode_regs smccc_save_gp_mode_regs
-#endif
-
-#endif /* __SMCC_MACROS_S__ */
index fed5944575ea4241bb6a0fc6aa2c6cba1ec4e28e..a6022cb01eede898b2b2a4d936ae2aca89494055 100644 (file)
 #define MDCR_TPM_BIT           (U(1) << 6)
 #define MDCR_EL3_RESET_VAL     U(0x0)
 
-#if !ERROR_DEPRECATED
-#define MDCR_DEF_VAL           (MDCR_SDD_BIT | MDCR_SPD32(MDCR_SPD32_DISABLE))
-#endif
-
 /* MDCR_EL2 definitions */
 #define MDCR_EL2_TPMS          (U(1) << 14)
 #define MDCR_EL2_E2PB(x)       ((x) << 12)
diff --git a/include/lib/aarch64/smcc_helpers.h b/include/lib/aarch64/smcc_helpers.h
deleted file mode 100644 (file)
index 11300b7..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-/*
- * Copyright (c) 2015-2018, ARM Limited and Contributors. All rights reserved.
- *
- * SPDX-License-Identifier: BSD-3-Clause
- */
-
-#ifndef __SMCC_HELPERS_H__
-#define __SMCC_HELPERS_H__
-
-#if !ERROR_DEPRECATED
-#include <smccc_helpers.h>
-#endif
-
-#endif /* __SMCC_HELPERS_H__ */
index 8e86df465cc56973528b6339a48e3ff2b4465025..a7a681f532506d6af78e509a609ff4c9566a4fb7 100644 (file)
  ******************************************************************************/
 #define CORTEX_A53_L2MERRSR                    p15, 3, c15
 
-#if !ERROR_DEPRECATED
-/*
- * These registers were previously wrongly named. Provide previous definitions so
- * as not to break platforms that continue using them.
- */
-#define CORTEX_A53_ACTLR                       CORTEX_A53_CPUACTLR
-
-#define CORTEX_A53_ACTLR_ENDCCASCI_SHIFT       CORTEX_A53_CPUACTLR_ENDCCASCI_SHIFT
-#define CORTEX_A53_ACTLR_ENDCCASCI             CORTEX_A53_CPUACTLR_ENDCCASCI
-#define CORTEX_A53_ACTLR_DTAH                  CORTEX_A53_CPUACTLR_DTAH
-#endif /* !ERROR_DEPRECATED */
-
 #endif /* __CORTEX_A53_H__ */
index 18cabe11bbbd0f120b4be7ac7873c03358b90411..3f0fb04be9ba677a4987f4f4094f82d1a102743b 100644 (file)
  ******************************************************************************/
 #define CORTEX_A57_L2MERRSR                    p15, 3, c15
 
-#if !ERROR_DEPRECATED
-/*
- * These registers were previously wrongly named. Provide previous definitions so
- * as not to break platforms that continue using them.
- */
-#define CORTEX_A57_ACTLR                       CORTEX_A57_CPUACTLR
-
-#define CORTEX_A57_ACTLR_DIS_LOAD_PASS_DMB     CORTEX_A57_CPUACTLR_DIS_LOAD_PASS_DMB
-#define CORTEX_A57_ACTLR_GRE_NGRE_AS_NGNRE     CORTEX_A57_CPUACTLR_GRE_NGRE_AS_NGNRE
-#define CORTEX_A57_ACTLR_DIS_OVERREAD          CORTEX_A57_CPUACTLR_DIS_OVERREAD
-#define CORTEX_A57_ACTLR_NO_ALLOC_WBWA         CORTEX_A57_CPUACTLR_NO_ALLOC_WBWA
-#define CORTEX_A57_ACTLR_DCC_AS_DCCI           CORTEX_A57_CPUACTLR_DCC_AS_DCCI
-#define CORTEX_A57_ACTLR_FORCE_FPSCR_FLUSH     CORTEX_A57_CPUACTLR_FORCE_FPSCR_FLUSH
-#define CORTEX_A57_ACTLR_DIS_STREAMING         CORTEX_A57_CPUACTLR_DIS_STREAMING
-#define CORTEX_A57_ACTLR_DIS_L1_STREAMING      CORTEX_A57_CPUACTLR_DIS_L1_STREAMING
-#define CORTEX_A57_ACTLR_DIS_INDIRECT_PREDICTOR        CORTEX_A57_CPUACTLR_DIS_INDIRECT_PREDICTOR
-#endif /* !ERROR_DEPRECATED */
-
 #endif /* __CORTEX_A57_H__ */
index 0331ace7c4a38cd706295fde6873e2ec4e064c9e..1a3c014eab1748af2e295b1c287d1d1dfb2f7898 100644 (file)
  ******************************************************************************/
 #define CORTEX_A72_L2MERRSR                            p15, 3, c15
 
-#if !ERROR_DEPRECATED
-/*
- * These registers were previously wrongly named. Provide previous definitions so
- * as not to break platforms that continue using them.
- */
-#define CORTEX_A72_ACTLR                               CORTEX_A72_CPUACTLR
-
-#define CORTEX_A72_ACTLR_DISABLE_L1_DCACHE_HW_PFTCH    CORTEX_A72_CPUACTLR_DISABLE_L1_DCACHE_HW_PFTCH
-#define CORTEX_A72_ACTLR_NO_ALLOC_WBWA                 CORTEX_A72_CPUACTLR_NO_ALLOC_WBWA
-#define CORTEX_A72_ACTLR_DCC_AS_DCCI                   CORTEX_A72_CPUACTLR_DCC_AS_DCCI
-#endif /* !ERROR_DEPRECATED */
-
 #endif /* __CORTEX_A72_H__ */
index 22c68006f02cf5ab6f305d85a5772ca8a377c0b1..9aa118b55c2c683c3949103469ba1f975cdf44d3 100644 (file)
  ******************************************************************************/
 #define CORTEX_A53_L2MERRSR_EL1                                S3_1_C15_C2_3
 
-#if !ERROR_DEPRECATED
-/*
- * These registers were previously wrongly named. Provide previous definitions
- * so as not to break platforms that continue using them.
- */
-#define CORTEX_A53_ACTLR_EL1                   CORTEX_A53_CPUACTLR_EL1
-
-#define CORTEX_A53_ACTLR_ENDCCASCI_SHIFT       CORTEX_A53_CPUACTLR_EL1_ENDCCASCI_SHIFT
-#define CORTEX_A53_ACTLR_ENDCCASCI             CORTEX_A53_CPUACTLR_EL1_ENDCCASCI
-#define CORTEX_A53_ACTLR_RADIS_SHIFT           CORTEX_A53_CPUACTLR_EL1_RADIS_SHIFT
-#define CORTEX_A53_ACTLR_RADIS                 CORTEX_A53_CPUACTLR_EL1_RADIS
-#define CORTEX_A53_ACTLR_L1RADIS_SHIFT         CORTEX_A53_CPUACTLR_EL1_L1RADIS_SHIFT
-#define CORTEX_A53_ACTLR_L1RADIS               CORTEX_A53_CPUACTLR_EL1_L1RADIS
-#define CORTEX_A53_ACTLR_DTAH_SHIFT            CORTEX_A53_CPUACTLR_EL1_DTAH_SHIFT
-#define CORTEX_A53_ACTLR_DTAH                  CORTEX_A53_CPUACTLR_EL1_DTAH
-#endif /* !ERROR_DEPRECATED */
-
 #endif /* __CORTEX_A53_H__ */
index 83ec934267b07f0861552bb378c1183283950b23..97d074e006927d9b2c3dc85f2bc225b4be63b94c 100644 (file)
  ******************************************************************************/
 #define CORTEX_A57_L2MERRSR_EL1                        S3_1_C15_C2_3
 
-#if !ERROR_DEPRECATED
-/*
- * These registers were previously wrongly named. Provide previous definitions so
- * as not to break platforms that continue using them.
- */
-#define CORTEX_A57_ACTLR_EL1                   CORTEX_A57_CPUACTLR_EL1
-
-#define CORTEX_A57_ACTLR_DIS_LOAD_PASS_DMB     CORTEX_A57_CPUACTLR_EL1_DIS_LOAD_PASS_DMB
-#define CORTEX_A57_ACTLR_GRE_NGRE_AS_NGNRE     CORTEX_A57_CPUACTLR_EL1_GRE_NGRE_AS_NGNRE
-#define CORTEX_A57_ACTLR_DIS_OVERREAD          CORTEX_A57_CPUACTLR_EL1_DIS_OVERREAD
-#define CORTEX_A57_ACTLR_NO_ALLOC_WBWA         CORTEX_A57_CPUACTLR_EL1_NO_ALLOC_WBWA
-#define CORTEX_A57_ACTLR_DCC_AS_DCCI           CORTEX_A57_CPUACTLR_EL1_DCC_AS_DCCI
-#define CORTEX_A57_ACTLR_FORCE_FPSCR_FLUSH     CORTEX_A57_CPUACTLR_EL1_FORCE_FPSCR_FLUSH
-#define CORTEX_A57_ACTLR_DIS_STREAMING         CORTEX_A57_CPUACTLR_EL1_DIS_STREAMING
-#define CORTEX_A57_ACTLR_DIS_L1_STREAMING      CORTEX_A57_CPUACTLR_EL1_DIS_L1_STREAMING
-#define CORTEX_A57_ACTLR_DIS_INDIRECT_PREDICTOR        CORTEX_A57_CPUACTLR_EL1_DIS_INDIRECT_PREDICTOR
-#endif /* !ERROR_DEPRECATED */
-
 #endif /* __CORTEX_A57_H__ */
index f5ca2ee7a41b44ad6ecd1c203fdeaca7b3d5f03a..5b9e06de235f8ddff328c2688f33299885f873e2 100644 (file)
  ******************************************************************************/
 #define CORTEX_A72_L2MERRSR_EL1                                S3_1_C15_C2_3
 
-#if !ERROR_DEPRECATED
-/*
- * These registers were previously wrongly named. Provide previous definitions so
- * as not to break platforms that continue using them.
- */
-#define CORTEX_A72_ACTLR                               CORTEX_A72_CPUACTLR_EL1
-
-#define CORTEX_A72_ACTLR_DISABLE_L1_DCACHE_HW_PFTCH    CORTEX_A72_CPUACTLR_EL1_DISABLE_L1_DCACHE_HW_PFTCH
-#define CORTEX_A72_ACTLR_NO_ALLOC_WBWA                 CORTEX_A72_CPUACTLR_EL1_NO_ALLOC_WBWA
-#define CORTEX_A72_ACTLR_DCC_AS_DCCI                   CORTEX_A72_CPUACTLR_EL1_DCC_AS_DCCI
-#endif /* !ERROR_DEPRECATED */
-
 #endif /* __CORTEX_A72_H__ */
diff --git a/include/lib/smcc.h b/include/lib/smcc.h
deleted file mode 100644 (file)
index ed1da2c..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-/*
- * Copyright (c) 2016-2018, ARM Limited and Contributors. All rights reserved.
- *
- * SPDX-License-Identifier: BSD-3-Clause
- */
-
-#ifndef __SMCC_H__
-#define __SMCC_H__
-
-#if !ERROR_DEPRECATED
-#include <smccc.h>
-#endif
-
-#endif /* __SMCC_H__ */
index a07e510b872884212f2db1408281aac48e3dd4a6..b3dad1027739d447c3e4af8a27172029cecfe618 100644 (file)
  * does not equal SMC_UNK. This is to ensure that the caller won't mistake the
  * returned UUID in x0 for an invalid SMC error return
  */
-#if !ERROR_DEPRECATED
-#define DEFINE_SVC_UUID(_name, _tl, _tm, _th, _cl, _ch, \
-               _n0, _n1, _n2, _n3, _n4, _n5) \
-       CASSERT((uint32_t)(_tl) != (uint32_t) SMC_UNK, invalid_svc_uuid);\
-       static const uuid_t _name = { \
-               _tl, _tm, _th, _cl, _ch, \
-               { _n0, _n1, _n2, _n3, _n4, _n5 } \
-       }
-#endif
-
-
 #define DEFINE_SVC_UUID2(_name, _tl, _tm, _th, _cl, _ch,               \
                _n0, _n1, _n2, _n3, _n4, _n5)                           \
        CASSERT((uint32_t)(_tl) != (uint32_t) SMC_UNK, invalid_svc_uuid);\
index 8718d1586307f76540baafa17f9da0a7a26eb6aa..98ef0211a9e46d747c5383f705e9f454ca2ebe82 100644 (file)
@@ -66,9 +66,6 @@
 #define SMC_32                         U(0)
 
 #define SMC_TYPE_FAST                  ULL(1)
-#if !ERROR_DEPRECATED
-#define SMC_TYPE_STD                   ULL(0)
-#endif
 #define SMC_TYPE_YIELD                 ULL(0)
 
 #define SMC_OK                         ULL(0)
index 09ec8d99b39b4488ae315c71902c68c0fd64fe08..d46d8461dfaedce858b9ac282d580e3032e74bcc 100644 (file)
@@ -7,10 +7,6 @@
 #ifndef __UTILS_H__
 #define __UTILS_H__
 
-#if !ERROR_DEPRECATED
-#include <utils_def.h>
-#endif
-
 /*
  * C code should be put in this part of the header to avoid breaking ASM files
  * or linker scripts including it.
index 36039ab408a1df2d68861a4307450d96f2ef9ebc..a30b57987bbe5221b411e8ff59533644049473ec 100644 (file)
@@ -37,7 +37,6 @@ struct secure_partition_boot_info;
 /*******************************************************************************
  * Mandatory common functions
  ******************************************************************************/
-unsigned long long plat_get_syscnt_freq(void) __deprecated;
 unsigned int plat_get_syscnt_freq2(void);
 
 int plat_get_image_source(unsigned int image_id,
index 3c64d3caac7b6b549a2d35dbfe0b86f190707c48..1a075aa5ad1953fa7fc0482e34718fc3cf6d858f 100644 (file)
@@ -55,16 +55,6 @@ func smc
        smc     #0
 endfunc smc
 
-/* -----------------------------------------------------------------------
- * void zeromem16(void *mem, unsigned int length);
- *
- * Initialise a memory region to 0.
- * The memory address must be 16-byte aligned.
- * NOTE: This function is deprecated and zeromem should be used instead.
- * -----------------------------------------------------------------------
- */
-.equ   zeromem16, zeromem
-
 /* -----------------------------------------------------------------------
  * void zero_normalmem(void *mem, unsigned int length);
  *
diff --git a/lib/locks/exclusive/spinlock.S b/lib/locks/exclusive/spinlock.S
deleted file mode 100644 (file)
index 2141f98..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-/*
- * Copyright (c) 2013-2016, ARM Limited and Contributors. All rights reserved.
- *
- * SPDX-License-Identifier: BSD-3-Clause
- */
-
-#if !ERROR_DEPRECATED
-#include "./aarch64/spinlock.S"
-#endif
index 78141b1a58a136b898ebdfc63a714db85dd8162a..88db1c9689442915eb9dc981f75fffaa7c874ae5 100644 (file)
@@ -128,12 +128,3 @@ func psci_power_down_wfi
        wfi
        no_ret  plat_panic_handler
 endfunc psci_power_down_wfi
-
-/* -----------------------------------------------------------------------
- * void psci_entrypoint(void);
- * The deprecated entry point for PSCI on warm boot for AArch64.
- * -----------------------------------------------------------------------
- */
-func_deprecated psci_entrypoint
-       b       bl31_warm_entrypoint
-endfunc_deprecated psci_entrypoint
index 60bdd3ea0dce5be6f1e8ddcf192c604cc6f5b522..e6f5f2045ec7bdee1d9b663bdc1301101ec1de2c 100644 (file)
@@ -19,9 +19,6 @@
  * platforms but may also be overridden by a platform if required.
  */
 #pragma weak bl31_plat_runtime_setup
-#if !ERROR_DEPRECATED
-#pragma weak plat_get_syscnt_freq2
-#endif /* ERROR_DEPRECATED */
 
 #if SDEI_SUPPORT
 #pragma weak plat_sdei_handle_masked_trigger
@@ -51,25 +48,6 @@ unsigned int platform_core_pos_helper(unsigned long mpidr)
        return idx;
 }
 
-#if !ERROR_DEPRECATED
-unsigned int plat_get_syscnt_freq2(void)
-{
-       WARN("plat_get_syscnt_freq() is deprecated\n");
-       WARN("Please define plat_get_syscnt_freq2()\n");
-       /*
-        * Suppress deprecated declaration warning in compatibility function
-        */
-#pragma GCC diagnostic push
-#pragma GCC diagnostic ignored "-Wdeprecated-declarations"
-       unsigned long long freq = plat_get_syscnt_freq();
-#pragma GCC diagnostic pop
-
-       assert(freq >> 32 == 0);
-
-       return (unsigned int)freq;
-}
-#endif /* ERROR_DEPRECATED */
-
 #if SDEI_SUPPORT
 /*
  * Function that handles spurious SDEI interrupts while events are masked.
index 8653e88656493606e8f99d8e7c559265376b3664..7214588a6dbd2ebc4799c661f24cc77ba6c24ba9 100644 (file)
 
 #define MPIDR_RES_BIT_MASK     0xff000000
 
-       /* ------------------------------------------------------------------
-        *  int platform_get_core_pos(int mpidr)
-        *  Returns the CPU index of the CPU specified by mpidr. This is
-        *  defined when platform compatibility is disabled to enable Trusted
-        *  Firmware components like SPD using the old  platform API to work.
-        *  This API is deprecated and it assumes that the mpidr specified is
-        *  that of a valid and present CPU. Instead, plat_my_core_pos()
-        *  should be used for CPU index of the current CPU and
-        *  plat_core_pos_by_mpidr() should be used for CPU index of a
-        *  CPU specified by its mpidr.
-        * ------------------------------------------------------------------
-        */
-func_deprecated platform_get_core_pos
-       bic     x0, x0, #MPIDR_RES_BIT_MASK
-       mrs     x1, mpidr_el1
-       bic     x1, x1, #MPIDR_RES_BIT_MASK
-       cmp     x0, x1
-       beq     plat_my_core_pos
-       b       platform_core_pos_helper
-endfunc_deprecated platform_get_core_pos
-
        /* -----------------------------------------------------
         * Placeholder function which should be redefined by
         * each platform.
index fd0a01e297d0eefcdde606edf01c5609c8a66b55..f1cc6bebdecb0f396f9339bb239d7ffbfa66d147 100644 (file)
         * --------------------------------------------------------------------
         */
 
-       /* -------------------------------------------------------
-        * unsigned long platform_get_stack (unsigned long mpidr)
-        *
-        * For the current CPU, this function returns the stack
-        * pointer for a stack allocated in device memory. The
-        * 'mpidr' should correspond to that of the current CPU.
-        * This function is deprecated and plat_get_my_stack()
-        * should be used instead.
-        * -------------------------------------------------------
-        */
-func_deprecated platform_get_stack
-#if ENABLE_ASSERTIONS
-       mrs     x1, mpidr_el1
-       cmp     x0, x1
-       ASM_ASSERT(eq)
-#endif
-       b       plat_get_my_stack
-endfunc_deprecated platform_get_stack
-
-       /* -----------------------------------------------------
-        * void platform_set_stack (unsigned long mpidr)
-        *
-        * For the current CPU, this function sets the stack pointer
-        * to a stack allocated in normal memory. The
-        * 'mpidr' should correspond to that of the current CPU.
-        * This function is deprecated and plat_get_my_stack()
-        * should be used instead.
-        * -----------------------------------------------------
-        */
-func_deprecated platform_set_stack
-#if ENABLE_ASSERTIONS
-       mrs     x1, mpidr_el1
-       cmp     x0, x1
-       ASM_ASSERT(eq)
-#endif
-       b       plat_set_my_stack
-endfunc_deprecated platform_set_stack
-
        /* -----------------------------------------------------
         * uintptr_t plat_get_my_stack ()
         *
index a99a7ccf9c5f09c9bb08df16050171a322fb9d4f..0ff6930552ebfae553ddea938b701508318ec77c 100644 (file)
@@ -42,32 +42,6 @@ func plat_set_my_stack
        ret
 endfunc plat_set_my_stack
 
-       /* -----------------------------------------------------
-        * unsigned long platform_get_stack ()
-        *
-        * For cold-boot BL images, only the primary CPU needs a
-        * stack. This function returns the stack pointer for a
-        * stack allocated in device memory. This function
-        * is deprecated.
-        * -----------------------------------------------------
-        */
-func_deprecated platform_get_stack
-       b       plat_get_my_stack
-endfunc_deprecated platform_get_stack
-
-       /* -----------------------------------------------------
-        * void platform_set_stack ()
-        *
-        * For cold-boot BL images, only the primary CPU needs a
-        * stack. This function sets the stack pointer to a stack
-        * allocated in normal memory.This function is
-        * deprecated.
-        * -----------------------------------------------------
-        */
-func_deprecated platform_set_stack
-       b       plat_set_my_stack
-endfunc_deprecated platform_set_stack
-
        /* -----------------------------------------------------
         * Single cpu stack in normal memory.
         * Used for C code during boot, PLATFORM_STACK_SIZE bytes
index 0747e15f6722bc7881e1f36df242e2985beca489..1457360a530091b6945879d1a6bef883d92ee08f 100644 (file)
@@ -33,16 +33,6 @@ NEED_BL32            :=      yes
 # generated while the code is executing in S-EL1/0.
 TSP_NS_INTR_ASYNC_PREEMPT      :=      0
 
-# If TSPD_ROUTE_IRQ_TO_EL3 build flag is defined, use it to define value for
-# TSP_NS_INTR_ASYNC_PREEMPT for backward compatibility.
-ifdef TSPD_ROUTE_IRQ_TO_EL3
-ifeq (${ERROR_DEPRECATED},1)
-$(error "TSPD_ROUTE_IRQ_TO_EL3 is deprecated. Please use the new build flag TSP_NS_INTR_ASYNC_PREEMPT")
-endif
-$(warning "TSPD_ROUTE_IRQ_TO_EL3 is deprecated. Please use the new build flag TSP_NS_INTR_ASYNC_PREEMPT")
-TSP_NS_INTR_ASYNC_PREEMPT      := ${TSPD_ROUTE_IRQ_TO_EL3}
-endif
-
 ifeq ($(EL3_EXCEPTION_HANDLING),1)
 ifeq ($(TSP_NS_INTR_ASYNC_PREEMPT),0)
 $(error When EL3_EXCEPTION_HANDLING=1, TSP_NS_INTR_ASYNC_PREEMPT must also be 1)