Fix iksemel compilation (#3451)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 18 May 2008 11:15:12 +0000 (11:15 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 18 May 2008 11:15:12 +0000 (11:15 +0000)
SVN-Revision: 11166

libs/iksemel/Makefile

index 68ed0f3604d202f805607976d401f9eaf5fe4b6f..995535874c0d197bde4c99a54bf74233a611c3f0 100644 (file)
@@ -34,7 +34,7 @@ CONFIGURE_ARGS += \
        --with-libgnutls-prefix="$(STAGING_DIR)/usr" \
 
 CONFIGURE_VARS += \
-       LIBS="-lgnutls -lgcrypt -lgpg-error" \
+       LIBS="-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib -lgnutls -lgcrypt -lgpg-error" \
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install