Create a library file for libfdt
authorRoberto Vargas <roberto.vargas@arm.com>
Tue, 8 May 2018 09:27:10 +0000 (10:27 +0100)
committerRoberto Vargas <roberto.vargas@arm.com>
Fri, 3 Aug 2018 10:31:26 +0000 (11:31 +0100)
TF Makefile was linking all the objects files generated for the
fdt library instead of creating a static library that could be
used in the linking stage.

Change-Id: If3705bba188ec39e1fbf2322a7f2a9a941e1b90d
Signed-off-by: Roberto Vargas <roberto.vargas@arm.com>
lib/libfdt/libfdt.mk
plat/arm/common/arm_common.mk
plat/qemu/platform.mk

index d03dde20421f8632e13becdeefb474005d0e4b8f..1cbbd785212dbf0735047e3c820e0a49bf12db68 100644 (file)
@@ -15,3 +15,5 @@ LIBFDT_SRCS   :=      $(addprefix lib/libfdt/,        \
                        fdt_wip.c)                      \
 
 INCLUDES       +=      -Iinclude/lib/libfdt
+
+$(eval $(call MAKE_LIB,fdt))
index 67b574de6c70f0c9023d0217d94798cafd4a1203..d8eda35b6413eb9e4eef3ac265df1098bac2b296 100644 (file)
@@ -185,8 +185,7 @@ include lib/libfdt/libfdt.mk
 
 DYN_CFG_SOURCES                +=      plat/arm/common/arm_dyn_cfg.c           \
                                plat/arm/common/arm_dyn_cfg_helpers.c   \
-                               common/fdt_wrappers.c                   \
-                               ${LIBFDT_SRCS}
+                               common/fdt_wrappers.c
 
 BL1_SOURCES            +=      ${DYN_CFG_SOURCES}
 BL2_SOURCES            +=      ${DYN_CFG_SOURCES}
index 379ab3dcae4dd2a533ea3749c0a7857182fff3a8..1d46eeccd6eff239929d7e22cdb60b03e4fc527e 100644 (file)
@@ -132,8 +132,7 @@ BL2_SOURCES         +=      drivers/io/io_semihosting.c             \
                                plat/qemu/qemu_io_storage.c             \
                                plat/qemu/${ARCH}/plat_helpers.S        \
                                plat/qemu/qemu_bl2_setup.c              \
-                               plat/qemu/dt.c                          \
-                               $(LIBFDT_SRCS)
+                               plat/qemu/dt.c
 ifeq (${LOAD_IMAGE_V2},1)
 BL2_SOURCES            +=      plat/qemu/qemu_bl2_mem_params_desc.c    \
                                plat/qemu/qemu_image_load.c             \