Merge pull request #54 from eloicaso/master
authorPau <pau@dabax.net>
Tue, 30 Sep 2014 16:50:55 +0000 (18:50 +0200)
committerPau <pau@dabax.net>
Tue, 30 Sep 2014 16:50:55 +0000 (18:50 +0200)
[New Package] bird-openwrt: BIRD daemon integration with UCI and LuCI configuration

alfred/Makefile
hnetd/Makefile
miniupnpd/Makefile
miniupnpd/patches/100-no-ssl.patch
miniupnpd/patches/101-ipv6-pinhole.patch [deleted file]
miniupnpd/patches/102-ipv6-ext-port.patch
miniupnpd/patches/103-nat-pmp-fix-writenu16.patch [deleted file]
miniupnpd/patches/103-no-ipv6-autodetection.patch [new file with mode: 0644]
ohybridproxy/Makefile

index 648a5efa5dbaee322c0cf6b4bf0f91a14ac2a315..de1a801fa66b808b65b249d1b343fb0815dcbc25 100644 (file)
@@ -73,7 +73,7 @@ define Package/alfred/install
        $(INSTALL_DIR) $(1)/usr/sbin
        cp -fpR  $(PKG_BUILD_DIR)/alfred $(1)/usr/sbin/
        [ "x$(CONFIG_PACKAGE_ALFRED_VIS)" == "xy" ] && cp -fpR  $(PKG_BUILD_DIR)/vis/batadv-vis $(1)/usr/sbin/ ; true
-       [ "x$(CONFIG_PACKAGE_ALFRED_GPSD)" == "xy" ] && cp -fpR  $(PKG_BUILD_DIR)/vis/alfred-gpsd $(1)/usr/sbin/ ; true
+       [ "x$(CONFIG_PACKAGE_ALFRED_GPSD)" == "xy" ] && cp -fpR  $(PKG_BUILD_DIR)/gpsd/alfred-gpsd $(1)/usr/sbin/ ; true
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/alfred.init $(1)/etc/init.d/alfred
        $(INSTALL_DIR) $(1)/etc/config
index c9d7ce6e78ae59b46a2dd2d766c3b3b3414ed022..4ca21d3446f26bad63e2ba9fde390a15c556b00b 100644 (file)
@@ -7,9 +7,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hnetd
-PKG_SOURCE_VERSION:=91aaab8bdd4de8bc96ad906673a79a6600cf93ac
-PKG_VERSION:=2014-09-02-$(PKG_SOURCE_VERSION)
-PKG_RELEASE:=2
+PKG_SOURCE_VERSION:=0c1d55d03983c726aaad010738236c2da64ca7df
+PKG_VERSION:=2014-09-26-$(PKG_SOURCE_VERSION)
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://github.com/sbyx/hnetd.git
index af9a940f62ced1deb3ff1e3a1645c128bc45d928..139320f1724cd35ffcf3c1e2cd4b4f3e94afa49c 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miniupnpd
-PKG_VERSION:=1.8.20140523
-PKG_RELEASE:=4
+PKG_VERSION:=1.8.20140906
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=fcac89e11da091b1cc61f43d83c9e4f5
+PKG_MD5SUM:=72a68c5757031d906a555f84e9a2a8f2
 
 PKG_MAINTAINER:=Markus Stenberg <fingon@iki.fi>
 
index f058c3bba361253ddaec25bfa1d664adfcbdd213..343e61559de91c94546380b53bf144f20e4472bc 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/Makefile.linux b/Makefile.linux
-index bcca779..7946108 100644
 --- a/Makefile.linux
 +++ b/Makefile.linux
-@@ -147,7 +147,8 @@ LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libmnl)
+@@ -147,7 +147,8 @@ LDLIBS += $(shell $(PKG_CONFIG) --static
  LDLIBS += $(shell $(PKG_CONFIG) --static --libs-only-l libnetfilter_conntrack)
  endif # ($(TEST),1)
  
diff --git a/miniupnpd/patches/101-ipv6-pinhole.patch b/miniupnpd/patches/101-ipv6-pinhole.patch
deleted file mode 100644 (file)
index 0ab4d4d..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/netfilter/iptpinhole.c b/netfilter/iptpinhole.c
-index 61ed41b..5cb0e0e 100644
---- a/netfilter/iptpinhole.c
-+++ b/netfilter/iptpinhole.c
-@@ -206,6 +206,8 @@ int add_pinhole(const char * ifname,
-       e = calloc(1, sizeof(struct ip6t_entry));
-       e->ipv6.proto = proto;
-+      if (proto)
-+              e->ipv6.flags |= IP6T_F_PROTO;
-       if(ifname)
-               strncpy(e->ipv6.iniface, ifname, IFNAMSIZ);
index d0c68aeb97105928d7debdbbba9161f70c9f2b0f..fdb2af47723b43fb7685c465bd815ee1c92f785a 100644 (file)
@@ -1,12 +1,10 @@
-diff --git a/pcpserver.c b/pcpserver.c
-index dec4b58..3cdf460 100644
 --- a/pcpserver.c
 +++ b/pcpserver.c
-@@ -1020,6 +1020,7 @@ static int CreatePCPMap_FW(pcp_info_t *pcp_msg_info)
-                                       &uid);
+@@ -1004,6 +1004,7 @@ static int CreatePCPMap_NAT(pcp_info_t *
+                                  timestamp);
        if (r < 0)
                return PCP_ERR_NO_RESOURCES;
 +      pcp_msg_info->ext_port = pcp_msg_info->int_port;
        return PCP_SUCCESS;
- #else
-       return PCP_ERR_NO_RESOURCES;
+ }
diff --git a/miniupnpd/patches/103-nat-pmp-fix-writenu16.patch b/miniupnpd/patches/103-nat-pmp-fix-writenu16.patch
deleted file mode 100644 (file)
index 6e94ad8..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/natpmp.c
-+++ b/natpmp.c
-@@ -54,7 +54,7 @@ INLINE void writenu32(uint8_t * p, uint3
- #define WRITENU32(p, n) writenu32(p, n)
- INLINE void writenu16(uint8_t * p, uint16_t n)
- {
--      p[0] = (n < 0xff00) >> 8;
-+      p[0] = (n & 0xff00) >> 8;
-       p[1] = n & 0xff;
- }
- #define WRITENU16(p, n) writenu16(p, n)
diff --git a/miniupnpd/patches/103-no-ipv6-autodetection.patch b/miniupnpd/patches/103-no-ipv6-autodetection.patch
new file mode 100644 (file)
index 0000000..acef536
--- /dev/null
@@ -0,0 +1,29 @@
+The miniupnpd makefile tries to autodetect iptables capabilities.
+This will incorrectly detect capabilities such as ipv6 support even though it is disabled for the target build.
+
+As the OpenWRT buildsystem already passes the right compile flags, we can skip the autodetection.
+
+
+diff -up miniupnpd-1.8.20140906/netfilter/Makefile.orig miniupnpd-1.8.20140906/netfilter/Makefile
+--- miniupnpd-1.8.20140906/netfilter/Makefile.orig     2014-09-28 16:39:56.652296642 +0200
++++ miniupnpd-1.8.20140906/netfilter/Makefile  2013-12-13 14:12:11.000000000 +0100
+@@ -38,6 +38,4 @@ endif
+ endif
+ endif
+-LIBS +=  /lib/libip4tc.so /lib/libip6tc.so
+-
+ all:  iptcrdr.o testiptcrdr iptpinhole.o \
+         testiptcrdr_peer testiptcrdr_dscp test_nfct_get
+ #        testiptpinhole
+diff -up miniupnpd-1.8.20140906/Makefile.linux.orig miniupnpd-1.8.20140906/Makefile.linux
+--- miniupnpd-1.8.20140906/Makefile.linux.orig 2014-09-28 16:46:06.781835136 +0200
++++ miniupnpd-1.8.20140906/Makefile.linux      2014-09-28 16:46:14.388907413 +0200
+@@ -70,7 +70,6 @@ CPPFLAGS += -DIPTABLES_143
+ endif
+ CFLAGS  += $(shell $(PKG_CONFIG) --cflags libiptc)
+-LDLIBS  += $(shell $(PKG_CONFIG) --static --libs-only-l libiptc)
+ LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-L libiptc)
+ LDFLAGS += $(shell $(PKG_CONFIG) --libs-only-other libiptc)
+ else
index 2680a9b8aeb5ef5e14011455b971822020455975..6ed8b911c5fb5420876d366411e66706d4c51f76 100644 (file)
@@ -7,8 +7,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ohybridproxy
-PKG_SOURCE_VERSION:=3a9489615c488afa85a823a40aea89b39bbac391
-PKG_VERSION:=2014-06-19-$(PKG_SOURCE_VERSION)
+PKG_SOURCE_VERSION:=ab6559bd5df88967e08478ab486b307c1b7eb759
+PKG_VERSION:=2014-09-29-$(PKG_SOURCE_VERSION)
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git