* fix ARV7518PW support
authorJohn Crispin <john@openwrt.org>
Tue, 29 Mar 2011 06:20:00 +0000 (06:20 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 29 Mar 2011 06:20:00 +0000 (06:20 +0000)
SVN-Revision: 26354

target/linux/lantiq/image/Makefile
target/linux/lantiq/patches/400-mach-arv45xx.patch
target/linux/lantiq/xway/profiles/002-arcadyan.mk

index 5fbf3321225198ca1e934778938849863867cb72..bfd73f6dd53582360dcdf2c3da605618195e1595 100644 (file)
@@ -119,6 +119,14 @@ define Image/Build/Profile/ARV452CPW
        $(call Image/Build/$(1),$(1),ARV452CPW)
 endef
 
+define Image/BuildKernel/Profile/ARV7518PW
+       $(call Image/BuildKernel/Template,ARV7518PW,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/ARV7518PW
+       $(call Image/Build/$(1),$(1),ARV7518PW)
+endef
+
 define Image/BuildKernel/Profile/ARV752DPW22
        $(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
 endef
index faaa6796f70aa047f51a999b723b363debc5510a..4da4c9859b70e47e61af3c3a1824b362d5da8d73 100644 (file)
@@ -38,7 +38,7 @@
 +obj-$(CONFIG_LANTIQ_MACH_ARV45XX) += mach-arv45xx.o
 --- /dev/null
 +++ b/arch/mips/lantiq/xway/mach-arv45xx.c
-@@ -0,0 +1,536 @@
+@@ -0,0 +1,537 @@
 +/*
 + *  This program is free software; you can redistribute it and/or modify it
 + *  under the terms of the GNU General Public License version 2 as published
 +arv7518pw_init(void)
 +{
 +#define ARV7518PW_EBU                 0x2
-+#define ARV7518PW_USB                 -1
++#define ARV7518PW_USB                 14
 +
 +      lq_register_gpio();
 +      lq_register_gpio_ebu(ARV7518PW_EBU);
 +      lq_register_nor(&arv75xx_flash_data);
 +      lq_register_pci(&lq_pci_data);
 +      lq_register_wdt();
++      lq_register_tapi();
 +      xway_register_dwc(ARV7518PW_USB);
 +      arv75xx_register_ethernet();
 +      //arv7518_register_ath9k(mac);
index a70a1ef7e1d80d5205ff202c8edf36dc8c4b6718..79694f141e68c4df982041a34adb3d715259cf84 100644 (file)
@@ -87,3 +87,15 @@ endef
 
 $(eval $(call Profile,ARV752DPW22))
 
+define Profile/ARV7518PW
+  NAME:=ARV7518PW - ASTORIA
+  PACKAGES:= kmod-usb-core kmod-usb-dwc-otg \
+       kmod-ledtrig-netdev kmod-ledtrig-usbdev kmod-leds-gpio kmod-button-hotplug \
+       kmod-ath9k wpad-mini ltq-dsl-firmware-a swconfig
+endef
+
+define Profile/ARV7518PW/Description
+       Package set optimized for the ARV7518PW
+endef
+
+$(eval $(call Profile,ARV7518PW))