[packages] libshout: fixup pkg-config file before installing it into staging dir
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 18 Dec 2009 16:20:39 +0000 (16:20 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 18 Dec 2009 16:20:39 +0000 (16:20 +0000)
SVN-Revision: 18824

libs/libshout/Makefile

index d2a490f63632cf90d59fcb65fe08b78a80be1203..2421e6d371cf3ddf1fda4481722644dd2536cf24 100644 (file)
@@ -58,6 +58,8 @@ define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.{a,so*} $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(SED) 's|/usr/include|$(STAGING_DIR)/usr/include|' \
+               (PKG_INSTALL_DIR)/usr/lib/pkgconfig/shout.pc
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/shout.pc $(1)/usr/lib/pkgconfig/             
 endef