sunxi: t113: add an extra step to copy u-boot into bin/ for eMMC boot support sunxi-t113-202306
authorZoltan HERPAI <wigyori@uid0.hu>
Sat, 26 Aug 2023 23:43:32 +0000 (01:43 +0200)
committerZoltan HERPAI <wigyori@uid0.hu>
Sat, 26 Aug 2023 23:43:32 +0000 (01:43 +0200)
Put an u-boot.bin into bin/ to make it easier for picking it to
install onto mmcblk1boot0.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/sunxi/image/Makefile
target/linux/sunxi/image/cortexa7.mk

index 35ccc2ba6e210a546dc2cf50df2228036d861581..16cec44c4f518afea32333bdff5b5597d91b91a5 100644 (file)
@@ -49,6 +49,10 @@ define Build/sunxi-emmc
        rm -f $@.boot
 endef
 
+define Build/sunxi-emmc-uboot-copy
+       $(CP) $(STAGING_DIR_IMAGE)/$(DEVICE_NAME)-u-boot-with-spl.bin $(BIN_DIR)/
+endef
+
 define Device/Default
   PROFILES := Default
   KERNEL_NAME := zImage
index 05095703194ed100ec63b2b834c2f391b9ddd5a6..77321772b42648c8e9b8f2d345959eee69d79d64 100644 (file)
@@ -247,7 +247,7 @@ define Device/myir_myd-yt113x
   SOC := sun8i-t113s
   IMAGES += emmc.img.gz
   IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
-  IMAGE/emmc.img.gz := boot-scr-emmc | sunxi-emmc | append-metadata | gzip
+  IMAGE/emmc.img.gz := sunxi-emmc-uboot-copy | boot-scr-emmc | sunxi-emmc | append-metadata | gzip
 endef
 TARGET_DEVICES += myir_myd-yt113x