Chan-sccp-b release v4.2.3 105/head
authorDiederik de Groot <ddegroot@talon.nl>
Thu, 18 Feb 2016 02:47:53 +0000 (03:47 +0100)
committerDiederik de Groot <ddegroot@talon.nl>
Thu, 18 Feb 2016 02:47:53 +0000 (03:47 +0100)
New Features in V4.2.3
 - Warning about use of ancient gcc compiler
 - New desktop/background images
 - New AMI Function:SCCPShowRefcount
 - Support for newer/future version of automake
 - Small size reduction of chan_sccp.so

Bug Fixes
 - Channel being left behind after hangup
 - Scheduled Hangup / Schedule Digit Timeout
 - Potential Deadlock Fallback Atomic Functions
 - MWI loosing track of new voicemails under certain circumstances
 - using gnu version of libiconv fixed
 - gen_sccp_enum improved / gnu awk extension dependency removed
 - set socket option should happen before binding to the socket
 - channel monitor/record handling fixed
 - Code cleanup / fixed memory leaks / fixed potential null pointer dereferences
 - Some smaller patches (Check ChangeLog for details)

net/chan-sccp-b/Makefile

index 49062a2752352d26af3951aaef88e296ce370afb..3e060db71cc665384110b4ec66c8f56ebcfa1e1f 100644 (file)
@@ -9,9 +9,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=chan-sccp-b
-PKG_REV:=6139
-PKG_VERSION:=v4.2-r$(PKG_REV)
-PKG_RELEASE:=3
+PKG_REV:=6647
+PKG_VERSION:=v4.2.3-r$(PKG_REV)
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://svn.code.sf.net/p/chan-sccp-b/code/branches/v4.2
@@ -66,6 +66,10 @@ Package/asterisk18-chan-sccp-b/description = $(Package/description/Default)
 Package/asterisk11-chan-sccp-b/description = $(Package/description/Default)
 Package/asterisk13-chan-sccp-b/description = $(Package/description/Default)
 
+CONFIGURE_ARGS += --enable-conference
+CONFIGURE_ARGS += --enable-advanced-functions
+CONFIGURE_ARGS += --enable-video
+
 ifeq ($(BUILD_VARIANT),asterisk13)
   CONFIGURE_ARGS += --with-asterisk=$(STAGING_DIR)/usr/include/asterisk-13
 endif