rtorrent: update to 0.9.6, disable ipv6 1923/head
authorHannu Nyman <hannu.nyman@iki.fi>
Fri, 6 Nov 2015 12:02:55 +0000 (14:02 +0200)
committerHannu Nyman <hannu.nyman@iki.fi>
Sat, 14 Nov 2015 08:34:09 +0000 (10:34 +0200)
Update rtorrent to 0.9.6.
Update patches.
Disable ipv6 in rtorrent, as ipv6 is disabled also in libtorrent.

Libtorrent compilation has been broken since #1181 got merged
and ipv6 got enabled. Users have seen issues like #1316 and #1804

IPv6 support in libtorrent & rtorrent master is not complete.
Instead there is a separate ipv6 branch, which still needs some
cleanup before mainstream use. See discussion at
https://github.com/rakshasa/rtorrent/issues/59#issuecomment-56651538
So, it makes no sense to use ipv6 with the master branch.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
net/rtorrent/Makefile
net/rtorrent/patches/100-fix-cross_compile.patch

index bba6ddee0153a095cca20c54479f0e19d649d650..596854eba3e4c79b8ec27fb27de8e1bf2ff6e8f1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2013 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rtorrent
-PKG_VERSION:=0.9.4-git-1
+PKG_VERSION:=0.9.6-git-1
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/rakshasa/rtorrent.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=7343e33a6a0d279179b304a380bf011f1c8be64a
+PKG_SOURCE_VERSION:=62cb5a4605c0664bc522e0e0da9c72f09cf643a9
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 
 PKG_LICENSE:=GPL-2.0
@@ -73,7 +73,7 @@ CONFIGURE_ARGS+= \
        --enable-shared \
        --disable-static \
        --disable-debug \
-       $(call autoconf_bool,CONFIG_IPV6,ipv6)
+       --disable-ipv6
 
 ifeq ($(BUILD_VARIANT),rpc)
        CONFIGURE_ARGS += \
index a4213514534022afaaed6b3e53d54dbb87ec98c0..82dcc7648b403412a008b643928bd5af0656d680 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -4,7 +4,6 @@ AC_DEFINE(API_VERSION, 8, api version)
+@@ -4,7 +4,6 @@ AC_DEFINE(API_VERSION, 9, api version)
  
  AM_INIT_AUTOMAKE
  AC_CONFIG_HEADERS(config.h)