adblock: 2.3.0 (package release 2) 3964/head
authorDirk Brenken <dev@brenken.org>
Mon, 6 Feb 2017 16:07:48 +0000 (17:07 +0100)
committerDirk Brenken <dev@brenken.org>
Mon, 6 Feb 2017 16:07:48 +0000 (17:07 +0100)
* update readme regarding unbound integration
* cosmetics

Signed-off-by: Dirk Brenken <dev@brenken.org>
net/adblock/Makefile
net/adblock/files/README.md
net/adblock/files/adblock.sh

index ea968aa696505cee6466b472f44df9dfd1fd077e..2c699678725daea068c4ab74efad633c0286053b 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
 PKG_VERSION:=2.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
 
index f45278d7cbee479de37b692ea67d30c1a3183976..62732e9075d0bf28888dbff583b94be094cc8b48 100644 (file)
@@ -125,12 +125,10 @@ A lot of people already use adblocker plugins within their desktop browsers, but
 
 **change default dns backend to 'unbound':**
 <pre><code>
-switch to 'manual' unbound config in /etc/config/unbound:
-  [...]
-  option manual_conf '1'
+Adblock detects the presence of an active unbound dns backend and the block lists will be automatically pulled in by unbound.
+The adblock script deposits the sorted and filtered block lists in '/var/lib/unbound' where unbound can find them in its jail.
+If you use manual configuration for unbound, then just include the following line in your 'server:' clause:
 
-include adblock lists in /etc/unbound/unbound.conf:
-  [...]
   include: "/var/lib/unbound/adb_list.*"
 </code></pre>
   
index b1396c76f1bf34e0b12b5f2f2248cdb65a62214f..d5989928270fff1f715a39f4c9c6b5f634aba792 100755 (executable)
 #
 LC_ALL=C
 PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-adb_ver="2.3.0"
+adb_ver="2.3.0-2"
 adb_enabled=1
 adb_debug=0
 adb_backup=0
+adb_backupdir="/mnt"
 adb_whitelist="/etc/adblock/adblock.whitelist"
 adb_whitelist_rset="\$1 ~/^([A-Za-z0-9_-]+\.){1,}[A-Za-z]+/{print tolower(\"^\"\$1\"\\\|[.]\"\$1)}"
 adb_fetch="/usr/bin/wget"
@@ -170,26 +171,17 @@ f_rmtemp()
 {
     rm -f "${adb_tmpload}"
     rm -f "${adb_tmpfile}"
-    if [ -d "${adb_tmpdir}" ]
-    then
-        rm -rf "${adb_tmpdir}"
-    fi
+    rm -rf "${adb_tmpdir}"
 }
 
 # f_rmdns: remove dns related files & directories
 #
 f_rmdns()
 {
-    if [ -d "${adb_dnsdir}" ]
+    if [ -n "${adb_dns}" ]
     then
         rm -f "${adb_dnsdir}/${adb_dnsprefix}"*
-    fi
-    if [ -d "${adb_backupdir}" ]
-    then
         rm -f "${adb_backupdir}/${adb_dnsprefix}"*.gz
-    fi
-    if [ -d "${adb_dnshidedir}" ]
-    then
         rm -rf "${adb_dnshidedir}"
     fi
     ubus call service delete "{\"name\":\"adblock_stats\",\"instances\":\"statistics\"}" 2>/dev/null
@@ -386,7 +378,7 @@ f_main()
 
         # basic pre-checks
         #
-        if [ "${enabled}" = "0" ] || [ -z "${url}" ] || [ -z "${src_rset}" ]
+        if [ ! "${enabled}" = "1" ] || [ -z "${url}" ] || [ -z "${src_rset}" ]
         then
             f_list remove
             continue
@@ -444,7 +436,7 @@ f_main()
         fi
         f_log "debug" "loop_2  ::: name: ${src_name}, rc: ${rc}"
 
-        # remove whitelist domains, sort and make them unique, final list preparation
+        # remove whitelist domains, final list preparation
         #
         if [ ${rc} -eq 0 ] && [ -s "${adb_tmpfile}" ]
         then
@@ -465,7 +457,7 @@ f_main()
         f_log "debug" "loop_3  ::: name: ${src_name}, rc: ${rc}"
     done
 
-    # sort block lists
+    # sort/unique overall
     #
     for src_name in $(ls -dASr "${adb_tmpdir}/${adb_dnsprefix}"* 2>/dev/null)
     do