net-snmp: add symlink for net-snmp-config into usr/bin 4484/head
authorPhilip Prindeville <philipp@redfish-solutions.com>
Fri, 16 Jun 2017 23:13:30 +0000 (17:13 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Wed, 21 Jun 2017 17:53:38 +0000 (11:53 -0600)
A lot of autoconf-based scripts expect --with-foo-dir=$(STAGING_DIR)/usr
and break if they can't find bin/foo-config as a child of that path.

Putting things in $(STAGING_DIR)/host/bin seems to be suboptimal; I
could change the install path but there's no saying what that would
break.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/net-snmp/Makefile

index 0fb6a8a34816973c2c306a24d9a8210384e1bf3c..856238eef1c040a2b8c9230742d54b282c3591c8 100644 (file)
@@ -209,6 +209,7 @@ define Build/InstallDev
        $(INSTALL_DIR) $(2)/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/net-snmp-config $(2)/bin/
        $(SED) 's,=/usr,=$(STAGING_DIR)/usr,g' $(2)/bin/net-snmp-config
+       $(LN) $(STAGING_DIR)/host/bin/net-snmp-config $(STAGING_DIR)/usr/bin/
 
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/net-snmp $(1)/usr/include/