JSON4Lua: Add new package 945/head
authorAmr Hassan <amr.hassan@codescalers.com>
Sun, 22 Feb 2015 13:55:07 +0000 (15:55 +0200)
committerAmr Hassan <amr.hassan@gmail.com>
Sun, 1 Mar 2015 13:04:15 +0000 (15:04 +0200)
Signed-off-by: Amr Hassan <amr.hassan@gmail.com>
lang/json4lua/Makefile [new file with mode: 0644]

diff --git a/lang/json4lua/Makefile b/lang/json4lua/Makefile
new file mode 100644 (file)
index 0000000..ff8774c
--- /dev/null
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#  
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=json4lua
+PKG_VERSION:=0.9.53
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://github.com/amrhassan/$(PKG_NAME)/archive/
+PKG_MAINTAINER:=Amr Hassan <amr.hassan@gmail.com>
+PKG_LICENSE=MIT
+
+LUA_MODULE_PATH:=/usr/lib/lua
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/json4lua
+  SUBMENU:=Lua
+  SECTION:=lang
+  CATEGORY:=Languages
+  TITLE:=json4lua
+  URL:=https://github.com/amrhassan/json4lua
+  DEPENDS:=+lua +luasocket
+endef
+
+define Package/json4lua/description
+       JSON and JSONRPC for Lua
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+endef
+
+define Package/json4lua/install
+       $(INSTALL_DIR) $(1)/$(LUA_MODULE_PATH)/json
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/json/json.lua $(1)/$(LUA_MODULE_PATH)/json.lua
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/json/rpc.lua $(1)/$(LUA_MODULE_PATH)/json/rpc.lua
+endef
+
+$(eval $(call BuildPackage,json4lua))