libmicrohttpd: implement build variants -ssl and -no-ssl
[feed/packages.git] / libs / libmicrohttpd / Makefile
index 9f9436467a9f19baa9733b2ea203e15f7a008de9..60b6553f2e76ee7b54f8ff27246d6d2c5560f76c 100644 (file)
@@ -20,30 +20,58 @@ PKG_MAINTAINER:=Martijn Zilverschoon <martijn@friedzombie.com>
 PKG_LICENSE:=LGPL-2.1
 PKG_LICENSE_FILES:=COPYING
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/libmicrohttpd/Default
+   SECTION:=libs
+   CATEGORY:=Libraries
+   TITLE:=GNU libmicrohttpd is a library that runs an HTTP server.
+   URL:=http://www.gnu.org/software/libmicrohttpd/
+endef
+
 define Package/libmicrohttpd
-       SECTION:=libs
-       CATEGORY:=Libraries
-       TITLE:=GNU libmicrohttpd is a library that runs an HTTP server.
-       URL:=http://www.gnu.org/software/libmicrohttpd/
-       DEPENDS:=+libpthread +libgcrypt +libgnutls +libgpg-error
+$(call Package/libmicrohttpd/Default)
+   TITLE+=(with-ssl)
+   DEPENDS:=+libpthread +libgcrypt +libgnutls +libgpg-error
+endef
+
+define Package/libmicrohttpd-no-ssl
+$(call Package/libmicrohttpd/Default)
+   TITLE+=(no-ssl)
+   DEPENDS:=+libpthread
+   VARIANT:=no-ssl
+   PROVIDES:=libmicrohttpd
+   CONFLICTS:=libmicrohttpd
 endef
 
-define Package/libmicrohttpd/description
+define Package/libmicrohttpd/description/Default
        GNU libmicrohttpd is a small C library that is supposed to make it easy
        to run an HTTP server as part of another application.
 endef
 
-CONFIGURE_ARGS += \
-       --enable-https \
-       --with-gnutls \
+define Package/libmicrohttpd-no-ssl/description
+$(call Package/libmicrohttp/description/Default)
+endef
+
+CONFIGURE_ARGS+= \
        --disable-curl \
        --disable-spdy \
        --without-openssl
 
+ifeq ($(BUILD_VARIANT),no-ssl)
+CONFIGURE_ARGS += \
+       --disable-https \
+       --without-gnutls
+else
+CONFIGURE_ARGS += \
+       --enable-https \
+       --with-gnutls
+endif
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
@@ -58,4 +86,9 @@ define Package/libmicrohttpd/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
 endef
 
+define Package/libmicrohttpd-no-ssl/install
+$(call Package/libmicrohttpd/install,$1)
+endef
+
 $(eval $(call BuildPackage,libmicrohttpd))
+$(eval $(call BuildPackage,libmicrohttpd-no-ssl))