pdns-recursor: Update to v4.5.7
[feed/packages.git] / net / pdns-recursor / Makefile
index 381bc28d2b77eb07e26974270c517264621fe800..54ac8c4f53a64e96706dd6302ae9f95108762149 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pdns-recursor
-PKG_VERSION:=4.4.2
+PKG_VERSION:=4.5.7
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://downloads.powerdns.com/releases/
-PKG_HASH:=b0b97f49848a1758b64bc0b99a596c1583ea525477193f3c01905f5163a4f5cf
+PKG_HASH:=ad4db2d4af4630757f786f3719225c2e37481257d676803a54194c7679d07bab
 
 PKG_MAINTAINER:=Peter van Dijk <peter.van.dijk@powerdns.com>
 PKG_LICENCE:=GPL-2.0-only
@@ -16,7 +16,6 @@ PKG_CPE_ID:=cpe:/a:powerdns:recursor
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
-PKG_BUILD_DEPENDS:=protobuf/host
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,7 +25,7 @@ define Package/pdns-recursor
   SUBMENU:=IP Addresses and Names
   USERID:=pdns:pdns
   TITLE:=PowerDNS Recursor
-  DEPENDS:=+boost +boost-context +boost-filesystem +libatomic +liblua +libopenssl +protobuf +libfstrm
+  DEPENDS:=+boost +boost-context +boost-filesystem +libatomic +liblua +libopenssl +libfstrm
   URL:=https://www.powerdns.com/recursor.html
 endef
 
@@ -40,20 +39,18 @@ define Package/pdns-recursor/conffiles
 /etc/init.d/pdns-recursor
 endef
 
+# not everything groks --disable-nls
+DISABLE_NLS:=
+
 CONFIGURE_ARGS += \
        --sysconfdir=/etc/powerdns \
        --with-lua=lua \
        --without-libcap \
        --without-libsodium \
-       --with-protobuf \
        --without-net-snmp \
        --enable-reproducible \
        --disable-silent-rules
 
-CONFIGURE_VARS += \
-       boost_cv_lib_context=yes \
-       boost_cv_lib_context_LIBS=-lboost_context
-
 define Package/pdns-recursor/install
        $(INSTALL_DIR) $(1)/etc/powerdns
        $(INSTALL_CONF) ./files/recursor.conf-dist $(1)/etc/powerdns/